Results 1 to 3 of 3
  1. #1
    Misc. User of PressF1 somebody's Avatar
    Join Date
    Dec 2004
    Posts
    5,198

    Default Volume Shadow Copy Service hangs after resume from standby (Vista)

    I have been using the "Complete PC Backup" utility in Vista (wbadmin.exe) to do differential, whole-disk image backups of my main PC to a remote fileserver. I've also been running them to an external USB hard disk. This backup utility relies on Volume Shadow Copy to take a "snapshot" of the hard disk at a point in time.

    This has been working fine for a number of months, and I have even done a "restore" from one of these backups with great success.

    The problem I'm facing at the moment is, after a fresh install of Vista Business SP1 last Monday, I've found that Volume Shadow Copy will hang, and thereby cause wbadmin to hang. I cannot kill that process, nor can I forcibly restart the Volume Shadow Copy service.

    The same problem occurs when using Cobian Backup 9, as it gets stuck on the step of initiating Volume Shadow Copy.

    Though I haven't been able to conclusively prove it, I believe that the problem occurs after Vista has been resumed from standby mode. A reboot solves the problem (though it requires forcibly powering off, as Vista will not shut down properly).

    Does anyone have any suggestions as to what the problem may be, and how I can deal with it?

    And no, I'm not willing to downgrade to XP, move to Linux, or buy a Mac.
    Any views expressed here are my own and do not necessarily represent the views of my employer or any affiliated 3rd party.

  2. #2
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,681

    Default Re: Volume Shadow Copy Service hangs after resume from standby (Vista)

    Just reading about your problem - have a look in the event viewer, and see if there are any errors about "Volume Shadow Copy" being turned off.

    If it is, go into the services and make sure its running.

    And no, I'm not willing to downgrade to XP, move to Linux, or buy a Mac.
    Nicely Put.

  3. #3
    Misc. User of PressF1 somebody's Avatar
    Join Date
    Dec 2004
    Posts
    5,198

    Default Re: Volume Shadow Copy Service hangs after resume from standby (Vista)

    Thanks Wainuitech. Each time the error has occurred, I've gone into services.msc to check that it is running, and it has been.

    There are a few entries in Event Viewer concerning Volume Shadow Copy (VSS), however they are not errors as such - rather responses to me trying to restart the service.
    Any views expressed here are my own and do not necessarily represent the views of my employer or any affiliated 3rd party.

Similar Threads

  1. Replies: 3
    Last Post: 08-07-2008, 07:16 PM
  2. Replies: 14
    Last Post: 03-05-2008, 08:05 AM
  3. Replies: 26
    Last Post: 03-02-2003, 06:15 AM
  4. Normal service will resume shortly
    By robo in forum PressF1
    Replies: 38
    Last Post: 23-06-2002, 09:12 AM
  5. Cannot resume from standby
    By in forum PressF1
    Replies: 0
    Last Post: 22-09-2000, 08:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •