Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    dudess_on_a_mish
    Guest

    Default Linux: Unable to access disk (CD drive)

    I am trying to add some more applications in Fedora Core 2 via Package Management in KDE but when I press OK after inserting Disk 2 of the installation CD I get the message "Unable to access disk - The disk was unable to be accessed for reading. Please confirm that it is in the drive and try again".

    This is strange because when the disc is put in the CD drive a Konqueror window opens with the contents of the CD displayed.

    I had the same problem in Fedora Core 1 and the only way I could add more apps was to reinstall Fedora and I don't particularly want to do that again.

    Anyone have any ideas please? I can't find any info on this on Google.

  2. #2
    Graham L
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    I don't like the OS automounting the CD when it's inserted. ;-)

    That might be the problem. Try making Konqueror release the drive so the package manager can grab it.

    Or have a look at /etc/fstab ... make sure the entry for the CD has "users" in its options column.

  3. #3
    dudess_on_a_mish
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    > Or have a look at /etc/fstab ... make sure the entry for the CD has "users" in its options column.

    Thank you Graham, that did the trick. :-)

  4. #4
    dudess_on_a_mish
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    Unfortunately I still have this problem. :-(

    > Try making Konqueror release the drive so the package manager can grab it.

    Can you explain how to do that, please? In simple terms, preferably....

  5. #5
    Graham L
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    Umm. ;-) I still don't like the system mounting things automatically.

    Open a terminal window (as root). Then you can type umount /mnt/cdrom . You might try repeating that a couple of times, until it says it's not mounted. (I've had the mount[ command show the CD mounted several times. :-( )

    The programme installer will complain and retry until it manages to grab the CD itself. I hope. ;-)

    If it asks for other disks, this will probably happen again and it will pay to keep the terminal open. I suppose you swear and kill the Konqueror window each time it happens.

    This is what happens when well-meaning enthusiasts try to make things user-fiendly and "like Windows". :_|

  6. #6
    dudess_on_a_mish
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    OK, I'm getting somewhere.... sort of. ;-)

    Somehow or other I managed to update some packages when the PC was booted with CD#2 in the drive but then couldn't eject it for CD#3 without doing the umount thing -- then it repeated its complaint about being unable to access the disc. Doing the umount thing a few times didn't make an impression so I am back to square one again.

    This is becoming a long, slow and painful process. Swearing and killing the Konqueror window makes no difference whatsover. :-(

    >This is what happens when well-meaning enthusiasts try to make things user-fiendly and "like Windows".

    What is your recommendation?

    I don't have to have autorun (it is disabled in Windows). If I remove autorun or whatever from /etc/fstab what are the consequences? How will I be able to run/access CDs? Will I need to mount them manually at each session?

    I am not scared of the command line as long as I know what to type and where/when I have to type things. :-)

  7. #7
    Graham L
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    I much prefer to mount disks myself. I think I know what I'm doing. I don't trust software to know what I'm doing.

    All you have to do is mount /mnt/cdrom or umount /mnt/cdrom. You hardly ever have to mount a floppy, because the mcopy, mdir, etc commands seem to work directly on the hardware device. mount tells you what is mounted.

    Taking out the "automount" should stop it happening. There is a service running to recognise the changed disk so it's probably a good idea to stop that from running. But I don't know off hand what it's called. ;-)

  8. #8
    dudess_on_a_mish
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    OK, I don't think it will be a problem to mount the drives myself. From the /etc/fstab contents copied below, would I remove the entire lines for the CD drives? As you can see it has "noauto" in there - I thought that disabled the autorun?
    [pre]
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hda3 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom udf,iso9660 noauto,users,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
    /dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,users,kudzu,ro 0 0
    /dev/hdb1 /mnt/data vfat auto,umask=0 0 0
    /dev/hdb6 /mnt/music vfat auto,umask=0 0 0
    [/pre]

  9. #9
    Graham L
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    You could, but it makes work. You'd have to do mount -t auto /dev/cdrom /mnt/cdrom or worse. The "kudzu" says the entry was made by kudzu --- the "checking for new hardware" at startup. (kudzu might just replace the entries if you took them out. ;-) )

    If you have an entry in fstab, you can say "mount /dev/cdrom" or "mount /mnt/cdrom" -- either will do -- that is, either the -device- or the -mountpoint- will do.

    The "noauto" just tells the system not to mount at boot time (because there might not be a CD there to mount. The other disk drive have to be mounted at boot time.

    I thought there might have been an "automount" option so you might have to find and stop the service. Taking out the "kudzu" option might have the effect we want ...

    By the way, if one of your CD drives is a writer, it might not work with the "ro" (read-only) option. ;-)

  10. #10
    dudess_on_a_mish
    Guest

    Default Re: Linux: Unable to access disk (CD drive)

    Hmm, plenty of food for thought there Graham, I'll give it some consideration before deciding what to do. You have clarified a few matters for me which explains some things that I didn't know.

    I have finally bashed the package updater into submission and have added all the packages I require. It might think twice before attempting to tell me who is boss next time. ;-)

    Many thanks for all your help, it is much appreciated. :-)

    [pre]Now, moving on to the next mission....[/pre]

Similar Threads

  1. Unable to access slave hard drive.
    By withersn in forum PressF1
    Replies: 19
    Last Post: 13-02-2004, 08:34 PM
  2. How do I access a second CD-ROM drive in Linux?
    By forrest44 in forum PressF1
    Replies: 8
    Last Post: 09-04-2003, 03:16 PM
  3. random floppy disk drive access
    By in forum PressF1
    Replies: 3
    Last Post: 03-06-2002, 07:44 PM
  4. Unable to Open Photos on Disk
    By in forum PressF1
    Replies: 4
    Last Post: 20-02-2002, 12:43 AM
  5. Unable to access hard drive
    By in forum PressF1
    Replies: 0
    Last Post: 15-10-1999, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •