Results 1 to 9 of 9
  1. #1
    george12
    Guest

    Default SUWIN caused Segment Load Failure

    When I try and install Windows 98, I get the problem,

    -----------------------------------------------------------------------------------
    Application Error

    SUWIN caused Segment Load Failure in module SUWIN.EXE at 0004:7624.

    [Close]
    -----------------------------------------------------------------------------------

    I have tried 2 different copies of Win98. The first, the error appeared while 'preparing to copy files', the other just after 'select directory' (when I clicked next it appeared). What can I do about this?

    My PC is a Digital PC 3000, with 128MB of RAM (2 x 64MB 168-pin), and an MMX P233 chip. I have a network card and sound card, both PCI installed. I am installing of a 48X cd-rom drive.

  2. #2
    Babe Ruth
    Guest

    Default Re: SUWIN caused Segment Load Failure

    george12,

    Have a read of the following MS KB articles Here and Here for some advice.

    Note that SUWIN is the protected-mode Setup component(s) responsible for calling all other dynamic link libraries (DLLs) used in Setup.

    Cheers, Babe.

  3. #3
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    NEW MESSAGE

    This time it's when it's just as it moves into 'Collecting information about your computer', and the message is:

    -----------------------------------------------
    [-] Setup
    -----------------------------------------------

    Message SU995003

    Setup cannot load a required library.
    (0x138b)

    -----------------------------------------------

    I'm just reading your KB articles now.

  4. #4
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    I'm following the KB advise now. The PC really crawls when you start disabling caches. I'm doing setup with 216 mins to go.

  5. #5
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    Hi guys. 2 hours 25 min later and it's just finished copying files. I am running a memory test to see if that was the problem.

  6. #6
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    hey, I think I know what could be the problem: on the mem test it says:

    L1 Cache - 16K 175MB/s - fine
    L2 Cache - Unknown - problem?

    In the BIOS I have options for Internal and External cache. Are these just different names for L1 and L2? I reckon disabling the L2 cache would fix the thing, but you guys know best. I have of course ruled out all the cards and stuff by taking them all out. The memtest is now at 72%, so I will continue installing windows soon.

  7. #7
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    OK, the story is, I know the cache is the problem, because it works when I disable the cache. I think I need to disable the L2 cache. Am I right? If I am, then which is L2, external (memory) or internal (cpu)?

    Sorry for posting so many consecutive comments.

  8. #8
    Babe Ruth
    Guest

    Default Re: SUWIN caused Segment Load Failure

    george12,

    The level 2 cache for the Intel 233MMX CPU was on the intel motherboard and was usually 256 KB - 512 KB, So I guess that's the external cache you are talking about.

    Cheers, Babe.

  9. #9
    george12
    Guest

    Default Re: SUWIN caused Segment Load Failure

    no, it was the internal (cpu) cache. sadly, that is the one that makes it run incredibly slow. Would sticking in a new cpu fix the problem? Because I have a few only slightly slower (200, 166 & 133).

Similar Threads

  1. VPN - problem with same segment
    By Geek4414 in forum PressF1
    Replies: 5
    Last Post: 08-10-2008, 01:02 PM
  2. Climate change caused by man ?
    By wmoore in forum PC World Chat
    Replies: 460
    Last Post: 04-03-2008, 08:19 PM
  3. How to cut a segment of an audio file?
    By Greg in forum PressF1
    Replies: 1
    Last Post: 29-09-2006, 10:00 AM
  4. directsound test failure results Failure at step 19
    By Dead_in_the_water in forum PressF1
    Replies: 5
    Last Post: 22-12-2005, 03:19 PM
  5. Network link load failure
    By Bolta in forum PressF1
    Replies: 8
    Last Post: 08-03-2003, 10:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •