Page 1 of 2 12 LastLast
Results 1 to 10 of 18
  1. #1
    Chilling_Silently
    Guest

    Default Linux pt. 1 - Watching a DVD

    I have now got sound with Xine, so I thought why not put in a looney tunes DVD I have (Yes.. Im just starting off... ) and see if it works. I could select certain parts (There were 5 odd files) and play them fine (They ended in .VOB I think), but there was no sound coz the sound is in a different folder.

    Anyways - I tried to use the DVD function on Xine - but no luck.

    So.. How would I go about setting up DVD Playback in Linux (RedHat 8). It reads the DVD fine, plays the parts of it fine, only theres no sound coz its in a different folder :-)

    Cheers


    Chilling_Silence

  2. #2
    Chilling_Silently
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    <bump>

    Anybody have any ideas?

    We have working:
    Video
    or
    Sound
    but not
    Both
    why
    Because the sound/vid files are located in a seperate folder, and only one works at a time, sound or vid but not both!

    Any idea's people?

    Cheers


    Chilling_Silence

  3. #3
    Graham L
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    The May PC Authority has an article on nice things for Linux. There is a specific mention that Xine as distributed by Red Hat does not handle encrypted DVDs. Have a look at FreshRPMS for a replacement which does. The article also recommends ALSA for sound rather than OSS. Same place.

  4. #4
    tweak\'e
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    <bump> (no i'm not trying to ad to my post tally.....honest ;-))

  5. #5
    Chilling_Silently
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    Thanks Tweak'e

    And Ive currently got no ALSA working on Xine, so tough luck there...

    Ive downloaded and installed Ogle DVD player, with the DVDcss rpm's and what-not.. it plays.. just a little jerky on the video.. doing a noticable skip once every 3 or so seconds


    Any ideas?

    And I cant change the nice value either?

    It just hangs...


    Cheers


    Chill.

  6. #6
    Chilling_Silently
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    Okay...
    OMS doesnt work..
    Ogle still plays it, but skips once every 2-3 seconds...
    VideoLAN Client will skip once every 1 1/2 seconds...
    Xine just wont play it (I think I need the plugin for Xine) at all!

    Ive tried increasing the Nice for the apps (Which freezes if Im my user, so to change the Nice value I have to be root) but that makes precious little difference, if any.

    It plays like an under-powered PC might play it, skipping frames and audio too.

    What might have gone wrong?
    Other than that, VideoLAN Client is a great media player :-)

    Thanks


    Chill.

  7. #7
    rsnic
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    the problem with rh8 is that dma is not enabled by default on ide drives, to stop it from being jerky enable dma as root.
    /sbin/hdparm -d1 /dev/hdb ---- make sure you get the right device

    try ogle to see if it still skips, if it doesn't you enabled dma on the correct device
    to get this to work every time you start the computer
    edit /etc/rc.d/rc.local and add the above line in the script. This script is executed every time your computer starts

    Once its working sweet i recommend you try mplayer to view dvd's i think its better, or use the goggles gui for ogle.

  8. #8
    Chilling_Silently
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    Okay, Thanks.

    I'll give that a shot and let you know how I get on.

    BTW - Im kinda hooked now on VideoLAN Client.. Very Nice and Clean too!

  9. #9
    Chilling_Silently
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    Err.. It didnt work

    I tried hda (My DVD drive is that for some reason.. my C: in doze is hdb1 then hdb5... not 100% sure but I think that the DVD Drive must be Primary Master)

    tried /dev/cdrom too, and /dev/dvd and all 3 came up saying it couldnt do it and would set it to DMA off (dma=0).

    This was done in a terminal after typing:
    # su -
    password:
    and then the jazz i was instructe to type.

    I even edited the file and added the line you mention, but no joy

    Is there another way to do it?

    Cheers


    Chilling_Silence

  10. #10
    rsnic
    Guest

    Default Re: Linux pt. 1 - Watching a DVD

    It is pretty much certain that dma being not enabled is causing the skips, some older motherboards and drives may not support direct memory access. A list of ide drives and device names can be found in /proc/ide/ and information about it can be found in its corresponding directory. Put a dvd in the drive and test each device listed there with /sbin/hdparm -tT /dev/[device]
    see which ones engage the dvd-rom when testing starts
    then try to enable dma for the device that is the dvd
    do ctrl-alt-f1 and login as root that way, my terminal sometimes doesn't display man pages properly which you should check out especially look at the hdparm -i and determine what dma mode the drive prefers.

Similar Threads

  1. Watching The Heptathlon?
    By SurferJoe46 in forum PC World Chat
    Replies: 0
    Last Post: 27-08-2007, 06:09 AM
  2. Trying to watching TV DVD on computer
    By asdex in forum PressF1
    Replies: 4
    Last Post: 09-04-2007, 01:37 PM
  3. Watching dvd on my computer lag
    By jevon in forum PressF1
    Replies: 12
    Last Post: 22-08-2006, 12:33 AM
  4. Watching H.264 on WinXP
    By sal in forum PressF1
    Replies: 6
    Last Post: 08-06-2005, 01:09 AM
  5. Watching DVD on TV
    By Bobdobalino in forum PressF1
    Replies: 1
    Last Post: 19-03-2004, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •