Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Nigel Thomson

    Default linux redHat 5 modem not detected

    16Mb Ram
    540Mb harddrive
    pragmatic telepermit says(h56rsp-AO) board says (h56rsn-AO)
    i believe it is a hardware modem as the big chip(rockwell) says
    RCVDL56ACF/SP with ACF being for hardware modems
    >>Sams teach yourself Linux in 24 Years
    i have installed RH5 on the above machine but am unable to get the modem to respond at all
    i have kind of hit a brick wall i am unsure if how to configure my serial ports and the howtos assume a knowledge i don't have, what i have found is that when i run dmesg it tells me something to the effect that i have a serial driver with no serial options enabled, i don't know what this means.
    I also can't test my modem by typing the
    echo "ATDT***-****/n" >/dev/cua1(ihave tried 0-3 and got no response)
    the other thing is using the dmesg command i can't find any mention of ppp and according to the book I need to recompile the kernel to do this, but again i have no idea how to do this
    I am using redhat 5 because it is small enough to fit onto my machine all other versions i have are apparently too big RH 7.1,Mdk 8./,9
    I really only want the machine to be able to do a web browsing, email etc
    I am trying to this on a budget of nothing and my only means of transferring data is floppy or CD and no i am not going to down load 80 slackware floppies, i don't have a CD burner so all file suggested for me to download will need to be floppy sized.
    >thanks for any help you can give
    sorry its so long but I am trying to put in all the info i can think of that will be useful

  2. #2
    Graham L

    Default Re: linux redHat 5 modem not detected

    Don't give up. My first installation was on a 386SX-20 with a 40MB disk and 6MB of RAM. (That's 40 megabytes, not gigabytes of disk). I made floppies on a friend's machine.

    There's no easy way to learn ... it's like anything. You will find the HOWTOs more understandable as you get into it. Have a browse through the links I have given in FAQ80. Especially read the Hardware-HOWTO, and Winmodems-HOWTO, and the Getting Started manual.

    Modem: It's a plugin card, so we call it a winmodem (internal), not a "hardware" one. A "hardware" one is plugged into a serial port on the the back of the box. ;-) Is it ISA or PCI? Has it got jumpers to set its IO address and IRQ? dmesg will probably show that you have two serial ports ... /dev/cua0 and /dev/cua1. These are the ones which have DB connectors on the back. You might have a mouse on one of them. An internal modem will need to be set to not interfere with a "real" serial port. If you are using "COM1" (/dev/cua0) you would set the modem to be "COM4" (/dev/cua3 ... see the different numbering?). Look at the site for information on "winmodems". If you have a BIOS option to disable the onboard serial ports, try that and see if the boot (or dmesg) shows the modem as a serial port. . That will show if it is colliding with the others.

    Including PPP: Compiling the kernel is not too difficult. If you have the sources and compilers -- the "development" package, cd to /usr/src/linux and type "make menuconfig". (You'll need to be root for this). Just work through the prompts. You can get help at each question. You will make mistakes. ;-) It doesn't matter. You can try again. When you have done the configuration, you need to do "make dep", and "make zImage", (and maybe "make modules" and "make module_install"). There's a HOWTO on Kernel, too. With 16MB, the compile will take a while ... maybe an hour or so. You'll see lots of messages as it works. It might be a good idea to just copy the new kernel to a floppy rather than putting it to the normal boot place. "find ./ -name zImage" will locate it, or you will see the path in the last few messages as it is compressed. If you cd to that directory you can do "dd if=zImage of=/dev/fd0 bs=72k" with a blank floppy in the drive will make it into a bootable floppy.

    It's great fun. Keep notes as you go. Don't feel terrible if you "break" it. You can reinstall it ... which is often much quicker than trying to fix it.

  3. #3
    Dolby Digital

    Default Re: linux redHat 5 modem not detected

    You can get "hardware" internal modems. My Red Hat box has one (although I currently use my external modem!). My quide is that if the modem has no irq/com jumpers, then its most likely a winmodem.

  4. #4
    Graham L

    Default Re: linux redHat 5 modem not detected

    I was keeping it simple ;-) ... An ISA internal will probably be a "hardware equivalent". My guide is the number of chips. If it's only got one or two chips, it's a winmodem.

    The important first step is to get the modem's "serial port" recognised and set up with a suitable address/IRQ. It might well work straight away afetr that.

  5. #5
    Nigel Thomson

    Default Re: linux redHat 5 modem not detected

    Well my modem is apparently an internal hardware one, refers to it as a "real" Modem
    and modemsite also refers to it as a hardware controller thing, so my new question is
    Why wont linux pick it up, I have been singularly unsuccessful in tracking down this particular modem, but have found that about half the other modems (from various manufacturers) have jumper settings, how do I go about figuring out which is what etc.
    Thanks for anyhelp you can offer.
    ps what is a good price for a second hand HD ie one larger than 1 gig as I have a feeling RH 5 might be a bit unsuitable for future expansion
    cheers Nigel.

  6. #6
    Nigel Thomson

    Default Re: linux redHat 5 modem not detected

    Whoops I meant to say it is hardware as it has the ACF chipset rather than the HCF or HSF.

  7. #7
    Graham L

    Default Re: linux redHat 5 modem not detected

    First: has it got any jumpers? If so, what are they labelled?

    If not, it might be an ISA pnp device. :-( There is a module called isapnp, but I don't think I've used it ... my gear is too old for that .

    Have you got a DOS/Win machine handy you can plug it into? It might be faulty ... that is not unknown. ;-) If it works (with AT commands), you should be able to see what its IRQ and address are with MSD or the Windows hardware thingy.

    Is PNP enabled in the BIOS? If not, turn it on. If it's on, turn it off. ;-)

  8. #8
    Nigel Thomson

    Default Re: linux redHat 5 modem not detected

    yes it does have jumpers the settings read as the following

    Com1: 2,4,6 ON IRQ3: 1 ON
    Com2: 1,5,6 ON IRQ4: 2 ON
    Com3: 2,4,7 ON IRQ5: 3 ON
    Com4: 1,5,7 ON IRQ7: 8 ON

    it appears to be set up for Com4

    unfortunately i don't have a windows machine to test it in

    Do I need to set an IRQ and if so How? as there is only one set of pins on the Card
    Thanks for the help so far it has given me a few more things to try out

  9. #9
    Graham L

    Default Re: linux redHat 5 modem not detected

    I'd be inclined to connect it as COM3, assuming that you have two normally there (COM1 & COM2). It should be smart enough to handle a "gap" in the sequence, but we''l make no assumptions. If you have only one "normal" COM port, make it COM2. If you have none, make it COM1 .

    It has to have an IRQ. 5 should be OK for COM3, because Linux has tended to not use interrupts for parallel printers because of the flakey implementation by IBM (in 1981). If You have only one (or none) COM ports, give the modem 3, or 4. (COM1 uses 4, COM2 uses 3).

    It ought to show as the Linux boots. Or on the output from dmesg (which is the same). You should be told the IRQ and address detected.

  10. #10
    Nigel Thomson

    Default Re: linux redHat 5 modem not detected

    seriel driver version 4.13 with no seriel options enabled
    tty00 at 0x03f8 (irg = 4) is a 16550A
    tty01 at 0x02f8 (irq = 3) is a 16550A
    tty02 at 0x03e8 (irq = 4) is a 16550A
    Does this nean there is a conflict between com1 & 3
    the lKernel version is 2.0.32

Similar Threads

  1. Linux Redhat 9
    By Crazkilla in forum PressF1
    Replies: 3
    Last Post: 04-11-2003, 02:48 PM
  2. RedHat external modem
    By Tamihana in forum PressF1
    Replies: 3
    Last Post: 25-06-2002, 11:39 AM
  3. Modem not detected
    By in forum PressF1
    Replies: 2
    Last Post: 13-06-2002, 05:49 PM
  4. Modem not detected
    By in forum PressF1
    Replies: 4
    Last Post: 26-05-2001, 07:32 PM
  5. Linux RedHat & CD-ROM
    By in forum PressF1
    Replies: 0
    Last Post: 03-07-1999, 12:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts