Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Aaaarrgggghhh: Gimme my OpenGL back

    Thanks to the kids installing a 1997 vintage kids game on my PC yesterday, my OpenGL has gone west.

    I've downloaded and installed the latest Detonator drivers for my GeForce2 card, and the install process appears to have worked. No driver conflicts reported - nvopengl.dll is sitting in Windows/system on my ME installation.

    But OpenGL aint a happening thing. If I fire up Half-Life I get the message that the selected OpenGL mode is not supported - indicating that the OpenGL component of the video drivers has not correctly installed (I have not changed my HL video mode at all from it's working state before I went to work yesterday).

    So I've uninstalled and reinstalled the video drivers several times now without success. I've even tried reinstalling DirectX, since this is probably what the old game screwed with.

    According to both the Nvidia site, and past experience, I should have tabs for OpenGl and Direct3D under the Additional Properties button of the display adpater - but these tabs are not there. However, I note that they are also not there on my Win2000 machine at work, so it may be that these tabs are no longer installed with the Detonator drivers.

    Anyone got any ideas beyond the obvious (uuuggghhh) - reinstall Windows?

  2. #2
    John Grieve
    Guest

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back


  3. #3
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    Thanks John. Will try that out.

  4. #4
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    Hmmm, doesn't seem to be a very recent version around.

  5. #5
    John Grieve
    Guest

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    You say you have nvopenGL.dll but is there also a openGL32.dll? See if it exists in any of the game folders and move a copy to the system folder if it is then try it. If that fails try the following.

    Another thing that can help is to reset your drivers to standard VGA drivers then reboot (do not let windows install any new drivers yet) and clean out the .inf file in the Inf/Other folder that relates to the Nvidia card then if you are happy with editing the registry then also go into HKey/Local machine/Software and remove the NVidia corporation key in its entirety then reboot let the card be detected and install the latest detonator drivers.

  6. #6
    kiwibeat
    Guest

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    theres a thing called detonator out there that removes all traces of graphics drivers
    http://www.guru3d.com/detonator-destroyer/

  7. #7
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    No luck so far - tried Det Destroyer, cleaning out old drivers and reinstalling etc etc. I have managed to get back the OpenGL tab (and other tabs) under Additonal Properties for the GerForce2 adapter, but even though it happily lets me change settings for OpenGL there, HL refuses to beleive that my card supports OpenGL.

    Going to have to go editing in registry now .......

  8. #8
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    ... oh and I checked John's suggetsion and there is alreday a copy of opengl32.dll in Windows/System. Going to try a complete registry purge of nvidia . . . .

  9. #9
    Hun Hunter Biggles's Avatar
    Join Date
    May 1988
    Location
    In the air
    Posts
    2,732

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    Well that was annoying but I've finally fixed it, thanks to a previous post I found on the opengl.org forums.

    Turns out that the old kids program that was installed must have written something into good old win.ini.

    I've yet to find out which entry was the culprit, cause it's late and I need to go to bed, but I tested it by simply renaming win.ini. On failing to find win.ini on restart Windows simply created a new, clean one, and boom, I'm back in business.

    I'll have to locate the offending entry so I can restore anything in there I need (although maybe I'll just see how my new clean win.ini goes first) but it is amusing that for all the "sophistication" of having a Windows registry the lame old Win 3.x win.ini can completely screw registered and installed components. Don't you love backward compatibility?

  10. #10
    John Grieve
    Guest

    Default Re: Aaaarrgggghhh: Gimme my OpenGL back

    If you can be bothered Bruce I wouldn't mind knowing what that setting in Win.ini is for future reference. I still install and play the odd older game and while I have never seen anything like that before its inevitable I or one of my friends will. Thanks. To tell you the truth the detonator destoyers usually clear up graphics issues like this so I was not sure what to suggest next. I was also under the impression that ME attempted to prevent things like this (tampering with win.ini sys.ini msdos.sys etc by program installs) anyway.

Similar Threads

  1. OpenGl
    By habib in forum PressF1
    Replies: 2
    Last Post: 17-02-2005, 07:54 PM
  2. OpenGL
    By jferg in forum PressF1
    Replies: 9
    Last Post: 25-02-2003, 11:04 PM
  3. OpenGL + XP
    By in forum PressF1
    Replies: 0
    Last Post: 18-06-2002, 12:50 PM
  4. OpenGL + XP
    By in forum PressF1
    Replies: 0
    Last Post: 18-06-2002, 12:46 PM
  5. GIMME THE EMAIL PROGRAM I WANT
    By in forum PressF1
    Replies: 0
    Last Post: 06-06-2001, 12:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •