Results 1 to 8 of 8
  1. #1
    Junior Member
    Join Date
    Apr 2005
    Posts
    87

    Default No USB working .... originally posted 26/03/2021

    Hi all ..

    Been a while since I've been on the forum and still have the problem of no USB working. Going back to the original thread, I've been able to get into both Windows 10 and Linux Puppy by using PS2 keyboard only ... unfortunately the mobo has a dual mode PS2 input which allows either a mouse or keyboard to be used, but not both at once.

    I think this happened when a faulty USB 3.0 cable from an external backup drive - all HD's are OK as far as data goes, just need to either get the USB ports working or replace the mobo ... it's 6th generation 1151 which are still available.

    Device manager is showing a Code 10 error (device cannot start) on USB controllers. Reading some of the possible fixes forum members have suggested and doing a bit of reading, it could be corrupt drivers and a clean install of Win10 has been suggested. I've tried a Win10 repair disc without success, but I do have a 250GB SSD drive I could put in and do a clean install.

    I'm at a stage where I'm going around in circles and would appreciate some more advice.

    Is it worth putting the SSD in and do a clean install ?? Replace mobo ?? Or can someone give me a step by step method of checking whether it's drivers or stuffed mobo ??

    Any help would be appreciated !! mobo is Gigabyte GA-H170-HD3 with i5 ... a few years old, but it does what I need it to.

    TAI SP8's

  2. #2
    Enterprise IT Consultant chiefnz's Avatar
    Join Date
    Dec 2004
    Location
    Sydney AU
    Posts
    1,708

    Default Re: No USB working .... originally posted 26/03/2021

    If you have a spare disk, try a fresh install of Windows... if the error persists then it could be a sign that there is an issue with the hardware....

    Ryzen 5 5600X
    Gigabyte X570 Aorus Pro Wi-fi
    Corsair Hydro H100x
    32GB DDR4 @ 3200MHz
    WD 512GB M.2 PCI-E 4 NVMe
    WD 1TB M.2 PCI-E 4 NVMe
    Gigabyte RTX 2060 OC
    Corsair 4000D Airflow
    Corsair RMx 850W

  3. #3
    VoidMaster
    Join Date
    Dec 2004
    Posts
    6,485

    Default Re: No USB working .... originally posted 26/03/2021

    Plug a usb battery pack into one of the usb ports and see if it charges, or use a usb powered flashlight or a speaker set and see if they work, this will test that there is power on the usd port, ie 5 volts, likely that the faulty cord blew the 5volt fuse resistor on the motherboard leading to the usb ports.
    It's not the least charm of a theory that it is refutable. The hundred-times-refuted theory of "free will" owes its persistence to this charm alone; some one is always appearing who feels himself strong enough to refute it - Friedrich Nietzsche

  4. #4
    Junior Member
    Join Date
    Apr 2005
    Posts
    87

    Default Re: No USB working .... originally posted 26/03/2021

    Quote Originally Posted by zqwerty View Post
    Plug a usb battery pack into one of the usb ports and see if it charges, or use a usb powered flashlight or a speaker set and see if they work, this will test that there is power on the usd port, ie 5 volts, likely that the faulty cord blew the 5volt fuse resistor on the motherboard leading to the usb ports.
    Hi zqwerty ... probably should have said that all USB ports were checked with a good multi-meter and voltages on all USB ports were OK @ 5v. It's definitely on the data side of things.

    Chiefnz ... On the SSD drive ?? I don't want to risk stuffing up the data on the old C drive as some (most) of it isn't backed up.

  5. #5
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,502

    Default Re: No USB working .... originally posted 26/03/2021

    What you can try, download macrium Reflect on a working Computer - https://www.macrium.com/reflectfree make a bootable CD Boot from that on the suspect PC, straight away that will tell you if its hardware or software as the USB ports should work from the CD if its software related, if still not working theres a hardware problem -- NOW image the whole drive to someplace. This way you have a backup of the current setup.

    Then as long as you have at least a working mouse Option ( a PS2 mouse will work fine if usb are not available), open the device manager - Select the USB Controllers and delete them, on a reboot they should reinstall.

  6. #6
    Junior Member
    Join Date
    Apr 2005
    Posts
    87

    Default Re: No USB working .... originally posted 26/03/2021

    Thanks Wainui ... I'll let you know what the outcome is. That said, I'm pretty sure it's a hardware problem and a new mobo, even though well out of date, is going to be the best solution for me ... $150 v Section 8

  7. #7
    amateur expert dugimodo's Avatar
    Join Date
    Dec 2005
    Posts
    8,126

    Default Re: No USB working .... originally posted 26/03/2021

    or you could just get an add in usb card something like this https://www.pbtech.co.nz/product/IDE...-Add-On-card-w

    Providing you are happy the motherboard is otherwise ok.
    Ryzen 2700X, 16Gb DDR4RAM, 512GB M.2 NVME SSD, MSI GTX1070

  8. #8
    VoidMaster
    Join Date
    Dec 2004
    Posts
    6,485

    Default Re: No USB working .... originally posted 26/03/2021

    Although the usb ports seem to be not working, can you plug in a keyboard or mouse and see if they are operational?

    I came across this program and wondered if perhaps someone had used it on the motherboard:

    https://www.majorgeeks.com/files/details/no_usb.html
    It's not the least charm of a theory that it is refutable. The hundred-times-refuted theory of "free will" owes its persistence to this charm alone; some one is always appearing who feels himself strong enough to refute it - Friedrich Nietzsche

Similar Threads

  1. Windows Update 15 Jan 2021
    By Brucem in forum PressF1
    Replies: 11
    Last Post: 20-01-2021, 04:50 PM
  2. Don't Know If I Posted This B4 Or Not -------
    By SurferJoe46 in forum PC World Chat
    Replies: 2
    Last Post: 02-11-2010, 05:18 PM
  3. Don't Know Whether This Has Been Posted Before.
    By Trev in forum PC World Chat
    Replies: 10
    Last Post: 18-10-2009, 12:16 PM
  4. About the FAQ I just posted
    By Chilling_Silence in forum PressF1
    Replies: 0
    Last Post: 04-12-2002, 10:51 AM
  5. Ya! I posted first!
    By in forum PressF1
    Replies: 1
    Last Post: 01-01-2002, 12:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •