Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Older by the minute
    Join Date
    Dec 2004
    Location
    Whitford
    Posts
    1,786

    Default Video playback sound - help please.

    I have a problem on some film and youtube clips. I do have sound but not the main performers. ie, background vocals and music but not the principal. I have the app set for Film and TV.

    I have downloaded VLC, same problem. I have found that I can get results using MPC-HP64 (built in version with K-Lite codecs program) on both my test clips. When I revert back to the Film & TV app, same old problem. I would have thought that Windows 10 and VLC would have been able to play these files without K-lite.

    Can I somehow change the file association for Film & TV to overcome the problem.

  2. #2
    amateur expert dugimodo's Avatar
    Join Date
    Dec 2005
    Posts
    8,143

    Default Re: Video playback sound - help please.

    Might be to do with surround sound and your speaker settings, maybe the players think you have a centre channel and you don't?
    I think VLC has an option to output in stereo for surround sound tracks, might be worth a try to confirm if that's the issue. Setting your sound device for stereo mode might be the solution if it's not already.

    File associations are easy, except I have no access here to confirm the steps - go to settings, apps, default apps, scroll down to the category you want, click on the player it shows now, and choose a different one from the drop down list that should appear. I might not have the steps exact but it's something like that. Alternatively, hit the start button and type default apps and start from there.
    Ryzen 2700X, 16Gb DDR4RAM, 512GB M.2 NVME SSD, MSI GTX1070

  3. #3
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,683

    Default Re: Video playback sound - help please.

    Have the same problem with Netflix, sometimes the audio is not right, using the App, so open in FF and its fine.

    To change the default player you can either right click a file - Open with - Select the Player you want, bottom left should be a box to change it to open that program every time, OR go into Default Apps - select the app to change and a list appears.

    Been using potplayer lately, works quite well on all media files. https://daumpotplayer.com/download/

  4. #4
    Older by the minute
    Join Date
    Dec 2004
    Location
    Whitford
    Posts
    1,786

    Default Re: Video playback sound - help please.


  5. #5
    Wrinkly Member! B.M.'s Avatar
    Join Date
    Dec 2004
    Location
    Mount Maunganui
    Posts
    8,278

    Default Re: Video playback sound - help please.

    And now for the Excuses.
    Global Warming is Mann made.

    Do not regret growing older. It is a privilege denied to many.
    .
    The problems we face today are because the people who work for a living are now outnumbered by those who vote for a living.

  6. #6
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,683

    Default Re: Video playback sound - help please.

    Quote Originally Posted by B.M. View Post
    And now for the Excuses.
    Theres two problems with that comment ( as per usual not knowing facts)

    Youtube uses HTML5 mainly https://www.youtube.com/html5
    Many YouTube videos will play using HTML5 in supported browsers. You can request that the HTML5 player be used if your browser doesn't use it by default.
    BROWSERS use html.

    So its NOT the inbuilt media players doesn't matter which OS is used.

    2nd - Bryan simply stated
    I have a problem on some film
    Thats wide open, What type of Film ?, Are they pirated, own created, supplied by whom ever ?? you dont know how the person who created them actually encoded, seen MANY movies not play on lots of Players Both on Windows OR Linux.

    The fact the VLC wont play correctly indicates its a Actual Movie encoding problem not the OS. VLC is not the be all to end all, personally I wouldn't use VLC unless it was the ONLY player, its rubbish compared to others.

    I got a couple movies here, wont play on anything apart from 1 player - Itunes, and thats because they are coded to Itunes.

    Guess what -Itunes wont install in Linux, you have to use WINE.

    And that's great for users of the Mac OS and Windows, which both have versions of iTunes. But what about Linux? Is there iTunes for Linux?

    The simplest answer is no. Apple doesn't make a version of iTunes that can run natively on Linux.
    BUT as per usual no actual offers of solutions, just TROLLING again.
    Last edited by wainuitech; 23-02-2019 at 11:18 AM.

  7. #7
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,683

    Default Re: Video playback sound - help please.

    Just adding to above, it Happens to ALL Media and all sources, here's a question on one of the Facebook pages I'm a member of, NOTHING to do with Windows or Linux- its an Apple problem.

    Click image for larger version. 

Name:	Facebook Question.png 
Views:	36 
Size:	13.8 KB 
ID:	9384

  8. #8
    Older by the minute
    Join Date
    Dec 2004
    Location
    Whitford
    Posts
    1,786

    Default Re: Video playback sound - help please.

    I own DVDs of Mamma Mia 1 & 2. Using iSkysoft media converter I downloaded them to my Win 10 Prof desktop and that's where I ran into problems in trying to replay them. Other DVDs have been downloaded without problems.

    I have now downloaded K-lite codecs which includes MPC HP64 as the media player. Absolutely no problems with it playing back all I have in the way of saved movies and youtube music clips. I am just surprised that the Windows 10 Films & TV isn't able to do the same. I must say that up until recently it did and I can vouch for the fact that it did play Mamma Mia1 a little while back without fault. I am unsure when it went wrong, maybe an update one or two back. That is why I added the #4 above in mitigation of the fact that I now have a problem. Seems many others do too. VLC has the same problem so a codec is not fixing its self to the programs somehow. Anyway, I'm happy that MPC-HP64 does the job.

  9. #9
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,683

    Default Re: Video playback sound - help please.

    I own DVDs of Mamma Mia 1 & 2. Using iSkysoft media converter I downloaded them to my Win 10 Prof desktop and that's where I ran into problems in trying to replay them. Other DVDs have been downloaded without problems.
    You have kind of answered your own Question

    If others you have done work as expected and play without errors, whats different ??? SIMPLE the DVD's.

    What could have happened is there is something in the DVD's that are different to others, not all DVD's are created the same, there could be some sort of Copy Protection or something in the DVD's.

    You may find some Programs like VLC need their codec's upgraded.

    You can try a different convertor as well, one that works quite well ( there's lots of them, some work better than others) is Handbrake, But it wont rip copyright DVD's, One that Does is DVDFab HD Decrypter.

  10. #10
    Wrinkly Member! B.M.'s Avatar
    Join Date
    Dec 2004
    Location
    Mount Maunganui
    Posts
    8,278

    Default Re: Video playback sound - help please.

    Quote Originally Posted by wainuitech View Post
    If others you have done work as expected and play without errors, whats different ??? SIMPLE the DVD's.
    What about the youtube clips?

    Bryan wrote:
    I have a problem on some film and youtube clips.
    Anyway, you might like to help this fellow out too.

    Click image for larger version. 

Name:	Win 10 Update.png 
Views:	60 
Size:	29.2 KB 
ID:	9385
    Global Warming is Mann made.

    Do not regret growing older. It is a privilege denied to many.
    .
    The problems we face today are because the people who work for a living are now outnumbered by those who vote for a living.

Similar Threads

  1. Movie playback sound problems.
    By Bryan in forum PressF1
    Replies: 4
    Last Post: 06-12-2014, 01:44 PM
  2. issues with sound and video playback
    By ice in forum PressF1
    Replies: 5
    Last Post: 10-07-2010, 12:22 PM
  3. Playback video- no sound
    By Nomad in forum PressF1
    Replies: 6
    Last Post: 15-11-2007, 01:05 PM
  4. No sound DVD playback
    By sam m in forum PC World Chat
    Replies: 1
    Last Post: 06-06-2006, 10:40 PM
  5. Video Playback
    By Obelix in forum PressF1
    Replies: 1
    Last Post: 01-07-2002, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •