Results 1 to 5 of 5
  1. #1
    Junior Member learning's Avatar
    Join Date
    Jan 2006
    Location
    Redmond
    Posts
    455

    Default Hyper-V Not Enabling - Win 10

    I am on Win 10 PRO and trying to enable Hyper-V. I have tried using both, power shell and the Add/Remove Windows feature but get error:

    The referenced assembly could not be found
    Error Code: 0x80073701



    I have also mounted the Windows ISO image and ran the enabling feature using DISM and still same error.


    Below is what i see in the error in DISM log.

    Scoured the net but the fixes some have suggested has not worked so far. Have gone over this link among other ones: https://windowsreport.com/cant-insta...-v-windows-10/

    Anyone come across this issue or any ideas to fix this ?

    2018-09-05 13:03:28, Info DISM DISM.EXE: Succesfully registered commands for the provider: Edition Manager.
    2018-09-05 13:03:28, Info DISM DISM Package Manager: PID=7156 TID=12536 Processing the top level command token(enable-feature). - CPackageManagerCLIHandler::Private_ValidateCmdLine
    2018-09-05 13:03:28, Info DISM DISM Package Manager: PID=7156 TID=12536 Attempting to route to appropriate command handler. - CPackageManagerCLIHandler::ExecuteCmdLine
    2018-09-05 13:03:28, Info DISM DISM Package Manager: PID=7156 TID=12536 Routing the command... - CPackageManagerCLIHandler::ExecuteCmdLine
    2018-09-05 13:03:28, Info DISM DISM Package Manager: PID=7156 TID=12536 Encountered the option "featurename" with value "Microsoft-Hyper-V" - CPackageManagerCLIHandler::Private_GetPackagesFrom CommandLine
    2018-09-05 13:03:28, Info DISM DISM Package Manager: PID=7156 TID=12536 Encountered an unknown option "featurename" with value "Microsoft-Hyper-V" - CPackageManagerCLIHandler::Private_GetPackagesFrom CommandLine
    2018-09-05 13:03:30, Info DISM DISM Package Manager: PID=7156 TID=12536 Feature Microsoft-Hyper-V-All with CBS state 4(CbsInstallStateStaged) being mapped to dism state 4(DISM_INSTALL_STATE_STAGED) - CDISMPackageFeature::LogInstallStateMapping
    2018-09-05 13:03:30, Info DISM DISM Package Manager: PID=7156 TID=12536 Initiating Changes on Package with values: 5, 7 - CDISMPackage::Internal_ChangePackageState
    2018-09-05 13:03:30, Info DISM DISM Package Manager: PID=7156 TID=12536 CBS session options=0x40100! - CDISMPackageManager::Internal_Finalize
    2018-09-05 13:03:44, Info DISM DISM Package Manager: PID=7156 TID=10948 Error in operation: (null) (CBS HRESULT=0x80073701) - CCbsConUIHandler::Error
    2018-09-05 13:03:44, Error DISM DISM Package Manager: PID=7156 TID=12536 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x800737 01)
    2018-09-05 13:03:44, Error DISM DISM Package Manager: PID=7156 TID=12536 Failed processing package changes with session options - CDISMPackageManager::ProcessChangesWithOptions(hr: 0x80073701)
    2018-09-05 13:03:44, Error DISM DISM Package Manager: PID=7156 TID=12536 Failed ProcessChanges. - CPackageManagerCLIHandler::Private_ProcessFeatureC hange(hr:0x80073701)
    2018-09-05 13:03:44, Error DISM DISM Package Manager: PID=7156 TID=12536 Failed while processing command enable-feature. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x800 73701)
    2018-09-05 13:03:44, Info DISM DISM Package Manager: PID=7156 TID=12536 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine
    2018-09-05 13:03:44, Error DISM DISM.EXE: DISM Package Manager processed the command line but failed. HRESULT=80073701

  2. #2
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,568

    Default Re: Hyper-V Not Enabling - Win 10

    Even though you mentioned you have tried several things that's not much help really, no one apart from yourself knows what they are

    Error 0x80073701 is ERROR_SXS_ASSEMBLY_MISSING, it means there are some system files are missing,

    Try running the sfc /scannow and DISM command(s) one in particular dism /online /cleanup-image /restorehealth

    Even if the checkhealth says its OK, that command has sometimes fixed faults even though the check says its OK.

    if you run the system info, does Hyper-V list say yes to all requirements ?


    Had the same thing on one of my older Computers, Virtual Box went bad and corrupted several required files. Doing a in place repair install fixed it, but that's going to the extreme ( maybe)
    Last edited by wainuitech; 06-09-2018 at 09:32 AM.

  3. #3
    Junior Member learning's Avatar
    Join Date
    Jan 2006
    Location
    Redmond
    Posts
    455

    Default Re: Hyper-V Not Enabling - Win 10

    Quote Originally Posted by wainuitech View Post
    Even though you mentioned you have tried several things that's not much help really, no one apart from yourself knows what they are

    Error 0x80073701 is ERROR_SXS_ASSEMBLY_MISSING, it means there are some system files are missing,

    Try running the sfc /scannow and DISM command(s) one in particular dism /online /cleanup-image /restorehealth

    Even if the checkhealth says its OK, that command has sometimes fixed faults even though the check says its OK.

    if you run the system info, does Hyper-V list say yes to all requirements ?


    Had the same thing on one of my older Computers, Virtual Box went bad and corrupted several required files. Doing a in place repair install fixed it, but that's going to the extreme ( maybe)

    Thanks Wainui, You are right. just did so many things in space of 2 hours i couldnt recall all to type away =)

    I did the sfc /scannow and it came out ok on integrity. When i do systeminfo, it does say Yes to all Hyper-V requirements.

    I just completed the DISM /online/.... like you mentioned and after reboot tried enabling again below is error i got in the logfile.

    It seems like it maybe missing a KB or something else but i cant quite pinpoint it. I see KB4093112 being mentioned in the logfile. I do not have this on my machine yet. But this is just a cumulative update.

    I may have had virtualbox on this PC when i was working with Vagrant at one time but i had uninstalled it. Now that you mentioned I will see if there is any remnants of it in registry.



    2018-09-05 14:36:03, Info CBS Exec: Resolving Package: Package_1967_for_KB4093112~31bf3856ad364e35~amd64~ ~10.0.1.3, Update: 4093112-5899_neutral
    2018-09-05 14:36:03, Info CBS Exec: Resolving component from existing package; passing NULL manifest path to PinDeployment and hoping things haven't been scavenged.
    2018-09-05 14:36:03, Info CBS Exec: Resolving Package: Package_1967_for_KB4093112~31bf3856ad364e35~amd64~ ~10.0.1.3, Update: 4093112-5899_neutral, PinDeployment: amd64_33412378c88c93de5678245e8a651ee4_31bf3856ad3 64e35_10.0.16299.371_none_fee964b6b4f316bf
    2018-09-05 14:36:03, Info CBS Exec: 83 deployments need bulk staging
    2018-09-05 14:36:03, Error CSI 00000008@2018/9/5:21:36:03.260 (F) onecore\base\wcp\componentstore\csd_locking.cpp(95 ): Error STATUS_SXS_ASSEMBLY_MISSING originated in function CCSDirectTransaction::LockComponent expression: (null)
    [gle=0x80004005]
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CBS.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905213417.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905195539.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905180325.log to WER report.
    2018-09-05 14:36:03, Info CBS Not able to add pending.xml to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Info CBS Not able to add pending.xml.bad to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Info CBS Not able to add poqexec.log to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Error CSI 00000009 (F) STATUS_SXS_ASSEMBLY_MISSING #227079# from CCSDirectTransaction::OperateEnding at index 0 of 1 operations, disposition 2[gle=0xd015000c]
    2018-09-05 14:36:03, Error CSI 0000000a (F) HRESULT_FROM_WIN32(ERROR_SXS_ASSEMBLY_MISSING) #226933# from Windows::ServicingAPI::CCSITransaction::ICSITransa ction_PinDeployment(Flags = 0, a = c798ff2be4a317562a08aa253f92c15c, version 10.0.16299.371, arch amd64, nonSxS, pkt {l:8 b:31bf3856ad364e35}, cb = (null), s = (null), rid = 'Package_2108_for_KB4093112~31bf3856ad364e35~amd64 ~~10.0.1.3.4093112-6295_neutral', rah = '2', manpath = (null), catpath = (null), ed = 0, disp = 0)[gle=0x80073701]
    2018-09-05 14:36:03, Info CBS Failed to pin deployment while resolving Update: Package_2108_for_KB4093112~31bf3856ad364e35~amd64~ ~10.0.1.3.4093112-6295_neutral from file: (null) [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:03, Info CBS Failed to bulk stage deployment manifest and pin deployment for package:Package_2490_for_KB4343897~31bf3856ad364e3 5~amd64~~10.0.1.7 [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:03, Info CBS CommitPackagesState: Started persisting state of packages
    2018-09-05 14:36:03, Info CBS CommitPackagesState: Completed persisting state of packages
    2018-09-05 14:36:03, Info CSI 0000000b@2018/9/5:21:36:03.957 CSI Transaction @0x175d6b9d120 destroyed
    2018-09-05 14:36:03, Info CBS Perf: Resolve chain complete.
    2018-09-05 14:36:03, Info CBS Failed to resolve execution chain. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:03, Error CBS Failed to process single phase execution. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:03, Info CBS WER: Generating failure report for package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.16299.15, status: 0x80073701, failure source: Resolve, start state: Installed, target state: Installed, client id: Windows Optional Component Manager
    2018-09-05 14:36:03, Info CBS Not able to query DisableWerReporting flag. Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CBS.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905213417.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905195539.log to WER report.
    2018-09-05 14:36:03, Info CBS Added C:\WINDOWS\Logs\CBS\CbsPersist_20180905180325.log to WER report.
    2018-09-05 14:36:03, Info CBS Not able to add %windir%\winsxs\poqexec.log to WER report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Info CBS Not able to add %windir%\winsxs\pending.xml to WER report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:03, Info CBS Not able to add %windir%\winsxs\pending.xml.bad to WER report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2018-09-05 14:36:04, Info CBS Reboot mark cleared
    2018-09-05 14:36:04, Info CBS Winlogon: Simplifying Winlogon CreateSession notifications
    2018-09-05 14:36:04, Info CBS Winlogon: Deregistering for CreateSession notifications
    2018-09-05 14:36:04, Info CBS FinalCommitPackagesState: Started persisting state of packages
    2018-09-05 14:36:04, Info CBS FinalCommitPackagesState: Completed persisting state of packages
    2018-09-05 14:36:04, Info CBS Enabling LKG boot option
    2018-09-05 14:36:04, Info CBS Exec: End: nested restore point - complete.
    2018-09-05 14:36:04, Info CBS Client aborted the install. [HRESULT = 0x800f0821 - CBS_E_ABORT]
    2018-09-05 14:36:04, Info CBS Exec: Installation failed but no store corruption found.
    2018-09-05 14:36:04, Info CBS Exec: Processing complete. Session: 30688608_1036192200, Package: Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~10.0.16299.15, Identifier: Windows Foundation [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:04, Error CBS Failed to perform operation. [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:04, Info CBS Session: 30688608_1036192200 finalized. Reboot required: no [HRESULT = 0x80073701 - ERROR_SXS_ASSEMBLY_MISSING]
    2018-09-05 14:36:04, Info CBS Failed to FinalizeEx using worker session [HRESULT = 0x80073701]

  4. #4
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,568

    Default Re: Hyper-V Not Enabling - Win 10

    Yeah the log does mention KB4093112, if it were me I'd make a restore point first (just in case), download the version for your computer, install it and see what happens.

    https://www.catalog.update.microsoft...px?q=kb4093112

    BUT it only mentions Windows 10 1709, if yours is 1803 then it may not apply. Usually if the patch doesn't apply to your OS it will stop and say so.

    It does mention Hyper-V in the information on it.
    Security updates to Internet Explorer, Microsoft Edge, Windows kpp platform and frameworks, Microsoft scripting engine, Windows graphics, Windows Server, Windows kernel, Windows datacenter networking, Windows wireless networking, Windows virtualization and Kernel, and Windows Hyper-V.

  5. #5
    Junior Member learning's Avatar
    Join Date
    Jan 2006
    Location
    Redmond
    Posts
    455

    Default Re: Hyper-V Not Enabling - Win 10

    Quote Originally Posted by wainuitech View Post
    Yeah the log does mention KB4093112, if it were me I'd make a restore point first (just in case), download the version for your computer, install it and see what happens.

    https://www.catalog.update.microsoft...px?q=kb4093112

    BUT it only mentions Windows 10 1709, if yours is 1803 then it may not apply. Usually if the patch doesn't apply to your OS it will stop and say so.

    It does mention Hyper-V in the information on it.
    Thanks i will give that a try. I do have a later build Win 10 OS so not sure if it works but at this stage its worth a try.

Similar Threads

  1. Hyper-V
    By mzee in forum PressF1
    Replies: 5
    Last Post: 11-08-2018, 07:13 PM
  2. CM Hyper 212 Plus
    By bk T in forum PressF1
    Replies: 10
    Last Post: 18-12-2012, 11:38 AM
  3. hyper threading
    By gtr676 in forum PressF1
    Replies: 13
    Last Post: 25-07-2004, 09:05 PM
  4. Hyper Thread or this new one . .
    By sc0ut in forum PressF1
    Replies: 0
    Last Post: 15-04-2003, 12:24 PM
  5. Hyper terminal ?
    By in forum PressF1
    Replies: 0
    Last Post: 29-01-2001, 03:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •