Results 1 to 6 of 6
  1. #1
    Senior Member
    Join Date
    Dec 2004

    Default DISKPART help, need to see some output

    I really need to see what a typical Windows 10 partitioning could look like for a GPT disk EFI booting.

    If someone could be kind enough to show me what these commands output on your computer:


    I then need information for these types of partitions:

    Your EFI/ESP partition
    Where Windows is installed partition
    The reserved partition
    The recovery partition

    The command to run would be:


    where # is one of the above partitions and then I would need you to do:


    Repeat it for each partition.

    My issue seems to be bigger than this (corrupted hard drive) but I think my EFI partition may not be shown correctly, but without coming across any information on what it should look like, it's hard to say. I am thinking of moving my EFI partition which maybe in the corrupted part of the drive and restoring the boot to hopefully get a semi-workable system.

    Thanks in advance.

  2. #2
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007

    Default Re: DISKPART help, need to see some output

    for starters, your commands are not complete, and listed incorrectly (what you listed wont work)

    Done with correct commands: BTW this is done in powershell NOT cmd.

    Click image for larger version. 

Name:	Partition_2.jpg 
Views:	108 
Size:	58.2 KB 
ID:	8962
    Click image for larger version. 

Name:	Others.jpg 
Views:	69 
Size:	46.0 KB 
ID:	8963

    Annndddddddddddddddd The partitions complete in partition software:

    Click image for larger version. 

Name:	Partitions_all.jpg 
Views:	88 
Size:	37.9 KB 
ID:	8964

    I live dangerously sometimes

    Should I hit Enter ??

    Click image for larger version. 

Name:	Should_I.png 
Views:	101 
Size:	25.8 KB 
ID:	8965
    Last edited by wainuitech; 27-07-2018 at 08:10 PM.

  3. #3
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007

    Default Re: DISKPART help, need to see some output

    Slight oops, the first PC isnt EFI booting, but the Office PC has:

    Click image for larger version. 

Name:	office.png 
Views:	94 
Size:	37.6 KB 
ID:	8966

    Click image for larger version. 

Name:	partions.png 
Views:	86 
Size:	36.2 KB 
ID:	8967

    Click image for larger version. 

Name:	All.jpg 
Views:	72 
Size:	27.0 KB 
ID:	8968
    Last edited by wainuitech; 27-07-2018 at 08:24 PM.

  4. #4
    Senior Member
    Join Date
    Dec 2004

    Default Re: DISKPART help, need to see some output

    Thanks Wainui, I knew you'd come through. Just trying to decipher it all.

    Was about to say the first post looked like MBR but the second post confirmed my problem.

    The EFI partition on this computer is showing as RAW instead of FAT32, heard updates could cause this but this disk is definitely on it's way out.

    As for the commands, normally 3 letters was enough to issue any of the commands, but this is also from the Win10 USB Recovery, after I posted I thought I should have just did the full commands.

    There's still a few things. The drive I am looking at seems to have way more drive letters assigned but I'll try and mimic how yours looks since I don't know why the recovery partitions would have letters assigned, unless that's by default?

    You have 2 recovery partitions (part 1/vol 1 and part 5/vol 3). I only have 1. My reserved partition isn't right (that was my fault, thought being so small I could trial changing the partition type) and for some reason DISKPART can't edit a partition back to reserved.

    If you can show me what this outputs from your Office PC:


    I need to see the TYPE, which looks like a GUID string, which is how you SET the ID of a partition in DISKPART and I want to see if I can do that, to a partition that says it's RAW, else I'm going to try to delete it and recreate it. However all information for it helps.

    What I'm trying to do is rebuild my BCD, but can't do it with a RAW partition, says unknown file system and since I don't use Windows myself, most tools to fix it were Windows related but I think I understand how I can do this in Linux now, just needed to see what the output was like before I attempted to fix it.

  5. #5
    Senior Member
    Join Date
    Dec 2004

    Default Re: DISKPART help, need to see some output

    I've not used Windows in a long time and don't have access to a Windows machine but that output helped me fix this problem. So I'll explain the issue I had and the steps I took to fixing it. I actually did part of it in Linux but learnt how to do it in Windows afterwards so I'll provide the Windows way.

    So when I booted this computer I had what I guess is a Black Screen of Death:

    Windows Boot Manager
    Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:
    1. Insert your Windows installation disc and restart your computer.
    2. Choose your language settings, and then click "Next."
    3. Click "Repair your computer."
    If you do not have this disc, contact your system administrator or computer manufacturer for assistance.
    File: \EFI\Boot\BCD (I think this was the location and file, it's similar to this anyways)
    Status: 0x???????? (Sorry I could not remember this, but it didn't help in searching for solutions anyways)
    Info: The Boot Configuration Data for your PC is missing or contains errors. (Not sure if this is the exact string either)
    So my error message was like this, searching around it suggested fixing the MBR/Boot and rebuilding BCD (Boot Configuration Data).

    I had to create a Windows 10 USB stick. Since I only use Linux I used a program called woeusb (formally called winusb) to create it from the ISO I downloaded from Microsoft. woeusb comes with a woeusbgui tool as well and if you don't like CLI (command line interfaces), you can use this instead. woeusb did seem to take a long time compared to writing Linux ISO files to USB but I tried the usual way of writing ISO to USB and it did not work with a Windows ISO.

    So with this USB I booted it (Step 1 from that BSOD)
    Chose my language setting: English (New Zealand) then hit Next (Step 2 from BSOD)
    Then down in the bottom right corner of the window was a link called Repair my computer which I clicked. (Step 3... great Windows left out the rest of the steps)

    Now there's multiple problems you could be facing with the above screen, my issue was somehow not an easy fix but I wish it were. Remember this is a GPT disk with EFI booting, so it has a different layout and means of booting than MBR type disks and it's quite important to know the differences when solving boot issues.

    So your first attempt should be to Troubleshoot your computer then perform the Startup repair. Read the message you get back, because if you're like me and skip a lot of the messages, you may miss the fact that it failed or was unsuccessful and that you should do an Advance repair. If this was successful for you, reboot your computer and see if it works. If it works, congratulations, I am envious that it worked easily for you.

    Since my issue wasn't fixed, I did the advance repair in the command prompt. These are the steps I took. If at any stage you don't get a success message, that's where you need to work on the problem. Unfortunately I don't know every fix for every unsuccessful message you may encounter as my first attempt failed at the end and then after I thought I had it sorted, it failed earlier.

    So the commands you do are: (I'm ignoring the drive letter and location, but it should be done where it starts you off in, think it's like x:\sources ... but again, I'm working from memory and these things weren't important for me to know at the time)

    bootrec /fixmbr
    bootrec /fixboot
    bootrec /scanos (this command may not be needed)
    bootrec /rebuildbcd (this command could be used instead of scanos because it still scans for installations. Just seems twice the work doing scanos and then rebuildbcd)
    scan os, normally lists all your Windows installations, not sure if it picks up other os but I only had 1 Windows installation and it found it.

    with /rebuildbcd if you have more than 1 windows installation it'll ask if you want to add them to your BCD, you can just choose A for (A)ll or (Y)es and (N)o the ones you do and do not want. If this command works for you congratulations, you should reboot and see if your computer works. For me, this is where it failed with this error message:

    "The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted."
    The volume it's talking about is your ESP (EFI system partition) which is where your EFI boot information needs to exists but rebuildbcd failed to rebuild it at that location. Thanks to Wainui's output, I discovered that this partition somehow got destroyed (possibly corrupt partition table or file system, I went for file system, knowing that my disk was dying, I used a Linux usb to boot first and was spammed with disk errors which for a usb boot, is strange as hard drives are not touched but they still need to be read to be seen in the OS). So that was the issue I needed to fix and to check what the problem was I did this:

    diskpart (to run DISKPART)
    Shows all your disks, you need to select your drive that has the ESP partition, normally the same as where Windows would be. If you changed this location, you should be more clued up to knowing where it is but others should rely on knowing where Windows would be. Normally DISK 0 is it.

    An asterisk (*) appears on the already selected drive, by default it's DISK 0 and normally this the correct one, if it is not, you need to do:

    Where # is the disk number.

    This will list all your partitions on that disk, now the ESP is usually 100MB (from information I've seen on the web as well as Wainui's output) but in my case it was 260MB. Now your ESP could be different but I would say if it's at least 100MB+ it maybe the right partition. Also note, LABELS and INFO/FLAGS you read may throw you off, these may not be correct or be different for everyone.

    Now this partition should say FAT32 but in my case it said RAW. I'm not sure what Windows thinks what RAW is but from my understanding in Linux this is an unformatted partition, meaning it's a partition with empty space.

    Now that may not be the case. It may say RAW because the magic that is needed to say what type of partition it is, is corrupted. Now file systems normally create a binary string which I call magic, because it kind of tells the computer what the partition is, normally magic is also associated with mime-types and knowing what certain types of files are, e.g. image/png (png picture files) have at the start of their file a string that says "Hey I'm a PNG" (not that, but something computers can translate into knowing it's a PNG file).

    So it's possible the magic is corrupted or the partition table is. Now in my case I went for corrupted magic and failed fixing it. How I tried to do it was say VOLUME 4 and PARTITION 1 is my ESP:

    DISKPART> LIST PARTITION (this is to check to make sure it picks the ESP partition if not, we change that too)
    DISKPART> DETAIL PARTITION (command is not needed but this is to show what information if anything is known about this partition)
    DISKPART> SET ID=C12A7328-F81F-11D2-BA4B-00A0C93EC93B
    Partition GUID are hell for typing, I don't know if there's any shortform way to do this. However, I believe this did not work or it changed but the file system still remained RAW (even after a reboot). So it failed pretty much.

    For more Partition GUIDs have a look at, MBR ones are not GUIDS but small hex values, as you can see by Wainui's first post his DETAIL PARTITION shows the TYPE as 07 which is hex value 0x7 which computers understand as NTFS BASIC DATA PARTITION which you probably don't need to know but I love information and that's the kind of 'magic' you sometimes come across.

    So my partition remains RAW, I can't rebuild because of it. I'm skipping some of the trial and errors I did getting to my solution, however there may have been a fix to it, quicker than what I came up with. This was where I cheated and went to Linux to delete the ESP partition and recreate it and format it as FAT32. I did this in the hope that when I rebooted back into Windows recovery, that I could issue the bootrec /rebuildbcd command and finally be done, but... things got worse. So instead of doing it in Linux, I'll show you how to do this from DISKPART and the command prompt. This way may actually avoid the problem I caused so you maybe able to stop reading (yay!) otherwise you might have to follow me to the end.

    See the code above to select your ESP partition. If LIST VOLUME shows that your ESP partition already has a drive letter you can ignore the next step, just remember that drive letter.

    DISKPART> ASSIGN LETTER Z (pick a letter not in use, don't use X)
    WARNING!!! Make sure you picked your ESP, what you are about to do will destroy data so make sure you got it right.
    format Z: /FS:FAT32 (confirm all messages and make sure Z: is your drive letter for your ESP!)
    I may have left out the part where I deleted the partition and recreated it in DISKPART on purpose, because when I did that, it just recreated the same RAW partition. I did read lots of reports that Windows build blah blah had issues and downgrading to a lower version works, but... I don't know what version I'm using, I assume the very latest but how do you check that from the USB that I booted? It's possible I skipped over it, as I said, I do skip a lot of messages because it's all very generic.

    Now you can attempt to do the bootrec commands again above and see if you get further, or in my case... I stopped sooner.

    I got stopped at:

    bootrec /fixboot
    Access Denied!!!
    Not sure what Access it was talking about but again, this stopped me in my tracks (I just thought of what it could be), I could not get pass that stage but if you managed to rebuildbcd... you completed the journey and made it out quicker than me.

    OK, so while I was writing that and knowing a bit about access being denied from a Linux viewpoint, I am wondering if it is because we assigned a drive letter, in which case we 'mounted' the partition and in Linux, modifying a mounted drive/partition is near impossible (although writing boot information shouldn't be considered modifying unless it does some flags, etc with the partition), so maybe we should have unmounted it. So to unmount the drive:

    Find your ESP Partition again using above commands

    Remember to use the letter you assigned to it if it wasn't Z. Then redo those bootrec commands, if it gets passed /fixboot maybe that was my issue all along but I have no way to test that now, my problem is solved but I guess if I want to recreate it, I just need to delete my ESP then recreate a new partition without formatting a file system and I'll be back at square 1.

    There was only one last option, the last thing for me to do, the one thing I truly wanted to avoid... Reinstall Windows... no I'm joking!!! But it seemed like I wasted many hours on this issue and I'm not even a Windows user, not since XP, so I'm really treading in the unknown and my instructions may not be the best, but from what I've read on the internet. It's definitely tangled around the web as it was hard finding information that was all there in one place like this is going to be (I hope).

    So here was my last command that actually allowed me to boot into Windows, you need to give ESP a drive letter so do the commands above to get you a letter then I did:

    bcdboot c:\windows /s z: /f uefi
    Even after that however I reattempted the bootrec commands and it still failed at /fixboot with access denied (maybe mounting problem?), anyways, I rebooted and lo and behold, Windows booted (maybe had an actual blue screen of death first) but rebooted it again and it started fine, rebooted again, again fine. Problem for me, solved partially. That disk is dying and I didn't really need windows to boot, however I was just curious as I've backed up all the data and just wondering what the process would be to fix a failing boot, since as I said... not a Windows user so was just learning something about the process... seems a bit hard, but I like the command prompt way and it only becomes easier the more you do it anyways.

    So I know this is long, many will skip what I say but this can render your system unbootable, so if your issue is slightly different, you should ask for advice and see if you should do these instructions or not, because it's at your own risk and I seemed to have got out of it but others won't have that luck considering there was steps that failed me at the start. Good luck.

  6. #6
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007

    Default Re: DISKPART help, need to see some output

    On Mine, all the partition letters are default except S, that's one I set as Storage.

    The commands you asked about:

    Click image for larger version. 

Name:	Partition_2.png 
Views:	83 
Size:	11.3 KB 
ID:	8971

    Haven't got time at the moment to read all of your post ( heading out)

    BUT I had a customers PC the other day similar wouldn't boot, all sorts of errors, couldn't see the OS, tried all the bootrec (s) NOTHING worked and NO OS found (but it was there, I did manage to get it going ( all but unstable) by running chkdsk with various combinations of switches as well as sfc/scannow several times. I also slaved the Drive to another W10 and on startup that found lots of errors, running chkdsk, and removing /replacing faulty / orphaned files.

    BTW, my first post, the comment about commands not complete -- Thats not fully correct in its own sense. I Was always taught use the full wording, as sometimes you can really screw up if the commands are shortened. The first time I used your commands as listed they didn't work, so went back to what I know does.

    Sometimes when it all turns bad, its quicker to save all the data either by using linux to copy off, or slave the drive and copy if able, wipe the drive and start again.
    Last edited by wainuitech; 28-07-2018 at 09:40 AM.

Similar Threads

  1. PSU output ripple
    By Agent_24 in forum PressF1
    Replies: 7
    Last Post: 11-10-2007, 06:41 PM
  2. Two inputs - one output
    By acheron4778 in forum PressF1
    Replies: 3
    Last Post: 30-07-2007, 04:52 PM
  3. PC to TV output
    By taly in forum PressF1
    Replies: 7
    Last Post: 01-07-2007, 05:19 PM
  4. Mic output
    By kjaada in forum PressF1
    Replies: 1
    Last Post: 27-02-2007, 08:19 AM
  5. Output to TV from Laptop
    By Groovvy in forum PressF1
    Replies: 6
    Last Post: 23-08-2006, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts