Results 1 to 10 of 10
  1. #1
    Senior Member Pato's Avatar
    Join Date
    Dec 2004
    Location
    Kapiti Coast
    Posts
    2,036

    Default Autoplay in Win10

    Using Win7 I would just insert a disk in the DVD drive and it would play, however, this is not the case with Win10. I can get a disk to play via the DVD drive using Windows Exployer but this is really not satisfactory.

    I have tried via Settings/Devices/Autoplay (switched on) but still no joy. Can someone suggest a solution please.?

  2. #2
    In a 1920s time warp Terry Porritt's Avatar
    Join Date
    Dec 2004
    Location
    Upper Hutt
    Posts
    5,361

    Default Re: Autoplay in Win10

    There always seems to be more than one way of doing things, they may be the same but try Control Panel- Hardware and Sound-Autoplay, tick the box Use AutoPlay for all media and devices then select a default program for the media, eg VLC for CDs

    Also have a look here: http://windowsreport.com/autoplay-no...ng-windows-10/ which has a registry fix

  3. #3
    Senior Member Pato's Avatar
    Join Date
    Dec 2004
    Location
    Kapiti Coast
    Posts
    2,036

    Default Re: Autoplay in Win10

    Quote Originally Posted by Terry Porritt View Post
    There always seems to be more than one way of doing things, they may be the same but try Control Panel- Hardware and Sound-Autoplay, tick the box Use AutoPlay for all media and devices then select a default program for the media, eg VLC for CDs

    Also have a look here: http://windowsreport.com/autoplay-no...ng-windows-10/ which has a registry fix
    I have already tried your first suggestion without success. Also had a look at registry fix but I couldn't find the HKCU reference. To be honest I am not that keen on playing around in the registry but perhaps that is the only fix. It appears a lot of people are having this problem. Dam Win10. Some recommend to restore ALL to default settings.
    Last edited by Pato; 17-09-2016 at 02:59 PM.

  4. #4
    Senior Member Driftwood's Avatar
    Join Date
    Jul 2007
    Location
    Central Otago
    Posts
    3,055

    Default Re: Autoplay in Win10

    Restore to default may be a good start.

  5. #5
    Senior Member Pato's Avatar
    Join Date
    Dec 2004
    Location
    Kapiti Coast
    Posts
    2,036

    Default Re: Autoplay in Win10

    wainuitech may have some suggestions. I have tried a lot of the so-called fixes on the net, but so far to no avail. You should be able to insert a disk and it should start playing making it simple for everyone.

  6. #6
    amateur expert dugimodo's Avatar
    Join Date
    Dec 2005
    Posts
    8,131

    Default Re: Autoplay in Win10

    They have been automatically disabling auto run features by default for years because it's a security risk. If you really want it see if this helps http://www.howtogeek.com/236241/how-...in-windows-10/
    I don't find it any great hardship to launch it myself personally.
    Ryzen 2700X, 16Gb DDR4RAM, 512GB M.2 NVME SSD, MSI GTX1070

  7. #7
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,566

    Default Re: Autoplay in Win10

    You dont need any reg fixes or change any difficult settings

    This has worked most of the time I've done it.

    1st thing you NEED to install a third party player, By DEFAULT Windows 10 wont play DVD's or Blu-Ray ( see last Line in)

    The suggested answers above if you combine them together should work.

    Go to the search, type in Auto - Open Autoplay settings, make sure Autoplay is set to on - then from the first dropdown box select "Ask me everytime" (Just for the hell of it)

    Next go into the old control panel /Autoplay Scroll down to DVD, from the dropdown box select "Ask me every time"
    Click image for larger version. 

Name:	Ask.jpg 
Views:	72 
Size:	29.7 KB 
ID:	7440

    When you put in a DVD you will (or should) get a bar fly out bottom right - MANY people miss it, or look at it with a dumb look going "whats that" and p1ss about clicking it, so they have to eject the DVD and start again.
    Click image for larger version. 

Name:	Option.png 
Views:	90 
Size:	30.8 KB 
ID:	7439

    When the bar flies out (may take a few moments) you click it, then another box will open up top, select what you want, meaning select the player you want to use.

    You can also select the default player from the above settings, instead of selecting Ask everytime select your player of choice.
    Click image for larger version. 

Name:	Select Device.jpg 
Views:	89 
Size:	34.3 KB 
ID:	7441

    Personally I got several which are AlPlayer, Zoom(free), VLC, Kodi and a couple of others
    Last edited by wainuitech; 18-09-2016 at 12:19 PM.

  8. #8
    Senior Member Pato's Avatar
    Join Date
    Dec 2004
    Location
    Kapiti Coast
    Posts
    2,036

    Default Re: Autoplay in Win10

    Thanks wainui. I have installed VLC in the meantime. I am trying to get my music cds to open automatically, but have tried a movie dvd also. I do not get a bar fly out when I insert a DVD, nothing.

    so I can't select a default player. I am probably missing something but I don't know what. I had tried the other suggestions before I posted on here and did not have any success.

    I can get these things to play ok but I want to make it simple for others by using autoplay. This has worked ok with XP and Win7 so I can't see what the problem is with Win10.

  9. #9
    Computer Technician wainuitech's Avatar
    Join Date
    Aug 2007
    Location
    Wellington
    Posts
    28,566

    Default Re: Autoplay in Win10

    The autoplay in the old control panel, you select the player for the media type. Looking at mine they look like they are almost greyed out but aren't, from the drop down boxes you select what ever you want.

    Click image for larger version. 

Name:	Audio CD.jpg 
Views:	71 
Size:	44.8 KB 
ID:	7442
    Make sure the boxes are selected other wise the options wont work on some settings:
    Click image for larger version. 

Name:	Autoplay.png 
Views:	71 
Size:	19.7 KB 
ID:	7443


    If these are not working then some setting is disabled. Playing about with reg files to turn on is not a good idea, esp if they should work by default. Everything I posted has worked here on our computers.

    Looking at some places that say alter the reg,- some (if not most) dont apply to everyones problem. Take as an example http://windowsreport.com/autoplay-no...ng-windows-10/ -- The settings they state for NoDriveTypeAutoRun dont exist, and some of the folders in the HKCU also dont exist on this PC thats working fine.

    I WONT go giving suggestions on altering the reg as its to dangerous when I cant reverse any stuffups. That site does have a reset option / Solution 1 in the control panel, give that a try. (driftwoods suggestion)
    Last edited by wainuitech; 18-09-2016 at 02:48 PM.

  10. #10
    Senior Member Pato's Avatar
    Join Date
    Dec 2004
    Location
    Kapiti Coast
    Posts
    2,036

    Default Re: Autoplay in Win10

    Those are not working for me and you say some setting is disabled. I appreciate the time you have taken and I will have a further play around. I found the same thing about the reg settings so gave up

    as I am not confident enough in the Reg to alter anything anyway.

Similar Threads

  1. DVD Autoplay
    By AZREAL in forum PressF1
    Replies: 2
    Last Post: 24-08-2003, 01:02 AM
  2. CD Autoplay XP
    By Trev0 in forum PressF1
    Replies: 7
    Last Post: 04-04-2003, 02:18 PM
  3. CD-ROM Autoplay
    By in forum PressF1
    Replies: 3
    Last Post: 08-12-2001, 07:15 PM
  4. Autoplay
    By in forum PressF1
    Replies: 2
    Last Post: 02-06-2001, 06:35 PM
  5. AutoPlay
    By in forum PressF1
    Replies: 0
    Last Post: 24-06-1999, 09:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •