Results 1 to 3 of 3
  1. #1
    Guest

    Default CD-ROM No Longer Works!

    Well, Christmas saw a new game come in, Grim Fandango, one of those EA Classic games. Before installing it I thought about doing the System Analysis on the computer to see if all was required, it fired up, and performed a CD Speed check, to which the CD-ROM slowed to a halt for some reason, yet it still said that it was doing the CD Speed Check.

    The computer froze, so I hit CTRL+ALT+DELETE several times, and then the computer restarted. I now wish I hadn't done that, as the CD Drive won't spin.

    The BIOS picks it up OK, but usually it does a little Spin if a CD is in, nope, not anymore. Going into Windows now, the CD drive still hasn't budged, although it had blinked once or twice. My Computer has the Drive listed, but the icon isn't what it should be, and clicking on the icon didn't produce a pie graph with amount of free space left like it normally does. Clicking on it, won't access the Autorun, or the Drives Contents, but the error message:
    M: is unaccessable.
    There was definately a CD in the drive at that time.

    Restarted the computer, and this time I removed the CD out of the drive. Closed it then put it back in, the CD this time was spinning, but not fast, and you heard these undescribable noises, and the computer froze, I tried to take the CD out, the tray popped out, and I took the CD and tried to put it back in - nope. It wouldn't go back in without pushing it in, something it usually does itself.

    Funnily enough, the CD was loading up the Autorun, but it didn't come up like it did when I first put the CD in.

    Other CD's have the same sort of problems.

    I don't know how to fix it... is it a problem with the hardware, or can I reinstall the drivers again and hope that it works?

    Thanks.

  2. #2
    Guest

    Default Re: CD-ROM No Longer Works!

    Have you had any joy with the CD?

    I have seen warnings with some of those speed checking programs, stating that they can cause irrepairable damage if used.

  3. #3
    Guest

    Default Re: CD-ROM No Longer Works!

    There was no warning. The CD drive successfully worked before starting the System Check. Everything was fine until the computer froze during the test.

    The drive has worked once or twice, but very briefly. I put in a CD and it starting spinning OK, and once I started the install, it went 30% of the way through and then I got the Blue Screen of Death saying to insert the CD - it was in however. So it is back to being broken again.

Similar Threads

  1. jv16 Power Tools no longer works
    By John D in forum PressF1
    Replies: 37
    Last Post: 05-01-2004, 06:11 PM
  2. Replies: 10
    Last Post: 09-05-2003, 07:32 PM
  3. Stolen from MSN, no longer works.
    By in forum PressF1
    Replies: 1
    Last Post: 05-06-2002, 09:34 PM
  4. start button no longer works
    By in forum PressF1
    Replies: 0
    Last Post: 05-11-2000, 10:57 AM
  5. start button no longer works
    By in forum PressF1
    Replies: 0
    Last Post: 05-11-2000, 10:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •