Results 1 to 2 of 2
  1. #1

    Default Not Enough Buffer Space for Variables

    Recently I have been programming a menu system into an old Dos 6.2 computer. I have been using the command 'set' (for creating variables) a lot and have run out of buffer space for which to store my variables in. Can anyone tell me how to increase the buffer size??

  2. #2

    Default Re: Not Enough Buffer Space for Variables

    You need to add to (or make) a CONFIG.SYS file.

    The line you need to increase the environment space is 'SHELL=COMMAND.COM /P /E: xxx'. If COMMAND .COM is in a sub directory, include the path. The default environment size ('xxx') is 512 (used to be 256) bytes, maximum is 32768. Try 1024 for a start. The /P option means load it 'permanently'. You can use /ML, /MH, or /MU to load it in the 640k space or in high memory or 'upper memory'. /MH is probably safe enough. You need a high memory driver loaded before this line.

Similar Threads

  1. Low Buffer Level & Low Used read Buffer
    By mark1978 in forum PressF1
    Replies: 1
    Last Post: 20-06-2008, 06:25 PM
  2. php session variables
    By bliss in forum PressF1
    Replies: 2
    Last Post: 16-05-2004, 09:02 PM
  3. session variables expire
    By sc0ut in forum PressF1
    Replies: 1
    Last Post: 28-11-2003, 01:55 PM
  4. Setting environment variables
    By airdale in forum PressF1
    Replies: 4
    Last Post: 27-10-2003, 08:56 PM
  5. Replies: 9
    Last Post: 17-10-2003, 07:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts