Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Noobish Pirate hueybot3000's Avatar
    Join Date
    Mar 2007
    Location
    At Sea
    Posts
    2,986

    Default Compatibility Issue with Asus R9 290 and P7P55D

    Hey Guys,

    My specs:
    I7 860
    Asus P7P55D Mobo running the latest bios I can find on their website (BIOS 2101)
    PSU Enermax ELT620AWT 620 Watt ( I'm 99% sure this is enough) No hard drives plugged in atm.

    Graphics card I was running is a 5850. I'm now trying to run a R9 290.

    I get absolutely nothing when I put the card in, I have tried reseating, checked power cables and used different dvi and hdmi cables but still black screen.

    I got to the point where I suspected the card was dead so picked up another one today but still no go. And I know this card works on other machines.

    Can I rule out PSU? It never had any issues with the 5850 and I know that doesn't mean much but it should still be fine from what I've read.

    Help!

  2. #2
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    44,851

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Did you when you updated the BIOS update Intel(R) Rapid Storage Technology Driver to v10.5.0.1026 too?? As it says on the site?

    Did you uninstall the drivers for the 5850 before you removed it / installed the new one? Did you connect the PCI-E 6+8 pin connectors?? It looks like it needs them
    Last edited by Speedy Gonzales; 07-08-2014 at 07:21 PM.

  3. #3
    Noobish Pirate hueybot3000's Avatar
    Join Date
    Mar 2007
    Location
    At Sea
    Posts
    2,986

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    No I didnt install the rapid technology driver - will do that now...

    The windows hard drive died on me so I chucked that and have pulled the card since then, I can still use the 5850 no probs though

  4. #4
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    44,851

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Ok but did you connect the PCI-E connectors from the PSU to the new one? It wont work if you dont

  5. #5
    Pretends to know things
    Join Date
    Feb 2010
    Posts
    3,532

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Does the GPU fan spin up when you power the computer on?

  6. #6
    Noobish Pirate hueybot3000's Avatar
    Join Date
    Mar 2007
    Location
    At Sea
    Posts
    2,986

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    PSU has the 8 + 6 pin required and it's plugged in. Fan spins no probs

  7. #7
    Noobish Pirate hueybot3000's Avatar
    Join Date
    Mar 2007
    Location
    At Sea
    Posts
    2,986

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    I'm wondering if you can use the ez flash to install an older bios, perhaps that would work? I know it can work as I've seen systems with those specs on other forums

  8. #8
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    44,851

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Try removing the battery for a min then put it back in then see what happens. If that works reconfigure the BIOS settings

  9. #9
    Noobish Pirate hueybot3000's Avatar
    Join Date
    Mar 2007
    Location
    At Sea
    Posts
    2,986

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Have tried that now, still no good

  10. #10
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    44,851

    Default Re: Compatibility Issue with Asus R9 290 and P7P55D

    Tried another PCI-E slot? You would have to see something to use Ez flash, you have to get into the BIOS

Similar Threads

  1. Replies: 6
    Last Post: 02-09-2012, 03:04 PM
  2. Updating drivers issue 8600GT (ASUS labeled)
    By goodiesguy in forum PressF1
    Replies: 14
    Last Post: 30-10-2011, 01:59 PM
  3. ASUS EEE issue
    By DeSade in forum PressF1
    Replies: 11
    Last Post: 31-07-2010, 12:36 PM
  4. strange internet issue on new laptop, network issue?
    By motorbyclist in forum PressF1
    Replies: 30
    Last Post: 31-07-2006, 11:16 PM
  5. ASUS A7V8X or ASUS A7N8X Mobo ?
    By craigrob in forum PressF1
    Replies: 10
    Last Post: 16-03-2003, 01:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •