Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Can't re Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    440

    Default Win 8.1 losing internet connection

    Hi, I have a new PC with Win 8.1 and every now and then the browser(s) cannot connect to the internet ie the modem. PC to modem/router is by cable.
    When this happens I see on the Onedrive and Dropbox icons suggest that they are up to date checked "in the last few seconds" but browsers do not work (Opera/Firefox/Chrome) but the network connection displays as ok. Unfortunately I generally can't tell exactly when the connection is lost
    I start my Win 7 laptop and it connects wirelessly on the same modem/router just fine.
    PC does not connect until restarted
    I'm not confident in getting anything fixed unless I can diagnose this a bit further, any wise advice please?

  2. #2
    Apple free in Appleby KarameaDave's Avatar
    Join Date
    Sep 2009
    Location
    Near Drummond, Southland
    Posts
    5,017

    Default Re: Win 8.1 losing internet connection

    Your network adapter may be set to a power saving mode:

    Note: Make sure that you are logged-in as an administrator to make these changes.
    a) Press Windows and X key together and select Device Manager.
    b) Locate the Network adapter and expand the driver icon.
    c) Right Click on the network adapter driver and click on Properties.
    d) Navigate to Power Management tab and uncheck the option that says “Allow the computer to turn off this device to save power”.
    e) Click on OK.

    I would also suggest you ensure that the latest drivers for this adapter from the manufacturers website are installed.
    FTW

  3. #3
    amateur expert dugimodo's Avatar
    Join Date
    Dec 2005
    Posts
    8,070

    Default Re: Win 8.1 losing internet connection

    Is it a telecom supplied Thomson router? they have known issues with windows 8.1 and DNS. If so manually setting your DNS setings to use googles apparently fixes it. Haven't done it myself only heard about it.
    Ryzen 2700X, 16Gb DDR4RAM, 512GB M.2 NVME SSD, MSI GTX1070

  4. #4
    Can't re Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    440

    Default Re: Win 8.1 losing internet connection

    HI K-Dave
    Thank you for your suggestion
    at d) on mine it didn't have exactly what you said. I unchecked "Reduce Link speed during standby" which seems similar. The option "Reduce link speed during system idle" was already unchecked.
    I also enabled the "Wake on Link Settings" option, seemed a good move. All the other "Wake ons" were enabled
    I won't be able to fully test it until next week but I'm hopeful, thanks again.

  5. #5
    Can't re Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    440

    Default Re: Win 8.1 losing internet connection

    Hi Dugi, no it's my own, a TP Link TD-W8968
    Worked fine on the previous cabled Vista PC (cough) and all the wireless stuff
    I'm hopeful the power settings will resolve it.

  6. #6
    Can't re Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    440

    Default Re: Win 8.1 losing internet connection

    Well, back home now. Problem hasn't gone away, same thing happened tonight

  7. #7
    Member
    Join Date
    Dec 2004
    Location
    NZ
    Posts
    44,851

    Default Re: Win 8.1 losing internet connection

    Is the firmware on the modem up to date?

  8. #8
    Senior Member
    Join Date
    Mar 2007
    Posts
    479

    Default Re: Win 8.1 losing internet connection

    Quote Originally Posted by dugimodo View Post
    Is it a telecom supplied Thomson router? they have known issues with windows 8.1 and DNS. If so manually setting your DNS setings to use googles apparently fixes it. Haven't done it myself only heard about it.
    Yes, I have the same problem here with Telecom supplied UFB modem, problem only appears since upgrading to Win8.1, was fine with Win8, and other PC with Win7/XP and Android Phone/Tabs are all working fine.

    I have not changed the DNS to Google's (8.8.8.8 and 8.8.8.4), but I fix it each time with ipconfig /flushdns, it sometimes require closing the current tab and opening a new tab before it works (on Chrome/FF/IE)

    Configuring your network settings to use Google Public DNS
    https://developers.google.com/speed/...dns/docs/using

    How to Flush DNS
    http://www.wikihow.com/Flush-DNS

  9. #9
    Can't re Member
    Join Date
    Jun 2008
    Location
    Auckland
    Posts
    440

    Default Re: Win 8.1 losing internet connection

    Updated firmware on TP Link TD-W8968
    Tried power setting options
    Tried ipconfig /flushdns, netsh winsock reset catalog, netsh int ip reset
    Tried Google Public DNS
    Sometimes can't open cmd window. When can run cmd the ping results don't seem to follow any pattern, sometimes no return, sometimes ok all the way to www.google.com etc
    Normally have to power down PC to get a connection back though sometimes reboot the modem works
    All was good with (Actrix) internet connection before the new PC. When the internet is working things might be fine for days
    ref 16-07-2014, 10:45 PM
    Not yet sorted ....

  10. #10
    Member bk T's Avatar
    Join Date
    Dec 2004
    Location
    Auckland
    Posts
    6,199

    Default Re: Win 8.1 losing internet connection

    Quote Originally Posted by dugimodo View Post
    Is it a telecom supplied Thomson router? they have known issues with windows 8.1 and DNS. If so manually setting your DNS setings to use googles apparently fixes it. Haven't done it myself only heard about it.
    You're right - change to Telecom's DNS should fix the problem.
    I'm having quite similar issues, after changing the DNS, everything works just fine.

Similar Threads

  1. Laptop frequently losing internet connection
    By Robin S_ in forum PressF1
    Replies: 6
    Last Post: 19-03-2011, 07:23 AM
  2. Sky losing connection
    By Digby in forum PC World Chat
    Replies: 5
    Last Post: 14-10-2009, 06:58 AM
  3. Losing Internet Connection
    By mack in forum PressF1
    Replies: 24
    Last Post: 29-12-2006, 06:25 PM
  4. keep losing internet connection
    By bizzack in forum PressF1
    Replies: 17
    Last Post: 14-12-2006, 03:19 PM
  5. losing internet connection
    By bootsy in forum PressF1
    Replies: 1
    Last Post: 12-12-2006, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •