PDA

View Full Version : Wireless router, Windows Vista Problems



Lazarui
22-05-2009, 04:03 PM
Hello! I thought I'd ask ya'all a question since you seem quite capable intelligent beings:

ahem!
I've just recently shifted into a new apartment a city center, I'm having quite a few problems with connection issues with my wireless router and my vista laptop(s) 3 actually in this house all vista. Now the router is a D-link DI-524 I've had it for quite a few years and haven't had this issue in the past, but recently it's been going insane and dropping network connections every once in a while. Also every time a larger file gets moved across the network it drops out and i cant reconnect to the router for about a minute. I also have some odd issues of when it randomly disconnects and i try to reconnect vista tells me the security key is incorrect no matter how many times i try to reconnect, BUT! if i reset the router it works fine again... For a while..

Now the question is: is this a vista problem? A compatibility issue with the router? or could it be some setting in my router?

In case of a router issue, either it going south or an issue with vista clients, whats a good router that is vista compatible out there, for a reasonable price, this is a home network so I don't need an insane out there wireless router

Router: DI-524
SSID not broadcasting(I live in a city center, not broadcasting my network name no way!)
WEP/TKIP security

Oh and also I'm picking up quite a few wireless networks in the area mainly from EOL, was just wondering if they could be having an effect, I have also try'd changing the channel the router broadcasts on but to no avail.

Long post is Long, so if you can help me it would be appreciated, and also if you read all that you are an amazing person! lol.

supersi
22-05-2009, 04:27 PM
All of the above can be the problem and will compound the problem.

One of the worst things about Vista is the low transfer rates you'll get between PC's. Even if one PC is Vista it will effect performance. I used to get only about 1mb/sec max wifi G transfer rate between pc's with Vista. Vista also has a nasty habit of dropping data and causing the transfer to fail. If you add in an older router that may well be starting to have degrading performance (it happens), apartment walls made of solid cinderblock and interference from other tenant's wifi networks/devices you have a recipe for unhappy networking.

Solutions. Ranked less-drastic to drastic.

1. Update your router's firmaware, move it away from cordless phone bases, elevate it's position to somewhere high like the top of a bookcase.

2. Buy one or two wifi extender boxes to boost your router's signal strength.

3. Ditch Vista. Microsoft is allowing free, 1 year trials of Windows 7. My wifi file transfer rate is now around 2-3mb/sec and I don't get drop-outs with Windows 7.
Windows 7 is actually pretty solid and much more efficient than Vista, even in it's Beta form. Or if you're really bitter with Microsoft try Linux.

4. Buy a new router. I had a router that's performance gradually degraded. I am now the proud owner of a Linksys WRT610N which offers great wifi coverage, but otherwise is a piece of **** because all the other stuff it purports to do doesn't work very well or not at all. I recommend browsing CNET's reviews http://reviews.cnet.com/ and then using Pricespy http://www.pricespy.co.nz/c_88.html?d=8834 to find the best deal on the router you choose. You can also check these guys out http://www.acquire.co.nz/acquire/default.asp?PageID=Home&mscssid=EECKEB1XFSSR2K340G05A4H50BH3D1S0 they have a great selection and often run really good product category promotions.

Lazarui
22-05-2009, 04:44 PM
Thanks mate I'll give those a shot!

I'm more of a hardware guy not very good with the in's and outs of the whole wireless network stuff so this'll be a big help!

Blam
22-05-2009, 06:01 PM
Update your wireless router's firmware.

How is the wireless strength?

Blam
22-05-2009, 06:28 PM
Just remembered....a 3rd party firewall can cause slow network transfer speeds, disable one if you have an external one.

Also try disabling Remote Differential Compression

Start>Control Panel>Programs and Features

Click on ‘Turn windows features on or off’ on the left side of the screen

Uncheck ‘Remote Differential Compression’

Blam