PDA

View Full Version : Desktop Icons disappear on startup



theother1
23-03-2009, 01:15 PM
Says it all really.
Some of you my remember that I had this problem back in January. This one may be the same but has slightly different symptoms.
Now when I boot up the desktop icons show up and then disappear and when I start Outlook it shows a message to say that a data file didn't close properly and is being checked.
I will do a Hijack this scan and post back.

theother1
23-03-2009, 01:24 PM
Logfile of Trend Micro HijackThis v2.0.2
Scan saved at 1:22:51 p.m., on 23/03/2009
Platform: Windows Vista SP1 (WinNT 6.00.1905)
MSIE: Internet Explorer v7.00 (7.00.6001.18000)
Boot mode: Normal

Running processes:
C:\Windows\system32\Dwm.exe
C:\Windows\system32\taskeng.exe
C:\Windows\system32\taskeng.exe
C:\Windows\Explorer.EXE
C:\Program Files\ASUS\ASUS CopyProtect\aspg.exe
C:\Program Files\ASUS\ASUS Live Update\ALU.exe
C:\Program Files\ASUS\SmartLogon\sensorsrv.exe
C:\Program files\P4G\BatteryLife.exe
C:\Program Files\CyberLink\Power2Go\CLMLSvc.exe
C:\Program Files\ASUS\ATK Hotkey\HControlUser.exe
C:\Program Files\ASUS\ATKOSD2\ATKOSD2.exe
C:\Windows\System32\hkcmd.exe
C:\Windows\RtHDVCpl.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\Program Files\ASUS\ATK Media\DMedia.exe
C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe
C:\Program Files\AVG\AVG8\avgtray.exe
C:\Program Files\iTunes\iTunesHelper.exe
C:\Windows\ehome\ehtray.exe
C:\Program Files\Windows Media Player\wmpnscfg.exe
C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNo tifier.exe
C:\Windows\system32\igfxsrvc.exe
C:\Program Files\WIDCOMM\Bluetooth Software\BTTray.exe
C:\Windows\ehome\ehmsas.exe
C:\Program Files\Protector Suite QL\psqltray.exe
C:\Windows\system32\wbem\unsecapp.exe
C:\Program Files\Internet Explorer\iexplore.exe
C:\Program Files\Lavasoft\Ad-Aware\AAWTray.exe
C:\Program Files\Internet Explorer\IEUser.exe
C:\Program Files\Google\Google Toolbar\GoogleToolbarUser.exe
C:\Program Files\Synaptics\SynTP\SynTPHelper.exe
C:\Windows\system32\SearchFilterHost.exe
C:\Program Files\Trend Micro\HijackThis\HijackThis.exe

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = http://www.google.co.nz/webhp?rls=ig
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = http://go.microsoft.com/fwlink/?LinkId=54896
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = http://go.microsoft.com/fwlink/?LinkId=54896
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Int ernet Settings,ProxyOverride = *.local
R0 - HKCU\Software\Microsoft\Internet Explorer\Toolbar,LinksFolderName =
O1 - Hosts: ::1 localhost
O2 - BHO: Adobe PDF Reader Link Helper - {06849E9F-C8D7-4D59-B87D-784B7D6BE0B3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelper.dll
O2 - BHO: AskBar BHO - {201f27d4-3704-41d6-89c1-aa35e39143ed} - C:\Program Files\AskBarDis\bar\bin\askBar.dll
O2 - BHO: Skype add-on (mastermind) - {22BF413B-C6D2-4d91-82A9-A0F997BA588C} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O2 - BHO: WormRadar.com IESiteBlocker.NavFilter - {3CA2F312-6F6E-4B53-A66E-4E65E497C8C0} - C:\Program Files\AVG\AVG8\avgssie.dll
O2 - BHO: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL
O2 - BHO: Google Toolbar Helper - {AA58ED58-01DD-4d91-8333-CF10577473F7} - C:\Program Files\Google\Google Toolbar\GoogleToolbar.dll
O2 - BHO: Google Toolbar Notifier BHO - {AF69DE43-7D58-4638-B6FA-CE66B5AD205D} - C:\Program Files\Google\GoogleToolbarNotifier\5.0.926.3450\sw g.dll
O2 - BHO: Google Dictionary Compression sdch - {C84D72FE-E17D-4195-BB24-76C02E2E7C4E} - C:\Program Files\Google\Google Toolbar\Component\fastsearch_219B3E1547538286.dll
O3 - Toolbar: &Google Toolbar - {2318C2B1-4965-11d4-9B18-009027A5CD4F} - C:\Program Files\Google\Google Toolbar\GoogleToolbar.dll
O3 - Toolbar: ZoneAlarm Spy Blocker Toolbar - {3041d03e-fd4b-44e0-b742-2d9b88305f98} - C:\Program Files\AskBarDis\bar\bin\askBar.dll
O3 - Toolbar: AVG Security Toolbar - {A057A204-BACC-4D26-9990-79A187E2698E} - C:\PROGRA~1\AVG\AVG8\AVGTOO~1.DLL
O4 - HKLM\..\Run: [CLMLServer] "C:\Program Files\CyberLink\Power2Go\CLMLSvc.exe"
O4 - HKLM\..\Run: [P2Go_Menu] "C:\Program Files\CyberLink\Power2Go\MUITransfer\MUIStartMenu. exe" "C:\Program Files\CyberLink\Power2Go" UpdateWithCreateOnce "SOFTWARE\CyberLink\Power2Go\6.0"
O4 - HKLM\..\Run: [HControlUser] C:\Program Files\ASUS\ATK Hotkey\HControlUser.exe
O4 - HKLM\..\Run: [ATKOSD2] C:\Program Files\ASUS\ATKOSD2\ATKOSD2.exe
O4 - HKLM\..\Run: [HotKeysCmds] C:\Windows\system32\hkcmd.exe
O4 - HKLM\..\Run: [RtHDVCpl] RtHDVCpl.exe
O4 - HKLM\..\Run: [PSQLLauncher] "C:\Program Files\Protector Suite QL\launcher.exe" /startup
O4 - HKLM\..\Run: [SynTPEnh] C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
O4 - HKLM\..\Run: [ATKMEDIA] C:\Program Files\ASUS\ATK Media\DMedia.exe
O4 - HKLM\..\Run: [ZoneAlarm Client] "C:\Program Files\Zone Labs\ZoneAlarm\zlclient.exe"
O4 - HKLM\..\Run: [AVG8_TRAY] C:\PROGRA~1\AVG\AVG8\avgtray.exe
O4 - HKLM\..\Run: [iTunesHelper] "C:\Program Files\iTunes\iTunesHelper.exe"
O4 - HKCU\..\Run: [ehTray.exe] C:\Windows\ehome\ehTray.exe
O4 - HKCU\..\Run: [WMPNSCFG] C:\Program Files\Windows Media Player\WMPNSCFG.exe
O4 - HKCU\..\Run: [swg] C:\Program Files\Google\GoogleToolbarNotifier\GoogleToolbarNo tifier.exe
O4 - HKUS\S-1-5-19\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-19\..\Run: [WindowsWelcomeCenter] rundll32.exe oobefldr.dll,ShowWelcomeCenter (User 'LOCAL SERVICE')
O4 - HKUS\S-1-5-20\..\Run: [Sidebar] %ProgramFiles%\Windows Sidebar\Sidebar.exe /detectMem (User 'NETWORK SERVICE')
O4 - Global Startup: Adobe Gamma Loader.exe.lnk = C:\Program Files\Common Files\Adobe\Calibration\Adobe Gamma Loader.exe
O4 - Global Startup: Bluetooth.lnk = ?
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office12\EXCEL.EXE/3000
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: S&end to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\PROGRA~1\MICROS~2\Office12\ONBttnIE.dll
O9 - Extra button: Skype - {77BF5300-1474-4EC7-9980-D32B190E9B07} - C:\Program Files\Skype\Toolbars\Internet Explorer\SkypeIEPlugin.dll
O9 - Extra button: Research - {92780B25-18CC-41C8-B9BE-3C9C571A8263} - C:\PROGRA~1\MICROS~2\Office12\REFIEBAR.DLL
O16 - DPF: {D27CDB6E-AE6D-11CF-96B8-444553540000} (Shockwave Flash Object) - http://fpdownload2.macromedia.com/get/shockwave/cabs/flash/swflash.cab
O18 - Protocol: linkscanner - {F274614C-63F8-47D5-A4D1-FBDDE494F8D1} - C:\Program Files\AVG\AVG8\avgpp.dll
O18 - Protocol: skype4com - {FFC8B962-9B40-4DFF-9458-1830C7DD7F5D} - C:\PROGRA~1\COMMON~1\Skype\SKYPE4~1.DLL
O20 - AppInit_DLLs: C:\PROGRA~1\Google\GOOGLE~1\GOEC62~1.DLL,avgrsstx. dll
O23 - Service: Apple Mobile Device - Apple Inc. - C:\Program Files\Common Files\Apple\Mobile Device Support\bin\AppleMobileDeviceService.exe
O23 - Service: ASKService - Unknown owner - C:\Program Files\AskBarDis\bar\bin\AskService.exe
O23 - Service: ASLDR Service (ASLDRService) - Unknown owner - C:\Program Files\ASUS\ATK Hotkey\ASLDRSrv.exe
O23 - Service: ATKGFNEX Service (ATKGFNEXSrv) - Unknown owner - C:\Program Files\ATKGFNEX\GFNEXSrv.exe
O23 - Service: AVG Free8 WatchDog (avg8wd) - AVG Technologies CZ, s.r.o. - C:\PROGRA~1\AVG\AVG8\avgwdsvc.exe
O23 - Service: Bonjour Service - Apple Inc. - C:\Program Files\Bonjour\mDNSResponder.exe
O23 - Service: Bluetooth Service (btwdins) - Broadcom Corporation. - C:\Program Files\WIDCOMM\Bluetooth Software\bin\btwdins.exe
O23 - Service: Google Desktop Manager 5.8.809.23506 (GoogleDesktopManager-092308-165331) - Google - C:\Program Files\Google\Google Desktop Search\GoogleDesktop.exe
O23 - Service: Google Updater Service (gusvc) - Google - C:\Program Files\Google\Common\Google Updater\GoogleUpdaterService.exe
O23 - Service: iPod Service - Apple Inc. - C:\Program Files\iPod\bin\iPodService.exe
O23 - Service: Lavasoft Ad-Aware Service - Lavasoft - C:\Program Files\Lavasoft\Ad-Aware\AAWService.exe
O23 - Service: LightScribeService Direct Disc Labeling Service (LightScribeService) - Hewlett-Packard Company - C:\Program Files\Common Files\LightScribe\LSSrvc.exe
O23 - Service: spmgr - Unknown owner - C:\Program Files\ASUS\NB Probe\SPM\spmgr.exe
O23 - Service: TrueVector Internet Monitor (vsmon) - Check Point Software Technologies LTD - C:\Windows\System32\ZoneLabs\vsmon.exe

--
End of file - 8322 bytes

Speedy Gonzales
23-03-2009, 01:34 PM
Whats the name of the file Outlook is checking?

Uninstall Askbar

theother1
23-03-2009, 01:47 PM
Funny thing is, it didn't check anything on most recent boot. Go figure.
What is Askbar?

Speedy Gonzales
23-03-2009, 01:52 PM
This

O2 - BHO: AskBar BHO - {201f27d4-3704-41d6-89c1-aa35e39143ed} - C:\Program Files\AskBarDis\bar\bin\askBar.dll

O3 - Toolbar: ZoneAlarm Spy Blocker Toolbar - {3041d03e-fd4b-44e0-b742-2d9b88305f98} - C:\Program Files\AskBarDis\bar\bin\askBar.dll

O23 - Service: ASKService - Unknown owner - C:\Program Files\AskBarDis\bar\bin\AskService.exe

It probably installed, when you installed a program (probably Google toolbar / zonealarm), if you didnt do a custom install and unticked it

Some sites say its malware

theother1
23-03-2009, 02:54 PM
Thanks Speedy,
OK, Did that but Icons still disappear!

Blam
23-03-2009, 02:59 PM
Askbar is just a toolbar installed with some programs.

Not dangerous-just unneeded.

What is the exact outlook message?

Download MalwareBytesAntiMalware and run a full scan.

Update first.

http://www.malwarebytes.org/

See if it fixes the icon problem

theother1
23-03-2009, 03:25 PM
I have restarted 3 times now without the outlook message coming up. Sorry can't tell you more about it.

Rob99
23-03-2009, 03:42 PM
Outlook was probally checking the pst file, it will do this from time to time when outlook does not close fully when turning off the computer. Not too much to worry about.

wainuitech
23-03-2009, 04:31 PM
If you are still having problems with the desktop Icons disappearing - Check this -

Right click the Desktop>View- Make sure "Show Desktop icons" is ticked

theother1
23-03-2009, 07:59 PM
Thanks Wainui, Yes I have done that but it is annoying when you have to do it on every bootup.
Blam, have run the malware scan - no malicious items detected.

Malwarebytes' Anti-Malware 1.34
Database version: 1887
Windows 6.0.6001 Service Pack 1

23/03/2009 7:35:43 p.m.
mbam-log-2009-03-23 (19-35-43).txt

Scan type: Full Scan (C:\|D:\|)
Objects scanned: 166737
Time elapsed: 2 hour(s), 32 minute(s), 31 second(s)

Memory Processes Infected: 0
Memory Modules Infected: 0
Registry Keys Infected: 0
Registry Values Infected: 0
Registry Data Items Infected: 0
Folders Infected: 0
Files Infected: 0

Memory Processes Infected:
(No malicious items detected)

Memory Modules Infected:
(No malicious items detected)

Registry Keys Infected:
(No malicious items detected)

Registry Values Infected:
(No malicious items detected)

Registry Data Items Infected:
(No malicious items detected)

Folders Infected:
(No malicious items detected)

Files Infected:
(No malicious items detected)

theother1
23-03-2009, 08:10 PM
I don't know what I did but just restarted and everything seems back to normal.
Thanks Speedy, Blam and Wainui.:)

Blam
23-03-2009, 08:14 PM
You may have to use trial an error.

See if it happens in safe mode-if it still does, it may be something wrong in the registry/system files

Otherwise-if it works fine in safe mode then it is most probably a peice of sftware causing this.

You will have to open msconfig then tick one program at a time until the problem happens again.

Blam

EDIT: Dang:p Just saw your post!

R2x1
23-03-2009, 09:52 PM
Have your icons been paid lately? Have they had any holidays?

They may be on strike. :(

theother1
23-03-2009, 10:16 PM
It isn't school holidays is it?
Guys,
The problem just came back and I didn't even reboot. Computer had been sleeping woke it up and the Icons were gone!!!!!!!

Rob99
23-03-2009, 10:23 PM
Does it only happen when coming out of sleep?

Blam
23-03-2009, 10:41 PM
It isn't school holidays is it?
Guys,
The problem just came back and I didn't even reboot. Computer had been sleeping woke it up and the Icons were gone!!!!!!!

Try what I posted above.

My guest is software interference.

You'll have to use the process of elimination:p

theother1
23-03-2009, 10:54 PM
Thanks Blam, Not my favourite option, but if that is the best anyone can suggest it will have to do.
Rob, it seems to happen on startup or wakeup

Rob99
23-03-2009, 11:06 PM
You may have some bad system files.

Next time they dissapear; Ctrl Alt Delete > Processes tab, find explorer.exe > click end process button > applications tab, new task button > type "explorer.exe".

Do they come back?

Another thing to try would be a system file check

Speedy Gonzales
23-03-2009, 11:25 PM
Do the taskbar icons disappear as well ??

Is hibernation enabled or disabled?

I would check event viewer, and look under system / application (for the time it happens).

And see what it says..Explorer.exe is probably crashing (why the icons disappear). Tell us what the event id is for it / them

Blam
24-03-2009, 09:33 AM
Just to clarify...is it both taskbar and icons not loading properly?

or JUST icons?

wainuitech
24-03-2009, 09:42 AM
You may need to rebuild the Icon Cache -- Its possibly damaged.

Click the start orb, type in CMD - in the results, Right click, Run as Administrator

Bring up the task manager - CTRL+SHIFT+ESC

Shutdown Explorer Process from the Task Manager

In the CMD window go to C:\Users\<ProfileName>\AppData\Local
Do the following command: attrib -H IconCache.db
Do the following command: del IconCache.db
Do the following command: start explorer

This should rebuild the Icon Cache

wainuitech
24-03-2009, 10:08 AM
Edit to above- in the command line C:\Users\<ProfileName>\AppData\Local

When opened the CMD window put in CD C:\Users\<ProfileName>\AppData\Local


Forgot the CD -- Opps:o

theother1
25-03-2009, 08:57 PM
Thanks guys,
I haven't done anything since my last post but evrything seems to have returned to normal???????????????????????!!!!!!!!!!!!!!!!
Computers, who would know?:confused:

theother1
26-05-2009, 01:49 PM
Thought you would all be fascinated to know that this problem has recurred.
This morning when I started up (not on wake up) all desktop icons were absent. Taskbar icons still present. Show desktop icons is ticked and when I untick it then tick it again the icons reappear.
Anyone?

Speedy Gonzales
26-05-2009, 01:59 PM
Install SP2 when it comes out, it should be out 28/29th / this week

theother1
26-05-2009, 02:02 PM
Thanks Speedy,
I have auto updates enabled so I guess I will get whether I want it or not.
Cheers
Rob

wainuitech
26-05-2009, 02:09 PM
Hopefully the Auto update is smaller than the full update package - Which is 476.20MB (http://www.imagef1.net.nz/files/Vista_SP2.jpg) - Should be.

Speedy Gonzales
26-05-2009, 02:15 PM
Hate to see what the 64 bit update is then if thats 476 mb

wainuitech
26-05-2009, 03:25 PM
DONT LOOK Speedy (http://www.imagef1.net.nz/files/Vista_64.jpg) -- Seems it may be both - Auto updates should be a LOT smaller - one would hope so any way.

Speedy Gonzales
26-05-2009, 03:38 PM
So that includes all of them in one download? Thats fine by me, at least it wont go towards my data usage :p . Even tho I dont have Vista

theother1
16-06-2009, 02:49 PM
You may have some bad system files.

Next time they dissapear; Ctrl Alt Delete > Processes tab, find explorer.exe > click end process button > applications tab, new task button > type "explorer.exe".

Do they come back?

Another thing to try would be a system file check

This problem has come back recently I did the explorer.exe end process thing and they came back but they are gone each time I reboot and have to do that thing again.

theother1
16-06-2009, 02:51 PM
Just to clarify...is it both taskbar and icons not loading properly?

or JUST icons?

Just the Desktop Icons, Blam

Speedy Gonzales
16-06-2009, 02:56 PM
So have you installed SP2 yet?

theother1
16-06-2009, 03:02 PM
I though it was installed automatically but I will try MS and see if I can see it. I did look for updates for my comp and just downloaded all the updates they recommended.
Thanks for the reminder.

Speedy Gonzales
16-06-2009, 03:13 PM
Right mouse / properties on my computer on the desktop (if its there). It'll tell you what SP is installed. Altho it may / should have told you to reboot, if it installed

Blam
16-06-2009, 03:34 PM
So does it happen when you boot into safe mode?

theother1
16-06-2009, 04:04 PM
So have you installed SP2 yet?

Yes, done now and what do you know? the icons don't seem to be disappearing!!!!!

Thanks for your help, O wise one!:thanks

Speedy Gonzales
16-06-2009, 04:17 PM
Cool !

theother1
18-06-2009, 12:05 PM
This is starting to get old really. The Desktop Icons have disappeared again.
Installed SP2 earlier this week and everything looked good.
However, on start up yesterday I noticed that the icons were missing again.
Silly really, but I am so used to them not being there that it took me a while to realise they were missing!!!!!!!!!!!:badpc:

Rob99
18-06-2009, 12:40 PM
Try a system file check.

Start > Run > sfc /scannow

wainuitech
18-06-2009, 01:20 PM
looking at the hijack log - is this an Asus notebook ??

If so

-Right click the Power icon in the system tray
-Select Power4Gear Extreme
-Click continue on the UAC prompt
-Make sure the 'Quiet Office' plan is selected
-In the lower right corner, there is an option to 'Hide Desktop Icons'. Set this to No

theother1
18-06-2009, 01:58 PM
Despite the prompts having different names, I managed to find my way there and the Hide Desktop icons was set to yes. I have changed it and will now reboot and see what happens. Thanks Wainui, Champion.

theother1
18-06-2009, 04:32 PM
Thanks Wainui
That seems to have done the trick.
Now to get the other computer fixed.

wainuitech
18-06-2009, 06:09 PM
no Problems - glad to be able to help keep your sanity :thumbs: