PDA

View Full Version : How to turn on function keys at startup?



davehold
05-03-2009, 11:52 AM
Can anyone tell me how to have the function keys automatically activated at startup under XP Pro?

wratterus
05-03-2009, 11:59 AM
Bit more info would be good.

Are you talking about a laptop or desktop? You mean the 'Fn' key on the laptop?

Whats the brand of laptop?

Were they working before? Did they just stop working? What do you currently do to get them working?

davehold
05-03-2009, 12:04 PM
Ooops.. I mam using a MS wireless keyboard and mouse

davehold
05-03-2009, 12:06 PM
my apologies for just sending a quick fire post. I am using a desktop with a MS wireless keyboard and mouse under a XP Pro SP3 OS. I would like the function keys to be activated automatically on startup as presently I have to hit the F lock key on the keyboard everytime I start or come out of standby. Thanks

Speedy Gonzales
05-03-2009, 12:18 PM
You shouldnt have to activate anything on startup.

Im using an MS wireless kb / mouse as well. All the keys work fine, everytime I reboot

Its probably because that kb has that F lock key.

davehold
05-03-2009, 12:32 PM
You shouldnt have to activate anything on startup.

Im using an MS wireless kb / mouse as well. All the keys work fine, everytime I reboot

Its probably because that kb has that F lock key.

The keyboard starts up using the upper F key functions and not the default ones but when I hit the F lock key (and the indicator lights) the F keys return to the defaults (as per my laptop F keys). Does this mean that I just have to live with this quirky MS setup for this kb?

Speedy Gonzales
05-03-2009, 12:39 PM
Umm yup, or take it back, replace it with a kb that doesnt have a F lock key

Unless there's an option in control panel under keyboard for it

Cicero
05-03-2009, 12:48 PM
The keyboard starts up using the upper F key functions and not the default ones but when I hit the F lock key (and the indicator lights) the F keys return to the defaults (as per my laptop F keys). Does this mean that I just have to live with this quirky MS setup for this kb?

It must be in the settings,have you looked in K/B settings?

Erayd
05-03-2009, 01:05 PM
This can't actually be disabled except via a registry hack - it's a particularly braindead move on MS's part, but there you go.

Grab the file from here (http://mirror.erayd.net/pressf1/misc/f-lock_killer.zip), unzip it, and run '2gfl-e.reg'. If you decide you don't like the changes and want to revert to the old behavior, 'undo.reg' will put it back.

davehold
05-03-2009, 01:42 PM
This can't actually be disabled except via a registry hack - it's a particularly braindead move on MS's part, but there you go.

Grab the file from here (http://mirror.erayd.net/pressf1/misc/f-lock_killer.zip), unzip it, and run '2gfl-e.reg'. If you decide you don't like the changes and want to revert to the old behavior, 'undo.reg' will put it back.

DOH !!! Thats not what I wanted to hear (wanna give me another answer...lol) I dont think I have the confidence to start hacking my registry options so maybe I will just have to live with hitting the F-lock key.

Rob99
05-03-2009, 01:57 PM
Think of it as a settings adjustment, and not a reg hack, give it a go.

There are plenty of these "settings adjustments" around, easy to apply and easy to undo.

Erayd
05-03-2009, 02:04 PM
DOH !!! Thats not what I wanted to hear (wanna give me another answer...lol) I dont think I have the confidence to start hacking my registry options so maybe I will just have to live with hitting the F-lock key.Just give it a go - it's not hard, and shouldn't break anything :).

Note you will need to reboot after applying or removing this for it to take effect.

davehold
05-03-2009, 02:10 PM
Think of it as a settings adjustment, and not a reg hack, give it a go.

There are plenty of these "settings adjustments" around, easy to apply and easy to undo.

OK...you have convinced me to give it a shot. Will report back.
(Hi ho hi ho... its off to hack I go...)

davehold
05-03-2009, 02:27 PM
This can't actually be disabled except via a registry hack - it's a particularly braindead move on MS's part, but there you go.

Grab the file from here (http://mirror.erayd.net/pressf1/misc/f-lock_killer.zip), unzip it, and run '2gfl-e.reg'. If you decide you don't like the changes and want to revert to the old behavior, 'undo.reg' will put it back.

OK...tried that.. but can I ask a dumb question? It doesnt look like an executable to me but I tried RUN under the start menu and pointed to "2gfl-e.reg" and then rebooted. Nothing has changed. I also just double clicked on the above and rebooted. Again nothing. So is this supposed to be done via a reg editor with a cut and paste or run from within e reg editor or another programme?

Speedy Gonzales
05-03-2009, 02:33 PM
Its not an executable its a registry file (which is why it ends in reg).

Which ends up in the registry. Depending on whats in it

After you ran it, did you click on YES?

Rob99
05-03-2009, 02:37 PM
You could also right click the reg file, then select merge.

davehold
05-03-2009, 02:38 PM
After I ran it... nothing happened, there was no box asking me to tick yes. Just nadda, either from the run command or from double click.

davehold
05-03-2009, 02:43 PM
Jus tried it again and the only thing that happened is that the file was opened in Notepad.

Rob99
05-03-2009, 02:51 PM
did the file contain this
Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,0d,00,00,00,3b,00,3b, e0,3c,00,08,e0,\
3d,00,07,e0,3e,00,3e,e0,3f,00,3f,e0,40,00,40,e0,41 ,00,41,e0,42,00,42,e0,43,\
00,43,e0,44,00,23,e0,57,00,57,e0,58,00,58,e0,00,00 ,00,00

Make sure it has .reg as the extention, then right click > merge

Speedy Gonzales
05-03-2009, 02:56 PM
Hmm there's another one here (http://www.msfn.org/board/index.php?showtopic=9314)

Seems to have more in it

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,19,00,00,00,3b,00,3b, e0,3c,00,08,e0,\
3d,00,07,e0,3e,00,3e,e0,3f,00,3f,e0,40,00,40,e0,41 ,00,41,e0,42,00,42,e0,43,\
00,43,e0,44,00,23,e0,57,00,57,e0,58,00,58,e0,3b,e0 ,3b,00,08,e0,3c,00,07,e0,\
3d,00,3e,e0,3e,00,3f,e0,3f,00,40,e0,40,00,41,e0,41 ,00,42,e0,42,00,43,e0,43,\
00,23,e0,44,00,57,e0,57,00,58,e0,58,00,00,00,00,00

Try that copy it from here, paste it into notepad, file / save as.

Change it to all files alongside save as type. Give it a name (with .reg at the end), double click on it, say yes if it asks, then reboot

davehold
05-03-2009, 02:58 PM
After right clicking the file opened a notepad window, which contained the following

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,0d,00,00,00,3b,00,3b, e0,3c,00,08,e0,\
3d,00,07,e0,3e,00,3e,e0,3f,00,3f,e0,40,00,40,e0,41 ,00,41,e0,42,00,42,e0,43,\
00,43,e0,44,00,23,e0,57,00,57,e0,58,00,58,e0,00,00 ,00,00

There was no merge option in notepad and I have no idea as to what to do from here.

Speedy Gonzales
05-03-2009, 03:01 PM
Merge isnt in notepad, you right mouse on that file and then select merge.

You dont open it in notepad

davehold
05-03-2009, 03:02 PM
Did everything you suggested speedy, and saved the file to keyboard.reg in the root directory of my OS. Double clicked and it just opened the file in notepad with no options. Reboot made no difference.

davehold
05-03-2009, 03:04 PM
Also right clicked on the file, chose merge, and the same result. The file just opens in notepad and sits there.

Speedy Gonzales
05-03-2009, 03:07 PM
Sounds like something is stuffed on your PC then, if its not working

Did you change txt to all files?? Then save. You should only have file.reg, not file.txt.reg when you saved it

davehold
05-03-2009, 03:14 PM
Sounds like something is stuffed on your PC then, if its not working

aww sh*t. Now thats something I didnt want to hear.

Sounds like something is stuffed on your PC... thats just too specific for me, can you be a little more general for me :illogical

Maybe I can live with the F-Lock after all.

Steven
05-03-2009, 03:15 PM
For your set up this is what you need to do http://jtsang.mvps.org/usb_intellitype.html

Speedy I would guess that he has file extensions hidden and so when saving as xxx.reg will get xxx.reg.txt but not see the .txt