PDA

View Full Version : Modifying the OS selection menu in XP



samnorr
15-01-2009, 10:47 PM
My PC currently has two different choices on the OS boot selection menu (both are Windows XP). This came about when I had to reinstall Windows a while ago because of a corrupt system file. I performed an upgrade installation, because I didn't want to lose all my files and settings, and they were not backed up at the time. But unfortunately this resulted in another separate Windows installation being put on the same partition, so there is now two Windows XP choices on the boot menu.

I have deleted the original Windows folder off the C drive, but I have no idea how to delete that installation entirely and get rid of it's boot menu entry.

I would apreciate any help. :)

Chilling_Silence
15-01-2009, 10:52 PM
*carefully* remove the entry from the C:\boot.ini file

Or, you can press the WinKey + Pause/Break
Click the Advanced Tab
Click Startup and Recovery, then just change the defaults in there :)

bob_doe_nz
15-01-2009, 11:54 PM
When you get the option of two XP versions at startup, which one do you want to remove?

And what is the folder containing the NEW windows? E.g is it C:\Windows or is it C:\WinXP. Remember that.

Once you know what it is, do the following...


Open up My Computer
At the top, click Tools / Folder Options / At the top, Click View
Where it says "Hide Protected Operating System Files (Recommended)" Make sure it is unticked.
Click OK.

Now if you look at the C: Drive, there should be a file called Boot.ini.


Right Click the file / Click Properties / Make sure "Read Only" is unticked / Click OK

Also, make a copy of boot.ini at this time.


Open the file with Notepad and make it full screen


At the top menu, click Format / Make sure there is NO tick beside "Word Wrap"
If there is... Click Word Wrap.



You will now get something that looks like...

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /usepmtimer /NoExecute=OptIn
multi(0)disk(0)rdisk(0)partition(1)\WINXP="Microsoft Windows XP Professional" /fastdetect /usepmtimer /NoExecute=OptIn

Find which line contains your new windows folder. Lets say it's WinXP.

You then need to remove the line containing the old Windows Folder so it looks like...


[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINXP
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINXP="Microsoft Windows XP Professional" /fastdetect /usepmtimer /NoExecute=OptIn

See that lines 3 and 5 have changed? Then, save the boot.ini file.

Reboot your computer, with luck it should boot without a menu with no problems.

Blam
16-01-2009, 12:46 AM
Actually the easiest way would be to get to msconfig(Run>MSCONFIG)>Get to the BOOT.INI tab>Click "check all boot paths"

Blam

samnorr
16-01-2009, 01:55 AM
Thank you all very much for your help, I just followed your advice and deleted the unwanted line from the Boot.ini file, and it worked perfectly! :thanks