PDA

View Full Version : Laptop XP user menu stops at desktop ! ?



Digby
01-12-2008, 03:06 PM
Hi Guys

My fiend has a laptop that boots up OK and gives you the Users Menu. When you click on a user it goes to their desktop but only shows their wallpaper - no icons. And you cannot get any further.

Sometimes I see a message about "Userinit.exe - Failed to initialize properly"

Any suggestions ?

FoxyMX
01-12-2008, 03:15 PM
Sometimes I see a message about "Userinit.exe - Failed to initialize properly"


I had that problem recently. The error message was related to Norton's and all the malware on the PC. I can't remember exactly how I got all the icons back but I think I used CTRL+ALT+DEL to bring up the Task Manager and they all appeared. :stare:

Either way it probably needs a good clean up. Can you boot into Safe Mode?

wratterus
01-12-2008, 03:17 PM
Go into the task manager as Foxy said, then check in the processes list if explorer.exe is started.

I doubt it is, if it isn't, in the task manager go to (File/new task/run) type in explorer.exe and press enter, do you get an error or does explorer start?

It does sound like the PC is a bit messy, clean it out with all the stuff in Speedy's sig (http://pressf1.pcworld.co.nz/member.php?u=8532) and then post a hijackthis log. :)

jwil1
01-12-2008, 03:44 PM
Sounds like a PC I had in once - wouldn't load desktop etc - like wratterus said, run explorer.exe from Task Manager :)

This worked for me - and then I cleaned the mountains of malware off it.....

Digby
01-12-2008, 03:48 PM
Thanks Guys

Yes I did a Ctrl Alt + Del and there was no Explorer, so I typed it and I got all the icons back.

Yes it is a mess, but at least I can start work on it now.

Thanks

Speedy Gonzales
01-12-2008, 03:49 PM
It definitely sounds like something nasty has screwed things up

Blam
01-12-2008, 04:03 PM
Yes, sounds like a virus is mucking about.

Before you clean it turn off system restore first

wainuitech
01-12-2008, 04:06 PM
Its full of spyware Alright - one suggestion that wratterus posted a while back - also check out: Once on the desktop, click start/run type in regedit navigate to

HKLM/Software/Microsoft/Windows NT/Current Version/Image File Execution Options/Explorer.exe

Remove The “Debugger” registry key. - if its there.

Then clean out the Spyware.

wratterus
01-12-2008, 04:07 PM
Its full of spyware Alright - one suggestion that wratterus posted a while back - also check out: Once on the desktop, click start/run type in regedit navigate to

HKLM/Software/Microsoft/Windows NT/Current Version/Image File Execution Options/Explorer.exe

Remove The “Debugger” registry key. - if its there.

Then clean out the Spyware.

Yep - thats happened a lot for me recently.

Digby
02-12-2008, 06:00 AM
Thanks for all the help guys.
I got explorer going and disabled a couple of entries in MsConfig.
Now it starts up OK so I can start to work on all the spyware etc.
I will check the registry !