PDA

View Full Version : Colour in win media player.



Cicero
27-11-2008, 09:29 PM
I have good colour in everything apart from WMP.
The colour is all washed out,wonder what the matter can be?

Renmoo
27-11-2008, 09:34 PM
Tools > Options > Performance: Check "Video Acceleration" is set to full.

Does this apply to other media players as well? How long has this happened? Have you tried System Restore?

Cheers :)

Cicero
27-11-2008, 09:46 PM
Tools > Options > Performance: Check "Video Acceleration" is set to full.

Does this apply to other media players as well? How long has this happened? Have you tried System Restore?

Cheers :)
Can't find performance check in XP.

I have had this prob for some time,just been given 20 good movies and not nice as it is at mo.

I don't use other media,so can't say.

wainuitech
27-11-2008, 10:05 PM
Might be barking up the wrong tree here - but to find performance you need the classic menu's , if you dont have it showing right click on a black section of the top Bar As shown Here (http://www.imagef1.net.nz/files/Classic.jpg) ( to the left of Now playing button Here (http://www.imagef1.net.nz/files/Here1227777091.jpg) ) and select classic menu - then you'll find Tools > Options > Performance etc.

While looking also check View>Enhancements>Video Path shown (http://www.imagef1.net.nz/files/View.jpg) and Check these settings (http://www.imagef1.net.nz/files/Check_Settings.jpg) - something may have changed as these will change the way every thing looks, hit reset to put back to default.

Edited: to close the video setting the small Red X is in the right hand corner.

kersonan
27-11-2008, 10:09 PM
Just as a way of checking that the issue is in fact isolated to WMP, can you try the same file via a different player

http://www.videolan.org/vlc/download-windows.html

VLC is a far superior media player and not known to require codec packs in order to play the many different packaging methods.

Cicero
27-11-2008, 10:33 PM
I looked at settings and all seemed OK,if I alter setting,it makes no difference to pic colour,in other words no matter how I alter settings,nothing happens.
I downloaded VLC media and colour is bad on that too.
Meantime thanks for efforts lads.

wainuitech
27-11-2008, 10:37 PM
Okay - work through this (http://support.microsoft.com/kb/306317)

Cicero
27-11-2008, 11:03 PM
Okay - work through this (http://support.microsoft.com/kb/306317)
These are parts I thought related to colour and they said not avilable on the run menu?"Windows can't find dxdiag,etc."




Try to play the file in Mplayer2:
Click Start, click Run, and then type mplayer2.
Click OK.
On the File menu, click Open, and then select the media in question.
Run the DirectX diagnostics as Windows Media Player is very dependent on DirectX:
Click Start, click Run, and then type dxdiag.
Click OK.
In the DirectX Diagnostic Tool, click the Display tab.
"Windows can't find dxdiag,etc."

kersonan
28-11-2008, 07:57 AM
Was having a bit of a think about this on the way into the office this morning. Perhaps its being caused by an old codec?

Grab this app, Gspot (yes I know, sounds a little odd)
http://www.headbands.com/gspot/

What it does is identifies the codec that the video file is using and tells you if you have it installed and if your copy is up to date. I've found it quite helpfull in the past

I would also update your DirectX install to the latest version.

wainuitech
28-11-2008, 08:28 AM
if DirectX is playing up that will cause problems. you can get DirectX 9.0 (http://www.microsoft.com/downloads/details.aspx?familyid=9226a611-62fe-4f61-aba1-914185249413&displaylang=en) from that link.

To reinstall mplayer2 according to This site (http://www.moviecodec.com/topics/5976p1.html)you have to reinstall WMP 10.

autechre
28-11-2008, 09:13 AM
If you're going to download DirectX 9, get the November 2008 (http://www.microsoft.com/downloads/details.aspx?familyid=886ACB56-C91A-4A8E-8BB8-9F20F1244A8E&displaylang=en) version. It has the latest fixes/updates.

Cicero
28-11-2008, 09:35 AM
Thanks again lads.
Ran all of those and updated,went to WMP,no changes at all.
Tried altering settings,but nothing would change.

wainuitech
28-11-2008, 09:41 AM
Its a long shot - but go to start/run type in sfc /scannow have your windows CD handy in case it needs it to replace any problems it finds.

Cicero
28-11-2008, 11:06 AM
Its a long shot - but go to start/run type in sfc /scannow have your windows CD handy in case it needs it to replace any problems it finds.
Did that Wainuilad,nothing changed.

I note colours in WM are OK when playing music,that is the colours that change on screen when playing music.

wainuitech
28-11-2008, 11:23 AM
Hmmmm - Since its playing up in VLC as well, it does sound like a Codec problem.

You can try removing the old ones (try add remove programs) then installing new ones, you can get them from here (http://www.free-codecs.com/download/K_lite_codec_pack.htm) - standard should be enough or FFDShow on its own from Here (http://www.free-codecs.com/download/FFDshow.htm) - FFDShow is included in the other download as well.

Edited: does it "wash out" only on a certain video Format Eg: AVI - as a test, try another format , see if windows Media Video will play as this is built into the player.

back to work----

Cicero
28-11-2008, 02:00 PM
Not much luck it seems.
Have run that as best as I can,without any effect on colour.

wainuitech
28-11-2008, 02:31 PM
Right oh - Don't know if you have nVidia Video Drivers or not, but I found this as well for possible " Washed Out Video"


GO to nVidia Display settings

Colour Correction

Apply colour changes to

Select 'All' in dropdown

Apply...

If do, under Display/ Video & television, you can reset the defaults (on mine its top right of the window)

Cicero
28-11-2008, 05:25 PM
Right oh - Don't know if you have nVidia Video Drivers or not, but I found this as well for possible " Washed Out Video"



If do, under Display/ Video & television, you can reset the defaults (on mine its top right of the window)

Looking in device manager,all I can find is NVIDIA Network Bus Enumerator.
Have run nvidia disk , it says all is well?

I think I might have got that wrong.!

wainuitech
28-11-2008, 06:44 PM
The location of mine nVidia controls is either down by the clock, small nVidia icon , or in the control panel - nVidia Control Panel Control panel open (http://www.imagef1.net.nz/files/Video_View.jpg)

Cicero
28-11-2008, 08:09 PM
The location of mine nVidia controls is either down by the clock, small nVidia icon , or in the control panel - nVidia Control Panel Control panel open (http://www.imagef1.net.nz/files/Video_View.jpg)
All can see in my control panel is Nvidia nview desktop.

Can't for the life of me find nVidia control panel.

Cicero
28-11-2008, 09:11 PM
I seem to have the nVidia thing everywhere,but no nVidia Control Panel.......

http://i3.photobucket.com/albums/y79/cicero1520/untitled.jpg

wainuitech
28-11-2008, 09:20 PM
Okay - try these - Right click on a blank area of the desktop, the nVidia Control Panel "should" be there in the menu.

If not try right click Desktop/Properties/ Settings tab/ Advanced Button ( down bottom right) You should see a Tab with your Card, Example (http://www.imagef1.net.nz/files/Card1227860310.jpg)<-- Powerful modern card eh!!:) Does the job, click on the big Start control Panel.

Edited: if not there - try start/run type in nvcplui.exe the control panel "should" open.

If it doesn't, or is missing the drivers may need to be reinstalled - this could whats causing the video to not function correctly.

Cicero
28-11-2008, 09:56 PM
Tried all you suggested and no luck.

My unit differs from your super unit,mine is GeForce 6600 GT.
For the life of me I can't find that nVidea control panel.
Thanks for your patience Wai,I will reformat as soon as I can sort our what to save etc.

wainuitech
28-11-2008, 10:39 PM
Your Graphic card will leave mine for dead - Hell todays onboard Graphics would beat my card :( What I was suggesting is go to nvidia's site Select your Graphic card (http://www.nvidia.com/Download/index.aspx?lang=en-us) download the latest drivers, download Driver Sweeper (http://www.guru3d.com/category/driversweeper/) remove the current nVidia drivers via add/remove programs, when the PC reboots, dont let it install the drivers automatically, then run the Driver Sweeper, select the Nvivia Display Drivers in the menu, to clean out any traces of the old display drivers,reboot, dont let any drivers install, then reinstall them again from the fresh download you have brought through.

It looks ( no pun intended) that its only something to do with graphic drivers, going for a complete reinstall is a bit over the top at this stage.

Rob99
28-11-2008, 11:09 PM
Looking at your desktop it would seem you need to change the display settings to 32bit.

Cicero
29-11-2008, 07:36 AM
Looking at your desktop it would seem you need to change the display settings to 32bit.
It is set at 32 bit!

Cicero
29-11-2008, 08:17 AM
Having redone drivers,I now can't play in WMP,it wants to play in MPC,thats the little player in snapshot.Sound has gone all strange too.

But, colour is good in little player,even though I can't understand a word.

wainuitech
29-11-2008, 10:09 AM
Changing back to WMP shouldn't be to hard, Try this first, right click a video file/ open with - select VLC player - see if it plays OK in there. If it does play OK,( picture) do the same again, then select Windows Media Player, see if it plays OK. If it does, try again, this time put a tick in the box that says words to the effect - always use this action( cant remember exact wording)

It does look like something has gone belly up with the codecs, by default WMP has great problems playing AVI files.

You may need to uninstall the codecs, which ever ones they were.

I had a similar problem earlier this year, jumpy video, sound crackly - I had the K-Lite full package installed, removed it and as mentioned in Post 15 installed only FFDSHOW (http://sourceforge.net/projects/ffdshow) - that cured the problems.

If the audio is still not right, try uninstalling the drivers, and reinstalling them again as per the graphics.

You can also try reinstalling Windows Media Player (http://www.microsoft.com/windows/windowsmedia/player/11/default.aspx)

Cicero
30-11-2008, 12:42 PM
Strange things happening Wai,I didn't know you had posted,I am not getting emails from F1 since all this began.

Will have a go at your last instructions asap.
Thanks again.

wainuitech
30-11-2008, 02:02 PM
Strange things happening Wai,I didn't know you had posted,I am not getting emails from F1 since all this began.

Will have a go at your last instructions asap.
Thanks again. Ditto!! I have had several PM's and normally get an email saying there is a new private message - no such message has come through :crying

Cicero
03-12-2008, 07:07 PM
You will have noted delay in replying.
I have installed Vista and that seems to have resolved all problems.

kersonan
03-12-2008, 10:28 PM
a rather extreme fix method, but hey if it worked :)