PDA

View Full Version : AppData Folder does not display in Windows Explorer



symiggy
27-11-2008, 03:55 PM
For the last few months I have had an ongoing problem insofar that my "AppData" folder simply does not appear in the usual folder tree in Windows explorer.

I am aware that the usual pathway is: C:\Users\<user name>\AppData\

But in my case when I open a Windows explorer window AppData just does not appear as a sub folder after I have clicked on my user name in C:\Users directory.

Specifically here is a "Users" folder in the C:\ directory with my user name in a sub folder as it should be but it does not contain the AppData folder or any of its contents.

In addition I am not able to navigate to AppData in any navigational field of any program since again AppData just does not appear where it should!

In the "Folder Options" dialogue box under the View tab, I have checked every box that directs Windows to Display data and I have unchecked every box that directs windows to Hide Data...and yet the AppData folder (and its contents) remains hidden from me. :badpc:

I am sure that the folder must actually exist since my computer is otherwise working in all ways normally ...but I do on occasion need to access my AppData folder and its contents.

I would really appreciate any help or suggestions to solve this mystery. :help:
Many thanks.

wratterus
27-11-2008, 04:04 PM
So you've enabled viewing of hidden files and folders? Control Panel/Folder options/View/Show hidden files and folders.

symiggy
27-11-2008, 04:32 PM
So you've enabled viewing of hidden files and folders? Control Panel/Folder options/View/Show hidden files and folders.

wratterus:

I have most certainly enabled viewing of hidden files and folders in the Folder Options dialogue box that you refer to.

In fact I have checked every box relating to Displaying data and I have unchecked every box relating to Hiding data.

It just makes no difference whatsoever....my AppData folder (and its contents) remains hidden and inaccessible to me in my Administrator account.

pctek
27-11-2008, 07:16 PM
Environment Variable May Not Expand %APPDATA% to the Application Folder
http://support.microsoft.com/default.aspx?scid=kb;en-us;329308

Ofthesea
27-11-2008, 08:51 PM
.. and if you're logged in as administrator you can see the folder?
And if so what are the properties settings, sharing etc?

symiggy
27-11-2008, 10:10 PM
Environment Variable May Not Expand %APPDATA% to the Application Folder
http://support.microsoft.com/default.aspx?scid=kb;en-us;329308

pctek:

I think I was able to follow the directions on the site you pointed me to but it made no difference .
I am still not able to see my AppData folder.
Perhaps if you could give me more explicit instructions I might have more luck.
Thanks.

beeswax34
28-11-2008, 11:57 AM
Well, as an interim solution, you could create a shortcut to it on your desktop.

The path you'll need to enter is: %AppData%

Ofthesea
28-11-2008, 12:44 PM
Environment Variable May Not Expand %APPDATA% to the Application Folder
http://support.microsoft.com/default.aspx?scid=kb;en-us;329308

= If %APPDATA% is not resolved correctly, and you try to start a program that is located in the user application folder, the program does not start because the program cannot be located in the path.

- the PC programs are reported as functioning correctly, user just unable to view the folder so maybe it is not that environment variable solution?
Current users folder can be identified as in run "cmd" then "set APPDATA"
It appears to be an issue with folder properties and security settings?

pctek
28-11-2008, 01:18 PM
I think I was able to follow the directions on the site you pointed me to but it made no difference .
I am still not able to see my AppData folder.


I was going to say do a Repair Install on windows, but I see its Vista. Bad luck as I have never been able to get that to work.

wratterus
28-11-2008, 01:19 PM
I was going to say do a Repair Install on windows, but I see its Vista. Bad luck as I have never been able to get that to work.

It doesn't. Useless it is.

symiggy
28-11-2008, 02:08 PM
= If %APPDATA% is not resolved correctly, and you try to start a program that is located in the user application folder, the program does not start because the program cannot be located in the path.

- the PC programs are reported as functioning correctly, user just unable to view the folder so maybe it is not that environment variable solution?
Current users folder can be identified as in run "cmd" then "set APPDATA"
It appears to be an issue with folder properties and security settings?

Ofthesea:

I did do a cmd > set APPDATA as you suggest and the response obtained in the cmd window clearly indicated that the APPDATA folder exists in its correct path....but I am still not able to see it or access it in windows explorer neither can I navigate to it within a search field of a program.

I have carefully checked the folder properties and security settings in the folder options dialogue box and every box is checked to show hidden data etc....by the same token all the hide boxes are unchecked.
I am really at a loss as to what to do next.

symiggy
28-11-2008, 02:14 PM
Well, as an interim solution, you could create a shortcut to it on your desktop.

The path you'll need to enter is: %AppData%

beeswax34:

Could you please give me more explicit directions as to how exactly I create the shortcut that you suggest.
Thanks

pctek
28-11-2008, 02:51 PM
It doesn't. Useless it is.

Hope they fix it in Win7............

Ofthesea
28-11-2008, 04:38 PM
er.. um.. under Windows Explorere "Organise" + "Folder and Search options" + "View" tab - if you set or unset the "Show + Hidden files and folders" then it can hide or show the "Appdata" folder.
Can you check that again please?

symiggy
28-11-2008, 05:17 PM
er.. um.. under Windows Explorere "Organise" + "Folder and Search options" + "View" tab - if you set or unset the "Show + Hidden files and folders" then it can hide or show the "Appdata" folder.
Can you check that again please?

Ofthesea:

Honestly I have checked the folder and search options so many times ...its just not funny!
Please believe me all the boxes that indicate "display" are checked and all the boxes that indicate "Hide" are unchecked...honestly....I kid you not....and while I am genuinely perplexed and grateful of any and all advice on this forum, I am also not trying to waste anybodies time over here.

I will try to post screen shots of my Folder Options Dialogue box over here I'm not too sure if I'm doing it correctly ...but here's hoping..

http://www.imagef1.net.nz/files/Folder_Options_01.jpg
http://www.imagef1.net.nz/files/Folder_Options_02.jpg
http://www.imagef1.net.nz/files/Folder_Options_03.jpg

Ofthesea
28-11-2008, 06:38 PM
Cheers, no problem, I'm sure the answer is somewhere in the settings though - some combination of settings. As you say the folder is there, just not visible.
Maybe try applying the default setting option then add the "Show hidden files and folders"
Otherwise I'm stumped.

pctek
28-11-2008, 07:59 PM
I think its a stuffup, if the MS fix didn't work then a repair as I said would, but you can't with Vista. Well try it anyway, nothing to lose......But you might want to google and see what some other forums say else you might have to do something drastic.


Just a thought - does it show in the registry? If you enter it, and do a find for "application Data"?
I have loads of entries, the third specifies the path for my username. Does yours?

beeswax34
28-11-2008, 09:24 PM
beeswax34:

Could you please give me more explicit directions as to how exactly I create the shortcut that you suggest.
Thanks

You need to right-click on your desktop -> New -> Shortcut -> The location of the item is: %AppData% -> Next -> Specify a name for the shortcut -> Finish

Ofthesea
28-11-2008, 09:25 PM
Reviewing, can you see the folder when logged in as Administrator?
I'm presuming you're logged in as a user when having the problem, switching to Administrator login should allow you to see the folder. If so you could try right click + properties and un-click the hidden attribute in the general tab. Then log back in as user and try it out.

If that fails you could resort to the registry if you're sweet with that -
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion*\Explorer\Advanced\Folder\Hidden\SHOWAL L
change the "Checked value" to 1

I'm still sure it's a view folder issue, not really Vista, just another wierd microsoft thing to keep people occupied

symiggy
28-11-2008, 10:00 PM
Hey everyone the plot thickens....

I did a simple search for "appdata" in the search box that appears on pressing the visa start orb ...and right on the top of the search results a faint (not fully coloured) folder labelled "appdata" appeared under the "Programs" heading at the top of the box.
On clicking the folder a new Windows explorer window appears with the appdata folder right where it should be under my name!!!
I can expand the appdata folder in this window and access its contents.......BUT...and sadly there is a but...When I close the explorer window so obtained, and then re-open a new Windows explorer window, the appdata folder is still hidden and in addition I still cannot navigate to the appdata folder as part of a search from within a program...which is what I really want to do.

Specifically I want to direct one of my programs "CCleaner" not to delete, ie to exclude a specific file which is present in a subfolder of appdata....I know for a fact that its there because I can see it ...but ONLY in the explorer window obtained in the search...when I try to navigate to it from within CCleaner...appdata is hidden.
I hope I amexplaining my problem in an understandable way.

I guess what I'm asking now is how do I get the faint appdata folder (obtained in a search) to appear in a normal Windows explorer window and therefore be available on navigation from within a program?

Thanks

Ofthesea
28-11-2008, 10:12 PM
I'm sure the "faint" is the indicator of a hidden folder - typical of a hidden folder issue, not so much Vista.
Can you see the folder as Administrator etc as per above?

symiggy
28-11-2008, 10:28 PM
Reviewing, can you see the folder when logged in as Administrator?
I'm presuming you're logged in as a user when having the problem, switching to Administrator login should allow you to see the folder. If so you could try right click + properties and un-click the hidden attribute in the general tab. Then log back in as user and try it out.

If that fails you could resort to the registry if you're sweet with that -
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion*\Explorer\Advanced\Folder\Hidden\SHOWAL L
change the "Checked value" to 1

I'm still sure it's a view folder issue, not really Vista, just another wierd microsoft thing to keep people occupied

Ofthesea:

I am able to log in as Administrator...but sadly the Appdata folder is still hidden exactly the same situation as when I am logged in with my usual user account ...(which incidentally also has admin privileges)

I did look at the registry settings using regedit and located the value that you describe, as fas as I can see the "Checked value" is 1....
specifically the value reads: CheckedValue REG_WORD 0x00000001 (1)
I am not especially comfortable in editing this ...but do you think I need to?

Ofthesea
28-11-2008, 10:58 PM
Hi Symiggy, nope don't bother with the registry now as it has the value that it should have in order to see hidden folders (1).
Why don't you now send your question directly to microsoft? Give them a chance to sort it.
I'm out of ideas sorry

symiggy
28-11-2008, 11:07 PM
Hi Symiggy, nope don't bother with the registry now as it has the value that it should have in order to see hidden folders (1).
Why don't you now send your question directly to microsoft? Give them a chance to sort it.
I'm out of ideas sorry

Hi Ofthesea

Good idea perhaps Microsoft can help...but frankly I'm not exactly holding my breath...given their past record in responding to pleas for help.

At any rate , thanks very much for all your suggestions and interest...much appreciated indeed.

symiggy
28-11-2008, 11:29 PM
Hi All who gave me suggestions....SUCCESS AT LAST!!!! :banana :clap

I guess I just blundered into the solution...

I accessed the appdata folder by creating a shortcut to it as per beeswax34 suggestion then I simply right clicked the folder and pointed to properties and under attributes the "hidden" box was checked...I simply unchecked this and applied to all.....after a minute of flipping through many files it was done...the appdata folder is revealed in all its glory ...and accessible to navigation.

Once more...many thanks to all of you who gave me suggestions and help with this ongoing problem. :thanks :D :thumbs: