PDA

View Full Version : CD-ROM Auto run not working



26-05-2001, 06:06 PM
Hi, I recently downloaded and installed Microsoft's Media Player 7.1, which when opened, caused an immediate lock up of my system and had to use reset to reboot, since then my CD-ROM doesn't want to Autorun music or data CD's.

Going into System Properties/Device Manager/CD-ROM, the Auto Insert Notification box is ticked, so theoretically should work, but doesn't. I have tried to remove the device from Device Manager and rebooting in the hope that Windows would find it and reload the generic driver and did, but still no go. I have also run System file checker for changed files and deleted files to no avail

I don't know if I have missed something or do I have to reinstall Windows again?

I can start music and data CD's manually without too much drama. Usually when playing music CD's the drive's activity light will flash on and off, but now just flickers occassionally like the HDD light.

Windows 98SE
ATAPI CD-ROM Drive (52 Speed)
Fic AZ11E Mobo
Via 133 Chipset
Award bios
128Mb 133 RAM

Any suggestions would be appreciated.

Thanks in advance: Bob :>(

26-05-2001, 07:13 PM
Hello Bob

Do the following >>
Open up Reg Edit and go to the folowing key >>
HKEY_USERS
DEFAULT
SOFTWARE
MICROSOFT
WINDOWS
CURRENTVERSION
POLICIES
EXPLORER

Once within the Explorer folder Double click the file: 'NoDriveTypeAutoRun' if present and change the value to '95 00 00 00'

If NoDriveTypeAutoRun is present follow the below steps:

click Edit from the drop down menu
click new
click binary value
enter 'NoDriveTypeAutoRun' as the name
enter '95 00 00 00' as the value

Once the above has been completed exit the registry, reboot the computer and your issue should be resolved.

Alan

26-05-2001, 08:41 PM
Thanks Alan, but the registry values you provided are already set!

27-05-2001, 04:59 AM
It could be a file association problem. Open Windows Explorer then go View/Folder Options/File Types/Audio CD. I use the default Windows Cd-Player and have the following settings for the Play property:

Action = & play

Apllication Used To Perform The Action = C:\WINDOWS\CDPLAYER.EXE -play

27-05-2001, 12:50 PM
Thanks K1w1, I tried your suggestion, but unfortunately didn't work either, so I reinstalled Windows and it has come right. Must have been a deleted or corrupted file.

Thanks to all that helped.

Bob :>)