PDA

View Full Version : start up chkdsk



NZHawk
21-10-2008, 12:53 PM
Every time the computer boots or reboots it does a check disk
I have checked the registry is set to autocheck autochk *
I have run fsutil dirty query C: and it comes back dirty
I have run chkntfs /d --> still runs check disk on every boot.

any suggestions please.

wratterus
21-10-2008, 12:58 PM
Have you run a manufacturers diagnostic on the drive? It may be failing.

Also, I assume you have tried letting the chkdsk run though?

NZHawk
21-10-2008, 01:11 PM
chkdsk has run through multiple times
I have scanned with Seagate Tools - no probs detected.
It is a WD hard drive - I am scanning with WD diagnostic now
will report back

wainuitech
21-10-2008, 02:11 PM
Try this assuming your main drive is C: start/run type in cmd type in chkdsk C: /f/x answer Y to run on next reboot, reboot the PC, if it doesn't work, restart the PC in Safemode with command prompt, and type in the command that way.

"Chkdsk /x" goes a little further than /f and helps ensure that any files that were left open get closed; it actually implies "/f" so you don't need the /f if you're using /x .

From a tech site-->
As mentioned above if it doesn't work this is why you boot from command prompt --- when you try to run Chkdsk inside Windows, you'll usually get the message: "Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts?" If you answer Yes, the drive's flag is set to dirty so the OS will know to run Chkdsk on reboot.
But if the flag is what's messed up--- if the flag is the source of the Chkdsk problem--- then relying on the flag to solve the problem may not work.

There is a reg hack to disable it as well - but see if the above fixes first.

NZHawk
21-10-2008, 02:21 PM
Finished the WD diagnostics - no problem.
running Chkdsk /x

NZHawk
21-10-2008, 02:30 PM
Chkdsk /x -- didn't work.

I need a bigger hammer.

wainuitech
21-10-2008, 02:57 PM
There is a reg hack- no idea if it works so use at your own risk - MAKE A RESTORE point BEFORE doing this if you try-- the following is copied from a tech site:

If you are comfortable with merging a file into the registry, here is a .reg file that should do the trick.

To disable checkdisk by merging a .reg file:

1. Open Notepad. Click Start --> Run --> type notepad --> press Enter or click OK

2. Copy and Paste the following code into the open instance of Notepad.


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager]
"AutoChkTimeOut"=dword:0000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager]
"BootExecute"=hex(7):61,00,75,00,74,00,6f,00,63,00,68,00,65,00, 63,00,6b,00,20,\
00,61,00,75,00,74,00,6f,00,63,00,68,00,6b,00,20,00 ,2a,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"SFCScan"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Explorer\MyComputer\cleanuppath]
@=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00 ,52,00,6f,00,6f,00,74,00,25,\
00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00 ,32,00,5c,00,63,00,6c,00,\
65,00,61,00,6e,00,6d,00,67,00,72,00,2e,00,65,00,78 ,00,65,00,20,00,2f,00,44,\
00,20,00,25,00,63,00,00,003. Click File --> Save As... --> change Save as type: to All Files --> name the file disablecheckdisk.reg --> Save the file to your Desktop.

4. If still open, close the file. Now find the disablecheckdisk.reg file you saved to your Desktop, and Double-Click it.

5. A box labled Registry Editor will appear and ask if you want to add the information to the registry. If you do, Click Yes.

To enable checkdisk by merging a .reg file: (Optional)

If you decide you need to re-enable checkdisk quickly, follow the steps from above, but make a new .reg file named enablecheckdisk.reg, with the following Copied and Pasted into Notepad:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
"SFCScan"=dword:0000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager]
"AutoChkTimeOut"=dword:0000000a


Edited: Then again the drive still could be faulty even though the checks say its OK ????

beama
21-10-2008, 05:23 PM
the command you are looking for is

chkntfs C: /x

regardless of file system

does not remove the dirty bit (M$ wont spill the beans on location on the disk) but it does stop chkdsk from running

NZHawk
22-10-2008, 05:17 PM
Thank you beama!
You are right it worked.
No more chkdsk


Cheers