PDA

View Full Version : Printer going off line



WayneMiddy
10-10-2008, 02:32 PM
I Have a Brother MFC-5840CN printer connected to this laptop (Insite 1.86Ghz 2Gb Ram xp pro) offen after the laptop goes into screen saver mode the printer goes off line and you need to reboot. The printer is connected using a usb port but is network ready, should i hook it up with a network cable if so will it auto detect and if not what settings do i need?
The network socket at the back is not used as i am using a wireless modem.
Thanks all
Wayne

pctek
10-10-2008, 02:43 PM
The laptop is actually an ASUS, look underneath to see its real model number.
Disable Sleep on your USB ports, go into Power Options.

WayneMiddy
10-10-2008, 03:00 PM
Model Z7100, can,t seem to find an option to disable "Sleep on your USB ports" under Power Options Hibinate is not enable.
Cheers
Wayne

wainuitech
10-10-2008, 03:46 PM
Try this - Right click My computer/properties/hardware tab/ Device manager / Expand out your USB Controllers, Locate the one that has the printer attached, right click it/Properties / under power management, untick Allow the computer to turn off this device Picture (http://www.imagef1.net.nz/files/USB1223609070.jpg)

Hooking it up Via Ethernet, would save the problem of having to have a PC/Laptop on for others to print to the printer.

WayneMiddy
10-10-2008, 05:32 PM
Thanks again i have untick as per wainitech post there was 5 USB root hubs ( laptop has 5 usb ports ) couldn't tell which was which so untick them all.
This could be why my wireless keyboard/mouse use to lock up a few months back and i stop using it.
The only other things i have on usb ports is a mouse and 320gb backup drive hopefully it wont bother them.
Cheers
Wayne

WayneMiddy
10-10-2008, 06:43 PM
Nope no joy printer now gone off line, printer symbol down in tray when moused over says no device.
Cheers
Wayne

wainuitech
10-10-2008, 07:34 PM
Does it only go off line when the screen saver comes on ??

Has it always done this - or just started ??

Also next time it goes off line go back into the USB controllers, look to see if every thing looks OK and there is no ? or ! marks suddenly appeared.

One other thing to try when it goes off line, click start/printers and Faxes or control panel, Printers and faxes, right click the printer and tell it to work on line - see what happens, either it will turn on or an error message - if you get the message post back the complete message.

Also try looking at this - Click start/run type in services.msc and enter when the window opens -Scroll down and locate the print spooler - right click & select restart

wainuitech
10-10-2008, 07:56 PM
if its only just started doing this - unplug the printer, uninstall the software, get the latest Drivers from Brother and reinstall it again.Drivers Here (http://www.brother.co.nz/Private/support/downloads.asp?productID=MFC5840CN) -Click on Brother Solution Center select Drivers - Windows XP - English then search to download select the More Information in blue, either the full package if you use all the features or just the driver if you dont.

WayneMiddy
10-10-2008, 11:12 PM
Yes only when screen saver goes on and yes i think it has always done this.No ? or ! in Device Manager. No option to tell it to work on line in printer properties. The enable printer pooling is not checked,Print directly to printer is enabled, should it be set to spool print documents?
There is no error message just document failed to print down on the printer icon in task bar.
services.msc clicked on restart but didn't wake up printer icon in task bar just had a ? on it. The Drivers link only gets me to a log on screen.
Cheers
Wayne

wainuitech
11-10-2008, 09:08 AM
Strange - the Driver link shouldn't have given the dealers login screen as it was on the public downloads - Never mind - try This one (http://www.brother.co.nz/Public/ProductDetails.asp?ProductID=MFC5840CN) - top right select Drivers/Downloads - then click on the " brother Solution Center" Button in the middle of the page - follow above to latest drivers.

If it only cuts out when the screen saver goes on, see if any of the power settings are set to turn off, This may work - but the laptop may also have its own power options - right click the desktop/properties/Screen Saver -under the Moniter power down the bottom right, click on the Power Button - look through all the settings and turn off anything that is set to save power when the screnn saver is activated.

WayneMiddy
11-10-2008, 07:59 PM
All 3 power settings are set to Never.
The latest driver release dated is 15/11/2004 which is older than the printer so do i need to download it? Could i just uninstall current driver and reinstall from CD if needed.
Cheers
Wayne

wainuitech
11-10-2008, 08:21 PM
yep - uninstall the printer, making sure its disconnected first, reboot and reinstall the software you currently have on CD - it will have any patches/improvements that the older one on Brothers site doesn't.

See if that makes any difference.

Try this first though ---- Please correct if I'm wrong, But it only goes offline if the Screen saver comes on ????

If so try turning off the screen saver and see if it still disconnects after a while/usual time.

WayneMiddy
11-10-2008, 10:26 PM
Have turned off screen saver have noticed it doesn't always go off line after screen saver has been active
The driver that came with the printer is the latest and the current driver loaded.
Laptop has been on for 6 hours now and still on line.Question after going into device manager and unticking allow the computer to turn off this device would the laptop have to be rebooted to take affect?
Cheers
Wayne

wainuitech
12-10-2008, 08:49 AM
Have turned off screen saver have noticed it doesn't always go off line after screen saver has been active
The driver that came with the printer is the latest and the current driver loaded.
Laptop has been on for 6 hours now and still on line.Question after going into device manager and unticking allow the computer to turn off this device would the laptop have to be rebooted to take affect?
Cheers
Wayne Pays to reboot when you make system changes so they do take effect, some operations have and you get a message requesting - some say you dont need to, but I have always found it best to reboot so the new settings take affect on a restart.

WayneMiddy
13-10-2008, 11:23 AM
Have turned off everything as above, laptop still goes in standby i guess i have to change that function in bios. Which F button on boot up as delete not doing it?
Cheers
Wayne

wainuitech
13-10-2008, 01:38 PM
Try F1 or F2

SolMiester
13-10-2008, 01:54 PM
Check the jumpers for the USB, if it states +5v, change to +5VSB. It will keep sleep state power to the usb port and keep your printer from sleeping and needing power on all the time....likewise, you should do this with any usb device that gives sleep\hibernation issue on wake-up!

SolMiester
13-10-2008, 02:22 PM
Doesnt look like you have those settings on your lappy, unless it is in the BIOS...

WayneMiddy
14-10-2008, 09:06 AM
Thanks guys no joy however, have confirmed its is when it goes into standby, as if i close the lid laptop goes into standby and printer goes off line. so i think i will plug it into the router and see if i can print wireless, might need some help with that but let you know in due course, thanks again.
Couldn't find any option in bios to turn off going into standby only lcd power saving mode which i turned off.
Wayne

SolMiester
14-10-2008, 09:27 AM
If the printer is network ready, just give it a static address and plug it into the router then use TCP/IP printing port instead of USB.
When adding the printer, select local, then create new port>TCP/IP, when it asks for the address, type in the IP address in the top field, leave the bottom field, then continue with driver selection etc.....