PDA

View Full Version : Dick Smith 7 port powered USB Hub



grantji
05-10-2008, 04:11 PM
Previously this has been working well, but has recently stopped. XP SP2 says that I need to install a driver for it. The DSE spec says XP should recognise it auromatically, but it doesn't So what should I do next pelase? And where woudl I go to get a driver?

Cheers.

Ian G

mark1978
05-10-2008, 04:41 PM
Hi,

Try to disconnect al devices that is in the hub, then go to device manager and see if you can find your USB Hub, right click and delete it, then remove your USB Hub from the USB port, Restart the computer, then try to put the hub in the pc again.

grantji
06-10-2008, 10:11 AM
Thanks for comments Mark.

I have tried your suggestion, but no change.

When I plug in the USB hub, Win says it wants to install new hardware. The Hardware Update wiz asks first "Do I want to install automatically." I answer yes and after a time it says it "cannot continue". So I go back to "Install from a list or specific location" when it searches for e:\UC35\winXP. I have a CD with this on (it came with the hub), but after a time the Wiz again says that it cannot continue with the H/Ware Update, even though it is apparently reading the CD.

Further in Device Manager I also have in "Other Devices" a USB Device with Yellow Question Mark. It gives me the message "Drivers for this device not installed (Code 28)" and hence it takes me to Hardware Update Wizard as described above.

I have checked that the USB hub it has power!!

All in all very frustrating.

I am wondering if the USB Hub is itself stuffed. Can I test it easily, like a ping command?

Any further help would be appreciated.

Ian Grant