PDA

View Full Version : Google thinks I am an iPhone



Jayess64
09-09-2008, 03:24 PM
My browser home page is set to www.google.com/ig, with a range of gadgets for latest news, weather etc. In the last couple of weeks, when I open my browser (Firefox 3.01) I am liable to get redirected to www.google.com/ig/i which, apparently, is the same page formatted for the iPhone.

When this occurs nothing I can do will let me open www.google.com/ig, and it's driving me bananas. It doesn't happen every time, just (in the last couple of days) most of the time. I get the same behaviour with my laptop as well.

Does anyone know what is going on, and how this can be rectified?

Message to Google: neither of my computers is an iPhone. They don't even look like iPhones.

wainuitech
09-09-2008, 04:07 PM
Change the home page back to google if thats what you want for a home page, or what ever site you want.

For Google - Either www.google.com or www.google.co.nz

Once you have the page you want, depending on what browser you are using, in FF tools/Options - under the main Tab, select use Current Page / OK.

In IE, tools / Internet options/General Tab / Use Current / OK.

Jayess64
09-09-2008, 04:28 PM
Change the home page back to google if thats what you want for a home page, or what ever site you want.

For Google - Either www.google.com or www.google.co.nz

Once you have the page you want, depending on what browser you are using, in FF tools/Options - under the main Tab, select use Current Page / OK.

In IE, tools / Internet options/General Tab / Use Current / OK.

Thanks, Wainuitech, but I wish it was so simple! My point is that when I try to direct the browser to www.google.com/ig it is immediately redirected to www.google.com/ig/g most of the time. I have since found that people on Google Groups have been complaining about this behaviour for several months.

wainuitech
09-09-2008, 04:34 PM
try changing it manually - open the browser, go to tools /Options ( if using FF) in the home page, remove whats there and type in the home page you want, try something different to google to start - any page will do, then try going back to google if you want.

Also download Ccleaner from my sig, and run that to clean out any temp files etc.

somebody
09-09-2008, 06:34 PM
It sounds like Google is either misinterpreting your browser's headers, or it has been set incorrectly.

Go to: http://analyze.privacy.net/ and see what the "Browser Type" says. It should say something similar to "Mozilla/5.0 (Windows; U; Windows NT 6.0; en-NZ; rv:1.9.0.1) Gecko/2008070208 Firefox/3.0.1"

robsonde
09-09-2008, 06:46 PM
Thanks, Wainuitech, but I wish it was so simple! My point is that when I try to direct the browser to www.google.com/ig it is immediately redirected to www.google.com/ig/g most of the time. I have since found that people on Google Groups have been complaining about this behaviour for several months.

try http://www.google.com/ig?rls=ig&hl=en&source=iglk

sal
09-09-2008, 06:54 PM
and just for the record, google.com/ig is only for a personalisd Google, nothing to do with iPhones.

robsonde
09-09-2008, 07:18 PM
and just for the record, google.com/ig is only for a personalisd Google, nothing to do with iPhones.

the problem is that google will re-direct you to a cutdown version of your personalised page if it thinks you are using an iphone.

i had this problem too and the link i posted works for me.

somebody
09-09-2008, 07:23 PM
and just for the record, google.com/ig is only for a personalisd Google, nothing to do with iPhones.

The OP said that going to this url redirected him/her to google.com/ig/i which is the iPhone version of a personalised google homepage.

sal
09-09-2008, 07:41 PM
The OP said that going to this url redirected him/her to google.com/ig/i which is the iPhone version of a personalised google homepage.
Arr, rtfop on me, huh.

Jayess64
09-09-2008, 09:07 PM
try http://www.google.com/ig?rls=ig&hl=en&source=iglk

Thanks, robsonde, I've changed the URL to your link. Maybe that will fix it.

Still don't understand how the problem occurred, though.