PDA

View Full Version : Sharing a Printer



Devie Boy
07-09-2008, 06:27 PM
Hi Gang
I have a new laptop which is connected to a radio router. My desktop is also connected by wire to the router. Both machines are connected in "Security" mode and work excellantly. The desktop has a printer which I have accessed and configured to "share'', but for the life of me I cannot get the the laptop to print from this printer. The printer will happily print from the desktop. Anyone have any idea how I can get the printer to print from the laptop? NB: I have the desktop going and connected to the router when trying to print to the printer via the laptop, but up to now, now go. I have had comment that I would likely have to install a "printer router"to get the printer to respond. Can anyone help? :nerd:

wainuitech
07-09-2008, 06:53 PM
I assume from the Laptop you have gone into the printer folder, told it to install a networked Printer ? Example (http://www.imagef1.net.nz/files/Add_printer.png)

Edited: thats assuming its XP, if vista its a bit differrent.

If so then the laptop as long as the printer is shared, and on the same workgroup, should see the Printer on the PC.

When you install the printer on the Laptop, it should drag the necessary drivers across the LAN, and of course the PC has to be turned on other wise the Laptop wont find the printer.

Devie Boy
08-09-2008, 08:35 PM
Hi Wainuitech

The laptop is on vista
The printer is on the same workgroup, I think
The printer is on the PC, not the laptop
Any advice. Thanks
Devie Boy

wainuitech
08-09-2008, 08:42 PM
Hi Devie, What make and model is the printer you are trying to connect to ?

Depending on what it is will depend if Vista has the drivers inbuilt or if they need to be downloaded and Installed .

Also have a look through These instructions (http://technet.microsoft.com/en-us/library/bb727037.aspx) -

Main items to make sure of
Pc and laptop are on the same workgroup
printer is shared on the XP machine, to check go to the printer, right click and make sure sharing and security is selected/ticked
On Vista - make sure network discovery is ON
printer sharing is ON
Password protected sharing is OFF


Once all is set, even without the printer being installed, the printer on XP once shared should be showing in network places in Vista

wainuitech
08-09-2008, 09:02 PM
Add to above -----

Also what do you have installed in the way of security software - that can be causing a problem as well.

Devie Boy
08-09-2008, 09:17 PM
Thanks for the advice, will check up on it all, bur my wife has now grabbed the desktop and in full song with her game, so will have to wait for an hour, I bet.

I am using a Belkin N wireless router, using the security in that router. Using zone alarm and Avast on both machines

wainuitech
08-09-2008, 09:39 PM
Also found this here - don't know if it works or not, but I will try tomorrow - Mrs wants me out of here :lol:

Lets say the XP PC that has the Printer is called Devie -

On the Vista machine, move the printer to the laptop - install the printer as a local printer Via usb and get the drivers working with the printer connected to the Vista machine.

Then reconnect the printer to the XP machine, make sure it still works, and do the following.

On the Vista machine in the printer properties, create a local port, and in the port name use the \\Devie\printer name.

The printer Name is what its called under the shared Properties.Example (http://www.imagef1.net.nz/files/printer_Shared.jpg) of one of my shared Printers on a XP Pro.

Edited: yes its a damn old MFC but works great, and outlasted many of my other printers.

Devie Boy
08-09-2008, 09:43 PM
Thanks mate

Will let you know how I get on tomorrow

Cheers
Devie Boy:)

Devie Boy
10-09-2008, 08:46 PM
Hi Wainuitech

I tried what you have suggested but still not printing.
The laptop recognised the printer and I printed a test page to see it was genuine.
In an earlier post you questioned whether the two computers were in a work group? both computers use the same modem and radio router but workgroup? This may be the sticking point
Workgroup. Where, how, etc?

Thanks mate

Devie Boy

wainuitech
10-09-2008, 09:12 PM
Okay - by default the workgroup for Vista is " workgroup" and for XP Hm its "MSHOME".

Lets make sure both read MSHOME.

In XP Right click My Computer/Properties/Computer Name Tab/ Click the Change button Make sure the workgroup says MSHOME. IF the XP computer is MSHOME leave it as is.

If not change it to MSHOME - it will take a second or two then a reboot is required. Example (http://www.imagef1.net.nz/files/Workgroup1221036133.jpg)

Back in a sec, changing PC's


Okay - in Vista Right Click Computer/Properties- to change the settings, click Change settings Example (http://www.imagef1.net.nz/files/Workgroup1221036489.jpg)
Next on the computer Name Tab, click the Change button Example (http://www.imagef1.net.nz/files/Workgroup2.jpg) then this applies to both XP and Vista make sure the workgroup says MSHOME (http://www.imagef1.net.nz/files/MSHOME.jpg) - reboots will be required if you change these. Once both are on the same workgroup they should see one another.

Had this exact problem yesterday, for some stupid reason if the PC's were on the workgroup called "Workgroup" they couldn't/wouldn't work, change the PC's to MSHOME and away they went.

The XP computer - is it XP home or Pro ?

Devie Boy
10-09-2008, 10:00 PM
Hi Again

Followed orders
Both computers are on MSHOME
Seem to recognise each other but the printer is still "Öff Line"

Cannot see what I am missing now

Cheers

Devie Boy

Devie Boy
10-09-2008, 10:02 PM
XP Computer is XP Home

Cheers

Devie Boy

Devie Boy
10-09-2008, 10:13 PM
XP Computer is XP Home

Cheers

Devie Boy

wainuitech
10-09-2008, 10:41 PM
Appears theres a common problem with the off line - cant duplicate the problem as all my Vista PC's have SP1 installed - I'm a bit knackered at the moment - I feel like my Aviator :( so cant think straight - working to long (again)

Does the Vista have Service pack 1 installed - there is meant to be a patch included in that to fix the off line problem.

I did find the below on another forum, a possible workaround - its similar to what I posted earlier, but also slightly different - no Idea if it works or not, but shouldn't hurt.
Here's the fix:
1. In Control Panel, Printers, delete offline printers. If they wont
delete, it may be because there are pending print jobs in the queue. Open the
printer and Cancel the jobs.
2. In Printer properties, Ports tab, delete the previoulsy installed
printers (offline statuts) that appear as Client Side Rendering Provider
under the Description column. To do this, highlight the port, then click on
Delete Port button. Click Apply.
3. Restart your PC.
4. Now reinstall the printers as follows:
5. Open Control panel, Printers, and click Add a printer.
6. Click Add a local printer.
7. Select the "Use an existing port" radio button, and select LPT1: (Printer
Port). Click Next.
8. Install the printer driver. Mine were found in the list inlcuded with
Vista. Select the manufacturer and the printer. Click Next.
9. In the next window, accept the printer name or type in a new name. Leave
the "Set as default printer" box unchecked. Click Next.
10. Vista should now install the printer. A window should open saying
"You've successfully added printer name.
11. DO NOT Print a test page at this time, because nothing is connected to
the LPT1 port on the laptop. Just press Finish. The printer you just added
should appear in the Printers window.
12. Click ONCE on the newly added printer to highlight it, then right-click
and open Properties.
13. On the Ports tab, click Add Port…, select Local Port, then click New Port…
14. When the Port Name window open, Enter a port name as follows:
\\computername\printername
(replace computername with the name of your PC acting as print server, and
printername with the name of your printer). Click OK.
15. You should now have a new port listed on the Ports tab of the printer
Properties, but now the Description should be Local Port, instead of Client
Side Rendering Provider. Click OK.
16. Now you can go to the General tab, and Print a Test Page.

Hopefully, your test page will print. Then restart your computer to check
that the printer comes back online.


The above is From Here (http://www.vistax64.com/vista-print-fax-scan/75468-printer-always-offline.html) - #9

Devie Boy
10-09-2008, 10:58 PM
Thanks Wainuitech
Will give it a go and let you know tomorrow, i hope
Cheers for now
Devie Boy

Devie Boy
14-09-2008, 08:35 PM
Thanks Wainuitech but no go. I really appreciate your help, but this has got me*****. I think I will save my dollars and get someone in to fix it, or just carry to laptop to the printer , plug it in and print. Primitive but the nice way aint working just now!

Cheers and much thanks Wainuitech

Devie Boy