PDA

View Full Version : .NET frameworks



nofam
12-08-2008, 12:49 PM
Do I need them? I know certain apps use them, but unless I'm specifically asked by an app to install it, should I bother?

And if I should bother, do I need to install 1.1 2 and 3 etc? Or are they various packages cumulative a la service packs??

:thumbs:

wratterus
12-08-2008, 12:52 PM
On my own PC I never install it unless a piece of software specifically requires it. EG any drivers for an ATI graphics card require version 2.0 of the .net framework. (Not that I've ever owned an ATI card...) :p

Also, if you install them in the wrong order (no one knows what the right order is) :D the SPs for them can throw a hissy and not install, leaving that friggin annoying auto update icon in the system tray. :badpc:

On customer's PCs, I put just the latest version on.

Speedy Gonzales
12-08-2008, 01:02 PM
I dont think 2 includes 1.1, or its service pack

I found this out one day. I went to install 2 uninstalled 1.1, and the ATI drivers wouldnt work.

And I couldnt reinstall 1.1. (XP wouldnt let me) !

I had to reinstall Windows, to fix it

But 3 (from what I've read) includes 2 and its SP.

In the end I managed to find a 47mb file with all the .net framework files (inc 3.5) in it.

And slipstreamed it to a cd. That way, I wont have to reinstall any of them if I reinstall XP.

It'll tell u if theyre cumulative (depending on which one you get) on the MS site