PDA

View Full Version : Sound/DirectX problems... ugh.



X6488
09-08-2008, 02:32 PM
So I installed the most recent DirectX stuff from Microsoft's site. Much to my annoyance, multiple programs now have no sound or don't work. This includes:

Diablo II (soundless)
Devil May Cry 4 (soundless)
Starcraft (soundless)
iTunes (songs don't start, no error message, lots of lag)
Windows Media Player (songs don't start, http://img518.imageshack.us/my.php?image=errorjg6.jpg)

But I know my sound drivers are working because they're displayed in the hardware. The startup sound also plays and AIM has no problems with its pings. My Google skills haven't been of any use at all either; I think my problem is unique. :(

System specs:
Windows Vista Premium (no service pack)
2 GB DDR2 RAM
Core2Duo@1.4ghz
Nvidia 8400M GS (yes, it's a laptop)

Here's to hoping for some good luck and advice from you guys. :horrified

Speedy Gonzales
09-08-2008, 02:38 PM
Info here (http://support.microsoft.com/kb/934275)

X6488
10-08-2008, 11:49 AM
Info here (http://support.microsoft.com/kb/934275)

Ugh... just when I thought it couldn't get worse.

So I did exactly as this thing told (aka installing SP1, the updates, etc). Surprise, now all my sound's gone! I decide to check on my sound driver. Sure enough, it's still listed. A click reveals "this device is working properly".

Surely someone has an idea? This isn't getting any better.

autechre
11-08-2008, 10:00 AM
Have you reinstalled/updated your sound drivers? You may need to despite what Windows thinks about your sound card.

SolMiester
11-08-2008, 12:41 PM
You will have to check what device is listed as proirty sound device in sounds icon in control panel....