PDA

View Full Version : USB Mass Storage error



mark1978
05-07-2008, 02:57 PM
Hi Guys,

Am going mad! My external USB drive is plugged into the usb port of my computer, but the computer is not recognising it! when I go into device manager there is a yellow exclamation in front of it.

I have tried to disable it and restart, no go, I have tried another USB cable...no go, I have tried to use a different port...no go!

Helpppp!!!

Speedy Gonzales
05-07-2008, 03:23 PM
Is it connected to power??

Is SP 1, 2, or 3 installed?

mark1978
05-07-2008, 07:56 PM
yes power is in, and have SP3

Speedy Gonzales
05-07-2008, 08:11 PM
Delete the ! and the entries under USB controllers in device manager, then reboot

mark1978
05-07-2008, 08:24 PM
tried it, no go!

Speedy Gonzales
05-07-2008, 08:26 PM
Sounds like USB 2 is disabled in the BIOS then, if it wont work in any port

Check the USB option in the BIOS

Have you got anything else thats USB, that works?? If it does work, something in that external drive is probably stuffed

mark1978
05-07-2008, 08:28 PM
do you know how to do that?

Speedy Gonzales
05-07-2008, 08:30 PM
Go into the BIOS set it to the default settings. Look for the USB / 2 option, put it on highspeed I think. Save the BIOS settings / reboot

I dont know what your system is, so cant tell u exactly where it is

gary67
05-07-2008, 08:46 PM
RIght click my computer in start menu click manage then open device manager then click usb controller see what thats set to also see if there are any yellow question marks anywhere there.

Just rebuilt my system and until I installed the latest PCI drivers for my new motherboard my usb's were set to usb1.1

mark1978
06-07-2008, 09:41 AM
You know what the strangest thing is!? When the external hard drive is directly plugged in the computer it is not recognised but when it is plugged in a little usb hub it IS recognised!.........dont get it!