View Full Version : Connectivity, or lack thereof

12-06-2008, 01:44 AM
So I had asked about this in another thread and the problem was swamped by another issue I was dealing with. The connectivity issue has gotten worse however so I figgered I'd repost with updates to the problem...here goes:

I have two Macs and a PC on a household network ethernet connection. Until recently I haven't had any problems. About a month and half ago however, my PC started actin' funny. Sometimes, it just looses it's connection. It used to be that I would restart firefox, or at worst, I'd restart the computer. Today however, I restarted the computer and I can't connect whatsoever. The little LAN connection icon in the lower right hand corner of my screen says I'm connected, but someone here said that doesn't mean beens. Anyway, all the other computers on the network work fine. So far I have restarted the router, switched the cables, checked connection, switched the ports they were connected to, and still no joy. Other than that my computer has never run better.

I am a confident Mac user and a relative noob to PCs so if you have any input, don't be afraid to use small words.


12-06-2008, 08:54 AM
Try this - its to see just how far it is connected or not.

Click start/run type in cmd Press enter/OK
In the command box that appears, type in ipconfig press enter.
See what IP address you are getting, what you should get is your IP, Subnet mask and gateway.

Depending on the routers address you should get something like this Here on mine (http://www.imagef1.net.nz/files/IP_address1.jpg)If you look the IP address is the same as the Gateway apart from the last set of numbers , yours may have different numbers Eg: 10.1.1.? but you get the idea.

IF you have a address of 169.X.X.X then your PC is not talking to the router.

IF you are getting a address thats appears to be working try this - in the command prompt type in ping ( Press enter) you should get back something like This here (http://www.imagef1.net.nz/files/Ping_1.jpg)- a reply from that address, which happens to be Telstras DNS servers, dont worry if you are not with telstra the servers should answer no matter who you are with, its only a test to see if you have a working internet connection.

Let us know the results,then a possible answer can be advised.

12-06-2008, 01:04 PM
OK so here's what I get. First off I get for my IP, 255 etc for my subnet and for my default gateway

When I ping that IP I get request timed out three times and then it says "Ping Stats: packets sent=4 received=o lost=4 (100% loss)

Methinks I'm in twubble

12-06-2008, 02:10 PM
Chill, when you got the timeout, are the other pc's on the network connected okay to the www?..

13-06-2008, 12:40 AM
the other two comps on the network are macs, but yes, they both are connected just fine. I'm using my wife's mac as we speak to get on this website

13-06-2008, 08:25 AM
Can you please check something - click start/Control Panel/ Open "network Connections" - On the Local Area Connection, Right Click/ Then click Properties/ Under the General Tab you will see a box with several types of connections, select "Internet protocol TCP/IP" - Double click it to open, or press the properties button once highlighted.
Look at the DNS Settings, are they set to obtain Automatically. If there are some numbers there, write them down (just in case) then select "obtain Automatically"

If no numbers who is your Internet Service provider ?

What you can also try is running a program called Winsock Fix (http://www.snapfiles.com/get/winsockxpfix.html) - it blows away the TCP/IP connection stack and rebuilds it, there may be some corruption there as well.

13-06-2008, 09:53 AM
My ISP is cavalier (I'm in the states)

There are no number written and both of the "automatic" bubbles are selected

13-06-2008, 09:54 AM
Incidentally, I can't download a program from the web, since I can't connect to it

13-06-2008, 10:18 AM
Here's more: This morning We noticed our printer wouldn't work and after talking just now with my wife I put together what's going on with that. I think the problems are related, but you let me know what you think.

When we first got this printer (a Brother HL-5250DN) We couldn't get either our two macs or our one pc to print. Eventually I got an email from a helpful tech I called at Brother who said there was a driver from a completely different printer that could act like one for a Brother. He showed me how to have the PC act as a sort of parent printer and then the macs would share that connection.

That worked great for a while until it stopped working and no matter what we did we couldn't get it to work. So we tried something else. We were able to print out a page on the printer (by hitting the start button three times or something) that showed the ip address being given to the printer. We were then able to set up ip printing. However when the printer got shutoff it stopped working and we realized that the ip was different (by printing out that page again). We updated the ip (a 192.169.1.x type number) and all was good. Today after printing out that page again I noticed that the ip had changed to something like And we cant print.

Alllll that being said, my wife is convinced that somehow the pc may still think its in charge (by still having settings we didn't change when we switched from sharing to ip printing) or at the very least that since the PC cant print, no one can. Also I was just informed by the old lady that the printed out info page says it's connected to the router just fine.

I want you all to appreciate just how difficult this was for me to explain, I am really not that good with this stuff, so thanks for the help and THANKS for being patient with me.

13-06-2008, 10:38 AM
Incidentally, I can't download a program from the web, since I can't connect to it
>:) Wont the MAC bring it through, then transfer VIA to a Pen Drive to the PC ?

Hmmm OK thought you were in New Zealand - Try this - open the command box again ( cmd) this time type in ipconfig /all see if it lists the DNS servers - then read below on changing the settings in windows, to match the ones shown.

No doubt you can get these numbers from the MAC's but my knowledge on MAC's to obtain these is next to nothing - unless its a Big MAC from McDonalds:D

You shouldn't have to do this as the router should be issuing the address for you, but sometimes it works -

OK now this will be fun:D I located the Cavalier settings - BUT its different for different states.
have a look at These Settings (http://www.imagef1.net.nz/files/DNS_USA.jpg) - Depending on where in the USA you are will depend on which ones you use ( select your area) , open the TCP/IP properties again, and this time in the DNS Servers, select "use the following DNS server address" - enter in the numbers in relation to your state.

If you want the whole setup manual its Here from Cavalier (http://www.cavtel.com/support/techsupport/index.shtml) Under DSL modem Guide.

See if that makes any difference.

Edited: regarding the Printer - If its connected to the PC then the address will be the one the router is given to the PC. The reason it may have dropped it is the router issues an address, and it may have issued a different one to the PC, so the printer then defaulted back to its default.

To stop that when the PC is connected, you look at the IP address it has now,( ipconfig - the Router is 1 your address is the top one) go into the TCP/IP settings and tell it to use the following address( enter the details it is given) Eg: 10.0.1.X with X being the current one.


Then set the printers IP to match. BUT being a DN printer, the N stands for network Capable, you should be able to plug the printer directly into the Router.

Cant look at the moment as I have a couple of jobs to go to. Il'' pop back later to see if any things changed.

14-06-2008, 12:13 AM
OK I entered those numbers. Originally the DNS servers part of Ipconfig had as the DHCP and default gateway. Would it help to post the other ipconfig info? I see here for instance that before entering the dns numbers the node type was broadcast and now it's unknown. Also for iprouting enabled and wins proxy enabled it says both are "no"

This may not mean a hill of beans but I figgered I'd share in case.

One more thing, the printer is now set up as a network printer. We had it set up as a shared printer a while back but when that topped working ip printing was the only thing that worked.

14-06-2008, 09:50 AM
OK well, I borrowed a teeny usb drive from work and used winsock xp fix but I still cant connect :(

14-06-2008, 10:17 AM
Hmmm OK so setting the DNS to your ISP didn't work either - We know by your first post that cables have been changed about so hopefully its not a cable/port issue on the router. Running winsockfix wont have hurt anything, just makes sure the TCP/IP stack is not damaged.

Put all the IP settings back to how they were, open the CMD box,type in ipconfig /flushdns <enter>

What firewall do you have ?

If its only windows firewall, go into the control panel, Windows Firewall, open and select off - In fact turn off the firewall any way.

What is the make and model of router you are using - May pay to look at the settings.

It sounds like for some reason the DNS sections are not talking.

14-06-2008, 10:52 AM
Just a thought - Are you by any chance running ANY Norton Security software - Anti-virus, Internet Security , 360 ?

14-06-2008, 01:34 PM
OK I "successfully flushed the DNS resolver cache"

For a firewall I have Comodo, no Norton. The router is a Linksys BEFSR41

OK Get this, I shut off Comodo and put it back on and now my pc is back online...but I still can't print

14-06-2008, 05:32 PM
Ok, if I read you reply right- the internet is now working. If the firewall was causing a problem that would certainly have that effect, if It falls off again , shut down the firewall,and possibly remove and reinstall it.

DO THIS ANYWAY on the current install of Comodo-

In comodo set the firewall so it allows all the address's through, to do that, open the firewall, up top click on Firewall, down on the right, select " My Network Zones" - Select your network from the box displayed, then on the right click the "Add" button, select " A new Address" -click on "A range Of Addresses" - in the first set of boxes type in in the second box type in save the settings, this will allow the complete range of addresses from the router through.

Now the Printer - If its connected to the PC (easiest) First I'd uninstall it and start again. If you don't have the driver CD - Download the drivers from Here its A NZ site (http://www.brother.co.nz/Public/support/downloads.asp?productID=HL5250DN) but no reason why they wont work in the USA.

It has both Windows and MAC drivers, download for all machines that require the printer.

Some of the problem could have been because as you mentioned in a earlier post, different drivers were used - use the right ones.

Reinstall the printer on the PC, make sure it working as it should. Then go into the printer folder, either start/printers (on the right menu) or start /control panel / Printers and faxes folder.

Locate the printer, right click it, select "Sharing" , click on "Share this printer" and save. You will see a hand under the printer, meaning its now shared.

Now to set up the MAC's - see if they can see the printer,They may require the drivers you downloaded before - To be honest here I don't know how to do this on a MAC, as I dont work with them, you would have more Idea as to the layout/functions of a MAC than I do.


If you go to this site (if you don't have the manual) Here Manual (http://www.retrevo.com/support/Brother-HL-5250DN-Printers-manual/id/282ci772/t/2/) The networking manual is the Third one down, it explains how to set up the printer for networking in both Windows / MAC. Its down loadable as well.

IF you want to set the printer on to the router (which its capable of) that way you don't need to have the PC turned on for the MAC's to print, as the print jobs go to the router, read the manual and it explains how - its a LOT easier if you have the manual and printer in front of you.

McDonalds and Big MAC's for dinner I think :D

15-06-2008, 02:16 AM
Wain you are a godsend and a wealth of knowledge. My baby will be waking from his nap soon, so if I can I'll try to get some of this done during the next nap. I think you'll be asleep yourself, no doubt gorged on Big Macs and Fries (I don't know about NZ, but here in the States MacD fries kick BK's butt).

More to come,