PDA

View Full Version : Xkbmap Ubuntu 8.04



kjaada
26-05-2008, 11:44 AM
I have a problem with no keyboard input in KDE (it is ok in gnome) would running Xkbmap -V restart the keyboard

Erayd
26-05-2008, 12:02 PM
The command is actually setxkbmap, and it's unlikely to fix anything - that utility is used for changing your keymap, not for enabling / disabling the keyboard.

Noting this is your second thread about the same problem... did you try the suggestion from the other thread about starting kcontrol from within gnome to check your keyboard setup?

Can you paste the contents of /etc/X11/xorg.conf here (inside [code] tags please, so that it will scroll).

kjaada
26-05-2008, 12:12 PM
here is the relevant bit (i think) and yes I tried kcontrol.
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Erayd
26-05-2008, 12:51 PM
I'm actually after more than that - it's not the only relevant part. Can you just paste the whole thing please?

kjaada
26-05-2008, 01:24 PM
xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Erayd
26-05-2008, 02:25 PM
Change your ServerLayout section to the following:
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection
Then reboot. Does that sort your issue?

Note that you will need to edit that file as root - normal users don't have permission to write to it.

kjaada
26-05-2008, 03:52 PM
That was a disaster.My box started up in low graphics mode and I had to shut down and start in recovery and reset X.
Going again but Xorg.conf is back to what it was and still no keyboard in KDE.
Incidentally I did find (yesterday)two other posts on forums with the same problem
in earlier versons of Ubuntu.and despite some answers neither were solved.

Erayd
26-05-2008, 06:24 PM
This should not happen. Either you made a typo, or the new version of Ubuntu has some very, very weird (and very sloppy) hacks applied to it. The ServerLayout section is the standard place to specify which input devices should be used. There is no logical reason why this change should break things.

kjaada
26-05-2008, 07:27 PM
I cut and pasted yr section in after deleting the entry.Also why does Gnome work ok if that edit is required.

Erayd
26-05-2008, 07:33 PM
That edit isn't required, it's optional, and can be overridden (this is why gnome works). Entering it should *never* break things though - the fact that it does means the Ubuntu devs have some something rather stupid.

I'll do a bit of research and see if I can find some more info on your problem.
Edit: Does this (http://ubuntuforums.org/showthread.php?t=458036) sound like your issue?

kjaada
26-05-2008, 07:54 PM
Here is a reply I found in a KDE forum dated about a year ago.Bit drastic for me as I can get by or resetup KDE with another profile

A somewhat brutal way is to log in via Gnome, then using a Terminal (e.g. xterm) an moving your kde-directory ($HOME/.kde) to something else (e.g. "mv $HOME/.kde $HOME/kde-backup). After that you log out and log into KDE.

With this method you loose all your settings etc. in KDE, but at least you get your keyboard. But, because you only moved your prior KDE-directory you may get your settings via the Terminal again. At least it's the fastest method for your problem

Jen
26-05-2008, 08:03 PM
That doesn't sound too drastic, in fact you could do it in Gnome as the hidden folder .kde will be present in your home directory. You need to show hidden files/folders first. Just rename it to .kde-orig and then log out of Gnome and back into KDE. It will create a new .kde automatically.

If it doesn't work, then just rename the original folder back to .kde.

I've had to remove my .kde before due to a bad upgrade and losing stuff off my KDE menus.

kjaada
27-05-2008, 07:12 AM
It is too drastic for me as I am OK with Gnome and there is no need 4 me to have KDE unless it has all the little personal tweaks I had.I might just as easily Set up kde as I want it
from the start again.If I do not find the little booboo that caused the whole thing soon I will start again.I moved things about in my home folder and did not delete anything other than pictures so if i could get an idea what to look for I may be ok.

kjaada
27-05-2008, 07:57 AM
Further to the above:Everything on my KDE desktop is working except the keyboard..
so there is "something" the hardware detection looks for that is not in its right place.
Could I put a command in autostart to give it a kick in the guts ?

kjaada
27-05-2008, 08:33 AM
PROBLEM FOUND !!!!!
It is the timeing of the keystrokes,if i hold the key down for a while it works.
How do I alter this ???

Erayd
27-05-2008, 09:14 AM
PROBLEM FOUND !!!!!
It is the timeing of the keystrokes,if i hold the key down for a while it works.
How do I alter this ???I mentioned this above - see the link in my post, it's the same issue you're having, and has the solution:


...Does this (http://ubuntuforums.org/showthread.php?t=458036) sound like your issue?

kjaada
27-05-2008, 09:34 AM
I should have said before but slow keys is turned off and I have also found if I turn off "use repeat" it turns itself back on

kjaada
27-05-2008, 10:38 AM
Solved at last:When I booted in to KDE this time got a popup "do you realy want to deactivate slow keys" clicked yes and all is back to normal.
Thanks people.