PDA

View Full Version : Windows updates not installing



Ardony
13-05-2008, 04:03 PM
Whenever I try to install Windows updates the installer grinds to a standstill on ms.net.framework 2.0 SP (KB110806), and I have to cancel the installation.
OS = WinXP Home 2002 SP2.

Any suggestions to overcome this gratefully received.

wratterus
13-05-2008, 04:05 PM
Try installing a later version of the .net framework.

Do a custom windows update, and install version 3. Hopefully that will either allow the earlier version to install, or remove it.

The .net updates can be a pig if they get messed up. :(

Ardony
13-05-2008, 04:14 PM
wratterus, thanks for your super-quick reply. Do you mean to install SP3? If so, I've been reading that it's not a good thing for computers with AMD processors, as mine has. I wasn't going to bother "upgrading", as I don't need the new features.

wratterus
13-05-2008, 04:19 PM
Nope sorry, not SP3, just a newer version of the .net framework. (version 3)

If you do a custom windows update, and ignore the SP3 upgrade thing, it should appear under optional software updates.

Richard
13-05-2008, 04:30 PM
Nope sorry, not SP3, just a newer version of the .net framework. (version 3)

If you do a custom windows update, and ignore the SP3 upgrade thing, it should appear under optional software updates.

As a matter of interest, what is the .net framework? :confused:

wratterus
13-05-2008, 04:33 PM
I would explain it....but wikipedia does a much better job. ;)

http://en.wikipedia.org/wiki/Microsoft_.NET

Richard
13-05-2008, 04:42 PM
Thanks wratterus, I read that and cannot say I am really any the wiser. I think I will just assume that I need it, and leave it be. ;)

wratterus
13-05-2008, 04:46 PM
Thats the one. :thumbs:

One of the more common bits of software that need it is ATI's Catalyst Drivers.

Ardony
13-05-2008, 05:36 PM
Nope sorry, not SP3, just a newer version of the .net framework. (version 3)

If you do a custom windows update, and ignore the SP3 upgrade thing, it should appear under optional software updates.

Oh, good, I'll give it a try. Appreciate your help on this.

wratterus
13-05-2008, 05:37 PM
No worries, hopefully it will co-operate with us.

gary67
13-05-2008, 07:47 PM
Funny SP3 is on my wifes AMD PC and is giving no problems at all so far (touching wood) she is just running a semperon as only does a bit of office stuff and emails.

Ardony
19-05-2008, 03:42 PM
wratterus,

An update. After a fair bit a fluffing around I got some help from MS's free e-mail support desk (didn't know they had one, but it's about time). Got it sorted at the second attempt by following their procedure - they didn't tell me that EVERYTHING else had to be shut down - anti-virus, anti-spyware, firewall, the lot. That and the delay of up to 24 hours in responding aside, I found the service very helpful and they also walked me through a fix for a Flash update that wouldn't install.

Now I'm waiting for a response as to why eight Office updates won't install. What a time-wasting pain all this is!

Thanks for your help on this,

Richard

wratterus
19-05-2008, 03:52 PM
OK, cool.

It does sound as if you have a bit of a Windows Update issue. :(

One thing that would be worth trying is to re-register all the related .dll files.

Copy and paste the following text into a .txt document, rename it to .bat and run it.

Then install the updated Windows Update Agent from here (go.microsoft.com/fwlink/?LinkId=43264). Reboot. May not help, but it's worth a try.



%windir%\system32\net.exe stop bits
%windir%\system32\net.exe stop wuauserv
%windir%\system32\regsvr32.exe %windir%\system32\atl.dll
%windir%\system32\regsvr32.exe %windir%\system32\jscript.dll
%windir%\system32\regsvr32.exe %windir%\system32\msxml3.dll
%windir%\system32\regsvr32.exe %windir%\system32\softpub.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuapi.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuaueng.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuaueng1.dll
%windir%\system32\regsvr32.exe %windir%\system32\wucltui.dll
%windir%\system32\regsvr32.exe %windir%\system32\wups.dll
%windir%\system32\regsvr32.exe %windir%\system32\wups2.dll
%windir%\system32\regsvr32.exe %windir%\system32\wuweb.dll
%windir%\system32\regsvr32.exe %windir%\system32\Wintrust.dll
%windir%\system32\regsvr32.exe %windir%\system32\Initpki.dll
%windir%\system32\regsvr32.exe %windir%\system32\Mssip32.dll
%windir%\system32\net.exe start bits
%windir%\system32\net.exe start wuauserv

Ardony
19-05-2008, 04:06 PM
Gosh, thanks. I'll give it a go.

Ardony
26-05-2008, 10:47 AM
'Morning wratterus,

It's taken several days, but finally (touch wood, fingers crossed, etc., etc.) I think the update issues are resolved. I tried your method first, but without success - it was certainly a lot simpler than the alternatives MS offered, none of which worked, except the last, which was to re-install Office. Needless to say, a great deal of time was wasted setting up everything again the way I had it before.

Even after all that there was still an issue with the XML Core Services 4.0 SP2 update which, according to my update history, had been downloaded and installed no fewer than 43 times this year. Finally got that sorted over the weekend.

Thanks again for your help and suggestions - I appreciate your time.

Richard

wratterus
26-05-2008, 11:33 AM
No worries mate, glad you got it sorted.

Hopefully it won't happen again!! :o