PDA

View Full Version : External HDD - not detected or crashes PC



strifest
26-04-2008, 07:46 PM
Just got a hard drive in an external USB2.0 enclosure but it either isn't detected by the computer (Windows XP) or it's detected it doesn't show up in My Computer and basically can't get in to it. Trying to look at it in device manager causes the computer to crash. The drive's model is HDP725050GLA360.

It's in an USB2.0 enclosure so it doesn't need drivers to work, right?

Can anyone offer some insight into this issue please?

Thanks in advance.

Speedy Gonzales
26-04-2008, 08:22 PM
Is it connected to power?

Go to event viewer, whats that say, about the time it crashed?

Under system / application?

NZMacka
26-04-2008, 08:47 PM
I have had exactly the same ssue with a 6month old Seagate 500GB drive, mounted in an external aluminium enclosure.. I downloaded the seagate test software and discovered the drive was failing....managed to get it replaced under warranty.... It might be worth checking the drive integrity?

strifest
26-04-2008, 09:57 PM
Speedy Gonzales: Went into the event viewer but has no idea which one relates to the external HDD. It did have an error message about an I/O error.

NZMacka: Will download the program and test the drive asap. The drive is new and only arrived today so we hope it's not drive integrity issues.

Would installing the service pack help in any way?

Thanks a bunch guys!

gum digger
26-04-2008, 10:14 PM
the disc might not be formatted, go to control panel - administrative tools - computer management - storage - disc management. and see if you see your hdd listed.

Ninjabear
26-04-2008, 11:37 PM
the disc might not be formatted, go to control panel - administrative tools - computer management - storage - disc management. and see if you see your hdd listed.

Maybe try allocating a drive letter to it by following the instruction from the above post

Speedy Gonzales
27-04-2008, 02:21 PM
Speedy Gonzales: Went into the event viewer but has no idea which one relates to the external HDD. It did have an error message about an I/O error.

And what does it say??

Double click on it, click on the icon under the down arrow and paste it here

Whats the event id for it?

strifest
28-04-2008, 11:37 PM
Ok, ran the seagate test on the hdd and it's fine. Contacted the shop and they said to return for a replacement. Fingers crossed everything works out.

Thanks so much for all your help!