PDA

View Full Version : networking problems



Joe_Davies
08-02-2008, 08:25 AM
Hi everyone,

I run a small network at home consisting of my desktop and my laptop. They are linked through a Belkin wireless router and I share an internet connection happily through my Telstraclear cable modem (SB 5101 Surfboard).

All that works fine (thanks largely to help I got from people in this forum!), but I need to also share files and the printer.

I have set a number of folders on both computers to allow sharing, and the printer is also allowed to be shared, but when I'm on the laptop, I can't access the desktop files and I can't use the printer either.

When I check "My Network Places", I can only see the folders I have set to "shared" on the computer I happen to be using, not the other one.

Obviously, I need to set something else up so I can "see" the other computer's shared folders and the printer etc, but I have no idea how to do this.

I have tried "mapping a network drive", but still can only access it from the computer I set it up on.

Can someone let me know what I need to do to share folders and the printer across the network?

Both computers are running Windows XP SP2. The desktop chip is an Athlon XP 1800, running 750 odd MB of RAM and the Acer laptop chip is a Celeron running 1Gb of RAM. The wireless router is a Belkin 802.11g model.

Any help would be much appreciated thanks.

Joe Davies

Speedy Gonzales
08-02-2008, 08:30 AM
Go to control panel / printers. Right mouse on the printer / properties / sharing.

Select share this printer.

Then on the networked printer, go to the same place and add a printer, and click on whatever comes up.

Right mouse on the folders you created / sharing and security

Go to tools / folder options in my computer.

Tick use simple file sharing.

If any firewalls are installed, you'll have to configure them, to allow file sharing.

Make sure file and printer sharing is ticked in the firewall / exceptions tab.

HOW are they connected?? By ethernet or wireless?

If its wireless, if the router is also an access point, you'll have to configure the router.

So, the laptop can connect to it.

nofam
08-02-2008, 08:52 AM
Are they both in the same workgroup?

If they're connected by ethernet, I'd suggest setting the Belkin wireless unit to operate only as an AP; having it's router functionality turned on can lead to issues if your cable modem is the gateway.

MushHead
08-02-2008, 01:33 PM
If they're connected by ethernet, I'd suggest setting the Belkin wireless unit to operate only as an AP; having it's router functionality turned on can lead to issues if your cable modem is the gateway.

Joe - ignore that last suggestion:

nofam - The TelstraClear network setup basically requires a router: the cable modem can't be fiddled with AFAIK (without stuffing things up, anyway) - Telstra have control over them anyway, to some degree. The settings they're configured with do not involve the cable modem doing any router-type stuff.

nofam
08-02-2008, 03:11 PM
nofam - The TelstraClear network setup basically requires a router: the cable modem can't be fiddled with AFAIK (without stuffing things up, anyway) - Telstra have control over them anyway, to some degree. The settings they're configured with do not involve the cable modem doing any router-type stuff.

Sorry Mush. . . .didn't realise that :o So any NAT etc must be done at the Telstra end??

Joe - have you run the network setup wizard on both PC's?

Speedy Gonzales
08-02-2008, 03:13 PM
Joe - have you run the network setup wizard on both PC's?

Dont use this, its as useless as **** on a bull.

nofam
08-02-2008, 03:20 PM
Dont use this, its as useless as **** on a bull.

:D He he. . . .sad but true - just trying to ascertain what Joe's done so far (or hasn't done!)

wainuitech
08-02-2008, 03:41 PM
Joe - are the PC's XP Home or XP Pro ?

If they are XP PRO - try this

To turn Simple File Sharing on or off in Windows XP Professional, follow these steps:
1. Double-click My Computer on the desktop.
2. On the Tools menu, click Folder Options.
3. Click the View tab, and then select the Use Simple File Sharing (Recommended) check box to turn on Simple File Sharing. (Clear this check box to turn off this feature.)

This only works in XP Pro - XP Home has it turned on by default.

Joe_Davies
08-02-2008, 10:02 PM
Hi all,

Thanks for the suggestions.

To answer some of the queries, both computers are running XP Professional.

I have run the Network Setup Wizard on both computers, and named the workgroup HOME in both cases.

I did what Speedy suggested, but on the laptop, I did not get offered any printers that I couldn't already see - ie the one connected to the desktop computer did not offer itself for sharing.

I will try Wainuitech's suggestion next and let you know how I get on.

Thanks for your help, it's really appreciated.

Joe Davies

Joe_Davies
08-02-2008, 10:16 PM
Well, simple file sharing is now checked on both computers. I tried Speedy's printer suggestion again (on the laptop), but still did not get offered the printer that is attached to the desktop. Tried sharing the folders again, but I still can't see the other computer.

Do I need to remove and re-map the network drive?

Any other ideas?

Joe Davies

sal
08-02-2008, 10:23 PM
I recently came across (http://www.computerworld.com/action/article.do?command=printArticleBasic&articleId=9058842) a pretty well rounded bit of 3rd-party software for configuring home networks called Network Magic (http://www.networkmagic.com/). Sorry for the sales pitch but after installing this the other day, it even seems to be a good replacement for the native Windows networking tools and wizards.

Be aware that it is a commercial product with a 7 day trial initially, then a "downgrade" to the free but crippled version (product comparison (http://www.networkmagic.com/product/compare.php)). It's still definitely worth checking out though. I'm admittedly not one for purchasing software but this is on my list of "Windows software to consider purchasing".

linw
09-02-2008, 09:29 PM
Tell us about your firewalls. If you use them, disable them.

You really need to go back to basic IP network stuff. Check what IP no. each comp has (get to command prompt and type ipconfig /all. What IP no. and what gateway is displayed?). Try pinging the IP no. on the other machine. What result?

See here for more details http://www.crn.com/white-box/59200376