PDA

View Full Version : Sata drives showing on 'safely remove' icon



mzee
17-12-2007, 12:41 AM
When I select the 'safely remove' Icon to remove a USB device, it also shows the SATA drives. Can I edit this list so that I do not turn off a drive by mistake.

System is xp Pro with dual core AMD processor & SATA drives.

Neil McC
17-12-2007, 07:34 AM
I'm using this now to disconnect flash and external drives and also my plugin carriage hard drives without rebooting.Very handy.You can right click on the icon once installed and select the drives you want to show up on the left click/disconnect list,as it shows them by name.
http://mysite.verizon.net/kaakoon/hotswap/index_enu.htm

wratterus
17-12-2007, 09:09 AM
Are you using SATA connectors on the motherboard, or a PCI card?

Agent_24
17-12-2007, 09:59 AM
I know some ASUS mobos (and probably others) do that sometimes, usually if the board has eSATA support...

Asus FAQ showed something you can edit in registry to stop the drives appearing in the safely remove list, but I don't know what you have to edit.

stormdragon
18-12-2007, 09:45 AM
For my ASUS Motherboard an M2N-MX SE and supposedly any board with nvidia chipsets:

go into regedit:

BACKUP THE REGISTRY

Then Under

HKLM\SYSTEM\CurrentControlSet\Services\nvata

go edit, create, "DWORD"

name it "DisableRemovable"

set value as "1"

mzee
23-12-2007, 10:13 PM
Thanks Stormdragon.
It worked a treat.:)

Agent_24
24-12-2007, 10:22 AM
It's funny, I had to do that myself very recently on a M2N-MX SE! Seems the problem only happens when you install the nvidia SW IDE drivers, with the standard windows one the hard drive doesn't get into the removal list

wratterus
24-12-2007, 01:55 PM
It's funny, I had to do that myself very recently on a M2N-MX SE! Seems the problem only happens when you install the nvidia SW IDE drivers, with the standard windows one the hard drive doesn't get into the removal list

Nvidia motherboard drivers...... :yuck: