PDA

View Full Version : Networking Help required.



kbcad
16-11-2007, 12:25 PM
I am trying to network two PC's together for file sharing, etc. They are currently networked together succesfully for Internet connection. The PC's are both Dells (Dell new and Dell old) and both running Win XP (one Home [Dell old] & one Professional). Dell new is connected by Ethernet to a Belkin Wireless G router which is in turn connected to a D-link ADSL2+ modem and then to the 'Net. Dell old has a D-Link DWL-G122USB adapter. This works fine, and I can access the 'Net from either PC (residential gateway?)
However, I have not been succesful in getting the 2 PC's to talk to each other. I ran the network wizard on both PC's and then ran the Network diagnostic tool and things seem to be OK. I had "expert" help yesterday, and after 2 hours had to do a system restore on both PC's as he went away having got nowhere.
I have AVG anti virus on Dell new and Zone Alarm security suite on Dell old.
When I click on My Network places on Dell old, then Entire Network, then MS windows Network, then MShome I get an error message :
Mshome is not accessible. No permission, etc" I can't see Dell new.
Similarly when I click on My Network places on Dell new I can't see Dell old.
All help much appreciated. KB.

Speedy Gonzales
16-11-2007, 12:32 PM
IS SP2 installed on both??

Did you try the Wireless Network Setup wizard. Since you're trying to get wireless to work??

You shouldnt need ZA, if the router has a firewall in it.

I wouldnt be surprised if ZA is stopping something.

Disable ZA and see if it works.

CYaBro
16-11-2007, 12:38 PM
Are both machines in the same workgroup? i.e MSHOME

Adge
16-11-2007, 12:52 PM
^^ what they said.

If you're sharing an internet connection then the two computers SHOULD be able to talk to each other. Have you set up the firewalls to allow each computer to talk to each other? Your router is assigning each of them an individual 'IP' number to idetify them, and you need to set up the firewalls so that they let though data from the other computer's IP address.

As CYaBro notes, both computers need to be on the same workgroup. You can check this by right-clicking My Computer and going into 'Properties'.

kbcad
16-11-2007, 12:54 PM
Thanks for quick reply.
1) SP2 on both.
2) wireless setup wiz. used.
3) both PC's on MShome
4) Disabled ZA on both PC's. Can now see Dell new from Dell old, but can't see Dell old from Dell new.

KB.

kbcad
16-11-2007, 02:15 PM
Well, I'm getting closer!
On Dell new I can now see, under Network places,MSHOME, an icon for Dell old. However when I right click to ckeck properties I get an error message: "Do not have access rights" KB.

Speedy Gonzales
16-11-2007, 02:20 PM
Open my computer / tools / folder options.

View / Tick simple file sharing on XP Pro.

kbcad
16-11-2007, 02:31 PM
Hi, Speedy - that box is already ticked. KB.

berryb
16-11-2007, 02:57 PM
Make sure you have the same user name and password on both PC's

Speedy Gonzales
16-11-2007, 03:01 PM
You DONT have to have the same username and PW on both.

To network.

wainuitech
16-11-2007, 03:09 PM
Two other things to check -
Both PC's have different names - cant both have the same name in a LAN
Make sure the ZA is set to allow the whole range of Ip Addresses through the firewall from 1 - 255

berryb
16-11-2007, 04:36 PM
You DONT have to have the same username and PW on both.

To network.

True but when trouble shooting it is easier.

pheonix
16-11-2007, 08:22 PM
Check that the Guest account hasn't been disabled on either PC.

kbcad
17-11-2007, 08:02 AM
Good morning, gentlemen.
Pheonix - Guest a/c was disabled on both PC's - changed it - no effect.
All helpers - Current situation - ZoneAlarm on (on both PC's) but configured to allow local network as trusted zone.
Can access Dell new from Dell old but not the other way round. Get message "not accessible - may not have permission, etc"
This was the same situation as when I disabled ZA on both PC's, so ZA is obviously not the problem.
Windows Firewall is off on both.
Can I presume that the "block" is caused by some setting on Dell old?
KB.

CaptinMoor
17-11-2007, 11:53 AM
Hi there, a good way to check network connectivity is to use the ping function. Obtain the IP addresses for both boxes and try and ping each other. Suggest using the command line and trying

Shell> ping -n 3 <ip_address>

This will tell you where there is connectivity between the two boxes. If this fails then I would make sure that both PC's can access network. I know that you have already said that they can but if you do it at the same time you can elimitate a failure in the network.

Once you have confirmed that you cannot ping Each PC and that you can in fact get to the network the next thing would be to see what old ZA is actually blocking. I would close all firewall applications on both PC's. Then try pining each PC again. No Joy, then there is probably another application blocking the traffic.

Have you got the windows default firewall disabled?? Try disabling this as well and retry.

For more information on how to correctly configure your ports on each PC visit the MS site located here. http://support.microsoft.com/kb/308127.

If you have more trouble post a list of the EXCEPTIONS that you already have loaded. You will get what I mean when you look at the attached page.

All the best and let us know how you get on.

CaptinMoor
17-11-2007, 11:56 AM
Sorry, just bothered to read the post above. I take it you have already set up shares on both PC's?? Right clicking on the folder and then on the sharing tab.

Try just turning ZA off all together and see if that makes any difference.

To view all open shares for an IP, in your broswer window go \\<ip_address>
by doing this does this bring anything up??

kbcad
17-11-2007, 12:52 PM
CaptinMoor - G'day, from Alexandra.
My current situation is that both PC's appear to be connected.
When I go into My Network places - View Workgroup Computers - MShome on Dell new, I can "see" both old and new PC's, but when I click on the pld PC icon I get "no access rights"
When I do the same thing on Dell old, I can "see" both PC's and access both.
I have tried disabling ZA to no effect.
I have run Network Diagnostics on both PC's, and both gave a "pass" for Network adaptors.
Dell new pinged 192.168.2.1 (default gateway), 192.168.2.10 and 10.1.1.1
Dell old pinged 192.168.2.1, 192.168.2.2 and 10.1.1.1
I'm out of my depth with these.
Windows Firewall disabled on both PC's
KB.

pheonix
17-11-2007, 06:04 PM
The IP numbers are just addresses so the information knows where to go. The 10.1.1.1 is the odd man out there. It should be in the same range as the other two. Change it to 192.168.2.5
To change, double-click on the connection and select Properties. Highlight "Internet Protocol (tcp/ip)" and click on the Properties button.

CliveM
17-11-2007, 06:33 PM
Network Magic Pro should work with your setup. The free 7 day trial should be enough to sort out your initial network setup problems.

linw
17-11-2007, 09:59 PM
You are getting warm! You could do a lot worse than studying this site http://www.crn.com/white-box/59200376

george12
17-11-2007, 11:04 PM
First thing is, what are you sharing? Try this:

On Dell Old, right click a folder you want to share and click properties. Click the sharing tab. Choose a share name. Choose the most lenient possible permission settings.

On Dell New, go to Run and type \\computername\sharename where computername is the name of Dell Old (see System Properties -> Computer Name and ignore and dots) and sharename is the name of the share you just made.

Still getting an error about permissions? Restart the Dell Old in safe mode by restarting it and then pressing F8 repeatedly until you see the boot menu, and choosing 'Safe Mode'.

Log on as Administrator. Now, right-click your C: drive in My Computer and make sure that the user 'Everybody' has 'Full Control'. If Everybody is not in the list, add it by click Add and typing 'Everybody'. Check the box that says something like 'Recursively apply these settings to all files and folders' (this may be in Advanced).

Click OK. It will take a while to go through everything. Now, restart back into normal Windows and see if it has helped.

Don't worry about whether the Guest account is on or off in control panel. It shouldn't affect file sharing as turning it off only disables logging on as Guest.

Finally, if it still isn't working, try re-sharing the folder/drive or sharing another one and see what the result is.

kbcad
18-11-2007, 06:57 AM
Thanks to all. I am going to have a very interesting Sunday following the advice offered. Will report back on, hopefully, progress. KB.

kbcad
18-11-2007, 11:14 AM
G'day, George12
This "On Dell Old, right click a folder you want to share and click properties. Click the sharing tab. Choose a share name. Choose the most lenient possible permission settings.On Dell New, go to Run and type \\computername\sharename where computername is the name of Dell Old (see System Properties -> Computer Name and ignore and dots) and sharename is the name of the share you just made" worked!
So I can get into Dell Old one folder at a time. However, I am still denied access through MShome. Getting closer. KB.

linw
18-11-2007, 01:51 PM
Did you wait up to 15 min for the share to show? It can take this long for the network to register the new shares.

kbcad
18-11-2007, 03:13 PM
To linw - success! Thank you for pointing me at http://www.crn.com/white-box/59200376.
This article advised that a Registry setting "restrict anonymous" should be set to 0. It was set to 1 on Dell old.
A quick regedit and bingo! I can now access Dell old. Once again, many thanks to all who participated. Regards, KB.

SolMiester
19-11-2007, 09:59 AM
So IP addressing is okay because both pc's see each other, you have to sort out access rights and shares for each pc now.

Have you set up a shared folder on each pc?

Edit : never mind, sorted!

linw
19-11-2007, 08:59 PM
Superb!! That registry setting had me stumped once. That site was my saviour, too. Did you read all the heartfelt thanks from people who had spent days and weeks fighting that one?