PDA

View Full Version : Help with linux.... Part 4 (Squid not starting)



ronyville
04-10-2007, 03:12 PM
Hey peeps,
Everything was running fine, did a few reboots and other stuff and now squid is not starting up. This is the message i get under /var/log/messages
"Squid Parent: child process -1 started"
"Squid Parent: child process -1 exited due to signal 9"

Did some research and found out the signal 9 is a kill process so something is killing the squid process, I have looked but i cant seem to find anything wrong anywhere. This is all the processes that are running at the moment.
PID TTY TIME CMD
1 ? 00:00:01 init
2 ? 00:00:00 kthreadd
3 ? 00:00:00 migration/0
4 ? 00:00:00 ksoftirqd/0
5 ? 00:00:00 watchdog/0
6 ? 00:00:00 migration/1
7 ? 00:00:00 ksoftirqd/1
8 ? 00:00:00 watchdog/1
9 ? 00:00:00 events/0
10 ? 00:00:00 events/1
11 ? 00:00:00 khelper
51 ? 00:00:00 kblockd/0
52 ? 00:00:00 kblockd/1
53 ? 00:00:00 kacpid
54 ? 00:00:00 kacpi_notify
148 ? 00:00:00 cqueue/0
149 ? 00:00:00 cqueue/1
150 ? 00:00:00 ksuspend_usbd
153 ? 00:00:00 khubd
155 ? 00:00:00 kseriod
166 ? 00:00:00 khpsbpkt
183 ? 00:00:09 kswapd0
234 ? 00:00:00 aio/0
235 ? 00:00:00 aio/1
391 ? 00:00:00 kpsmoused
428 ? 00:00:00 ata/0
429 ? 00:00:00 ata/1
430 ? 00:00:00 ata_aux
434 ? 00:00:00 scsi_eh_0
435 ? 00:00:00 scsi_eh_1
448 ? 00:00:00 ksnapd
451 ? 00:00:00 kjournald
484 ? 00:00:00 kauditd
518 ? 00:00:00 udevd
1815 ? 00:00:00 kmpathd/0
1816 ? 00:00:00 kmpathd/1
1841 ? 00:00:00 kjournald
2383 ? 00:00:00 restorecond
2394 ? 00:00:00 syslogd
2397 ? 00:00:00 klogd
2425 ? 00:00:00 mcstransd
2438 ? 00:00:00 portmap
2459 ? 00:00:00 rpc.statd
2499 ? 00:00:00 rpc.idmapd
2519 ? 00:00:00 dbus-daemon
2558 ? 00:00:02 pcscd
2640 ? 00:00:00 automount
2659 ? 00:00:00 acpid
2670 ? 00:00:00 hpiod
2675 ? 00:00:00 python
2687 ? 00:00:00 cupsd
2701 ? 00:00:00 sshd
2725 ? 00:00:00 sendmail
2734 ? 00:00:00 sendmail
2746 ? 00:00:00 gpm
2758 ? 00:00:00 httpd
2760 ? 00:00:00 httpd
2761 ? 00:00:00 httpd
2763 ? 00:00:00 httpd
2764 ? 00:00:00 httpd
2765 ? 00:00:00 httpd
2766 ? 00:00:00 httpd
2767 ? 00:00:00 httpd
2769 ? 00:00:00 httpd
2777 ? 00:00:00 crond
2847 ? 00:00:00 xfs
2858 ? 00:00:00 smbd
2861 ? 00:00:00 smbd
2862 ? 00:00:00 nmbd
2873 ? 00:00:00 winbindd
2877 ? 00:00:00 winbindd
2895 ? 00:00:00 atd
2917 ? 00:00:05 yum-updatesd
2929 ? 00:00:00 avahi-daemon
2930 ? 00:00:00 avahi-daemon
2941 ? 00:00:02 hald
2942 ? 00:00:00 hald-runner
2948 ? 00:00:00 hald-addon-acpi
2955 ? 00:00:00 hald-addon-keyb
2961 ? 00:00:00 hald-addon-keyb
2964 ? 00:00:00 hald-addon-keyb
2971 ? 00:00:00 hald-addon-stor
3044 ? 00:00:00 smartd
3050 ? 00:00:00 miniserv.pl
3055 tty1 00:00:00 mingetty
3056 tty2 00:00:00 mingetty
3057 tty3 00:00:00 mingetty
3058 tty4 00:00:00 mingetty
3059 tty5 00:00:00 mingetty
3060 tty6 00:00:00 mingetty
3061 ? 00:00:00 prefdm
3065 ? 00:00:00 gdm-binary
3102 ? 00:00:00 gdm-binary
3148 ? 00:00:00 gdm-binary
3149 tty7 00:01:29 Xorg
3210 ? 00:00:00 gnome-session
3262 ? 00:00:00 ssh-agent
3265 ? 00:00:00 dbus-launch
3266 ? 00:00:00 dbus-daemon
3273 ? 00:00:00 gconfd-2
3276 ? 00:00:00 gnome-keyring-d
3278 ? 00:00:01 gnome-settings-
3295 ? 00:00:08 metacity
3300 ? 00:00:02 gnome-panel
3302 ? 00:07:01 nautilus
3306 ? 00:00:00 bonobo-activati
3312 ? 00:00:00 eggcups
3314 ? 00:00:00 bluetooth-apple
3316 ? 00:00:00 gnome-vfs-daemo
3329 ? 00:00:00 puplet
3334 ? 00:00:01 nm-applet
3336 ? 00:00:00 pam-panel-icon
3337 ? 00:00:00 pam_timestamp_c
3351 ? 00:00:00 mapping-daemon
3352 ? 00:00:00 escd
3355 ? 00:00:01 gnome-power-man
3362 ? 00:00:00 gam_server
3366 ? 00:00:05 wnck-applet
3368 ? 00:00:00 trashapplet
3376 ? 00:00:00 notification-ar
3378 ? 00:00:02 mixer_applet2
3380 ? 00:00:00 clock-applet
3406 ? 00:00:01 gnome-screensav
3408 ? 00:00:00 notification-da
3412 ? 00:00:02 gnome-terminal
3415 ? 00:00:00 gnome-pty-helpe
3416 pts/1 00:00:00 bash
3432 ? 00:00:00 firefox
3445 ? 00:00:00 run-mozilla.sh
3450 ? 00:01:21 firefox-bin
3775 ? 00:00:13 gedit
4307 ? 00:00:00 dhcdbd
4311 ? 00:00:00 NetworkManager
4336 ? 00:00:00 dhclient
4652 ? 00:00:00 pdflush
4654 ? 00:00:00 pdflush
4716 pts/1 00:00:00 ps

Any help would be appreciated.
Cheers

Graham L
04-10-2007, 03:57 PM
Squid will probably have a log file of its own.

It might just be that there wasn't anything for a client to do, so it was stopped. (Usually, a system which can have multiple client processes running (depending on the demand) keeps one (or more) ready for immediate use, but ... ;) )

ronyville
04-10-2007, 04:17 PM
Squid will probably have a log file of its own.


If you are talkin about this /var/log/squid/access.log, I had a look and its empty. :stare:

beama
04-10-2007, 05:08 PM
try
service squid status
want do you get back

ronyville
04-10-2007, 06:48 PM
Tried service start squid and /etc/init.d and also through webmin.

service start squid gives me ..................... FAILED. ( after about 2 mins )
Squid is also on the startup options and still doesnt start.
M thinking that squid may have crashed.. :badpc:

ronyville
10-10-2007, 02:01 PM
Heres some more details if it helps with my squid problems.. if not than i might just have to reinstall everything all over again :badpc:

[root@proxy2 ~]# squid -z
2007/10/10 14:15:20| Creating Swap Directories
[root@proxy2 ~]# service squid start
init_cache_dir /var/spool/squid... Starting squid: ........[FAILED]....
[root@proxy2 ~]# squid -NCd1
2007/10/10 14:19:46| Starting Squid Cache version 2.6.STABLE13 for i686-redhat-linux-gnu...
2007/10/10 14:19:46| Process ID 3513
2007/10/10 14:19:46| With 1024 file descriptors available
2007/10/10 14:19:46| Using epoll for the IO loop
2007/10/10 14:19:46| Performing DNS Tests...
2007/10/10 14:19:46| Successful DNS name lookup tests...
2007/10/10 14:19:46| DNS Socket created at 0.0.0.0, port 32772, FD 5
2007/10/10 14:19:46| Adding nameserver 192.168.9.254 from /etc/resolv.conf
2007/10/10 14:19:46| User-Agent logging is disabled.
2007/10/10 14:19:46| Referer logging is disabled.
2007/10/10 14:19:46| ipcCreate: fork: (12) Cannot allocate memory
FATAL: Failed to create unlinkd subprocess
Aborted

Erayd
10-10-2007, 02:15 PM
it's running out of memory, or SELinux is blocking it. Do you have any swap set up? If so, is it enabled? How much memory is in the system? Is SELinux enabled?

ronyville
10-10-2007, 02:22 PM
it's running out of memory, or SELinux is blocking it. Do you have any swap set up? If so, is it enabled? How much memory is in the system? Is SELinux enabled?

Firewall and SELinux has been disabled,
swap is 992MB, used is 60MB only,
real memory is 512MB, used is 148MB only
CPU P4 3.0GHz

ronyville
10-10-2007, 03:50 PM
Thanks for your helps guys, I just reinstalled squid and its working fine now, just need to configure it to my old settings.

Cheers