PDA

View Full Version : winXP 64 bit error: The system administrator has set policies to prevent this install



guiltstealer
08-07-2007, 08:36 AM
hi there ppl :)

i'm using winxp 64bit on an e6700 pc... and i'm trying to install the training for motionbuiler software but the when it reaches the windows installer part (after self-extraction) it gives this error:

"The system administrator has set policies to prevent this install"

i am the sys admin... and i have tried to change the wininstaller policies by starting the gpedit.msc through run and disabling the disable windows installer policy in Local Computer Policy/ computer configuration/ administrator templates/ windows components/ windows installer... i have also tried setting a key in HKLM\Software\Policies\Microsoft\Windows\Installer by the name of DisableMSI with a value of 0. i have even tried right-clicking the installation package and running it as an administrator... but NOTHING WORKS:confused:

can someone out there please help me on this?:help:

thanks a lot in advance :)

berryb
08-07-2007, 06:46 PM
Have you disabled the security option (can't think what it called) in the user account. I had to disable this to get a certain piece of software to inst all and run but had to enable it for most programs to install - Adobe for one. The setting is enabled by default.

guiltstealer
09-07-2007, 09:53 AM
hi BerryB..

thanks for the reply...

but which option are u talkin about?

berryb
09-07-2007, 05:51 PM
hi BerryB..

thanks for the reply...

but which option are u talkin about?

Sorry re read your post. I'm thinking of Vista.

SolMiester
09-07-2007, 06:03 PM
Have you tried, 'Run as' then use the administrator account?

krisr
03-09-2007, 03:32 PM
Have you tried using the Windows Installer Cleanup Utility? It's available here http://support.microsoft.com/kb/290301 and fixed my issues.

1) Install this utility and run it.
2) Select the installer configuration for the software you are trying to install (hopefully it's listed).
3) Click on Remove
4) Try installing the software again.

I was having the same error as you but mine was a problem with MSXML6.0 while installing SQL Server 2005 Express Edition. This worked for me after I removed the installer configuration for MSXML6.0.

I hope this works for you,
Kris

Febee
04-10-2007, 04:38 AM
Sorry re read your post. I'm thinking of Vista.

Could you possibly find the option again?
I'm having the same problem but on Vista :/

berryb
04-10-2007, 11:27 PM
Could you possibly find the option again?
I'm having the same problem but on Vista :/

I had to turn off "User Account Control" in control panel/user accounts. The reason was that Adobe Reader would not install as Adobe had not updated their program to work fully with Vista. This has now been fixed as my problem was sometime ago. But the same thing could happen with other programs I suppose and this may be your problem??

Once Adobe was installed I had to enable the option again as other programs wouldn't install and I was having permission problems.

You may have to right click and "run as administrator".

HTH