PDA

View Full Version : mix gigabit lan with 100/10 without a switch



heni72847
16-06-2007, 08:10 PM
want to make some of my computers connect using gigabit ethernet
but don't really want to spend money on a new router or switch yet
so was thinking of leaving everything as it is
and just add two gigabit NIC onto the two mostly used computers which require faster networking

my plan is drawn here:
http://img172.imageshack.us/img172/3865/mixedsd7.gif

so all the computers will connect to router which max at 100mbps
but is it possible to have two special computers with a second 1000mbps NIC
and joined up by a crossover cable?

not exactly sure how to tell those two computers to send data across the gigabit path instead of through the router when they decide to exchange files..

is this setup possible at all?
want to make sure before I go and buy the new 1000mbps NICs

Erayd
16-06-2007, 09:15 PM
Yes, this is possible, and very easy to implement. Just specify a custom route on each PC - you should only need to do this once, then it will all 'just work'. And if you happen to unplug the gigabit, it should automatically fall back to the existing 100MBits/sec network, and will start using the gigabit again when you plug it back in.

heni72847
16-06-2007, 09:25 PM
how exactly do you specify a custom route on each PC?
and one of the two machines is running kubuntu..so prob need to go learn more stuff again..

Speedy Gonzales
16-06-2007, 09:33 PM
and one of the two machines is running kubuntu..so prob need to go learn more stuff again..

It maybe, or should be pretty easy to see XP's folder from Kubuntu ( I did it here, managed to share the XP folder on the other PC, from Kubuntu).

You have to install Samba. Once u get the XP folder shared, you can either access it by putting a shortcut on the Kubuntu desktop or typing the ip addy / folder in FF..

The files in the shared XP folder will also appear here.

But trying to see a folder on Kubuntu from Windows is a bit trickier. I havent figured this bit out yet.

Bantu
16-06-2007, 09:40 PM
nothing to stop you running dual nics in your two main machines and the rest of your network 100.
A lot of linux machines run dual nic.
1000 in each of your two main machines plus a 100 nic in each of all machines. assign maybe 10.0.0.* to your two 1000's and 192.164.1.* to all the 100 nics, they will still all talk to each other.

heni72847
16-06-2007, 09:51 PM
ahh okay
I got samba working the way I want it already
just wasn't sure what happens when I have two NIC

so now my network is the 192.168.1.* range
so for my 1000mbps NIC I just set a different range eg. 192.168.2.*
then should be sweet :D

thanx all~

Erayd
16-06-2007, 10:19 PM
You will still need to add custom routes (use the 'route' command on both operating systems, syntax varies a bit) if you are accessing the PCs by name, or by the windows network folders. If you access them by their gigabit IP then you don't need to bother.

winmacguy
16-06-2007, 11:22 PM
Pardon the side track but what are you going to be running over your gigabit network?

heni72847
16-06-2007, 11:53 PM
my kubuntu machine's purpose is mainly web browsing and email
just something to access internet quickly without turning my xp machine on
but it got 40+20gb hdd in it
so I use it as network storage too
recently I kinda end up moving files quite often so I thought maybe I'll give gigabit ethernet a try to speed things up..

..um..custom routes..
not exactly sure what that is..I guess I'll just access it by \\ip address then..

Myth
16-06-2007, 11:53 PM
Just an aside ...

But trying to see a folder on Kubuntu from Windows is a bit trickier. I havent figured this bit out yet.
In smb.conf I set security to shared (security = share) which bypasses password requirements. But then again I don't mind others having free access to my files. The shared dir was set to root has write access, all users can read (to prevent those on the network from deleting or adding any files)

heni72847
17-06-2007, 12:02 AM
since going OT..might as well post my smb.conf if speedy wanna check this out



[global]
workgroup = MYWORKGROUP
server string = MYMACHINENAME
interfaces = lo eth0
bind interfaces only = Yes
security = user
log file = /var/log/samba3/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384 IPTOS_LOWDELAY
dead time = 15

[Kubuntu Share]
path = /home/user/xpcme
comment = kubuntu share
read only = no

I think I setup some samba user accounts too on kubuntu
which matches the username and password on my xp machine making things simplier

Speedy Gonzales
17-06-2007, 10:07 AM
Just an aside ...

In smb.conf I set security to shared (security = share) which bypasses password requirements. But then again I don't mind others having free access to my files. The shared dir was set to root has write access, all users can read (to prevent those on the network from deleting or adding any files)

lol I cant even see the folder on XP let alone bypass the pw prompt etc.

It did come up with the pw prompt before I reformatted Linux (coz I screwed up the printer I configured on Linux, I deleted it and couldnt get it back!).

I'll have to check smb.conf, if I can find it that is, and see whats in it.

At the mo, I'm trying to get KPPP (the dialler to dial out). I dl Gimp-ppp last night to see if that would be any better. Since at least it doesnt run by stupid scripts and at least it looks more like XP's.

I can dial out using pon and poff in terminal, but KPPP even tho I used the Wizard which put in the right info, it stops at Initialising and goes no further (this DID work too before I formatted, I just cant remember WHAT I did), previously.

The modem is recognised obviously, since it dials out if I use pon to get onto Ihug.

Speedy Gonzales
17-06-2007, 10:18 AM
since going OT..might as well post my smb.conf if speedy wanna check this out



[global]
workgroup = MYWORKGROUP
server string = MYMACHINENAME
interfaces = lo eth0
bind interfaces only = Yes
security = user
log file = /var/log/samba3/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384 IPTOS_LOWDELAY
dead time = 15

[Kubuntu Share]
path = /home/user/xpcme
comment = kubuntu share
read only = no

I think I setup some samba user accounts too on kubuntu
which matches the username and password on my xp machine making things simplier

I'll look at my smb.conf, (I'm on XP atm).

If you want to share a folder on XP's is the workgroup the same as Ubuntu's??

You may want to change security = share as Myth said. That may get u somewhere.

heni72847
17-06-2007, 01:32 PM
um..er.. I posted my working smb.cfg
I can use user security and still make it work
and yea..workgroup name across the machines are the same