PDA

View Full Version : LAN help



Michael8
09-06-2007, 05:06 PM
Hi,

I am having problems sharing files over a network. The computers in my house and the modem are connected to a switch. The IP settings for each computer are set to automatic. I can surf the internet from any of the computers however I cannot access the files of another computer. I have set the properties of the folders of all the computers to allow file sharing. Everytime I go to view my network connections, the other computers of the network do not show up in the list.

How do I configure the settings of the computers so that I can share files?

Thankyou,

Michael

Speedy Gonzales
09-06-2007, 05:43 PM
Make sure the workgroups on all are the same and if any firewalls are installed they have to be configured as well.

Renmoo
09-06-2007, 08:18 PM
Have you tried unsharing and resharing the folders concerned?

Cheers :)

motorbyclist
10-06-2007, 02:25 AM
XP or vista? - did you run the wizard? any firewalls?

switch or hub or router? - ie will it actually assign ip addresses.

what ip addresses are being used? - sometimes it pays to manually set one of them

motorbyclist
10-06-2007, 02:32 AM
oh, here's a thought, find our if your computers can "see" each other.

are you familiar with the "ping (http://www.imagef1.net.nz/files/ping.JPG)" command? just replace "10.1.1.1" with your another computer's ip address.

and then have some fun, try

ping www.google.com

ping www.google.co.nz

ping www.google.co.uk

and see the different results :D - yep i got bored one day

Michael8
11-06-2007, 02:54 PM
I've tried it with all the firewalls turned off but it still doesn't work. How do you change the workgroup name?

I haven't tried unsharing and sharing the files concerned. When the computers are connected directly to each other without the switch using cross-over network cables, the files on each computer can be accessed.

One computer is using vista, the other 2 are using xp. I did not run the wizard. The ip configuration are set to automatic. The ip address of the computer that I am using right now is 10.1.1.3 and the default gateway is 10.1.1.1. The other ones are similar.

I tried pinging the other computers but I got the requests timed out and there was a 100% lost. This happened when I tried to ping this computer's own ip address as well.

Michael8
11-06-2007, 03:51 PM
Not sure if this helps but my modem is a router (D-link 502T). So the router and the computers of the network are connected to the switch.

linw
11-06-2007, 08:09 PM
Forget about file sharing for the moment as you have to get pings to work first. Must admit I am not at all sure about what is wrong as working to the Internet proves the basic IP system is working. I am also very puzzled that you can't even ping your own IP number. Bottom line, however, is that your pings are not getting a reply.

What firewall are you using? You say you have tried turning it off with no better result. Sometimes the background firewall services still run even though you have turned the FW off. Try to see if the firewall has a trusted zone like ZoneAlarm and set the zone to an IP range like 10.1.1.1 to 10.1.1.254.

Check that the subnet mask is the same for all machines (type ipconfig /all at the command prompt). It is normally 255.255.255.0

Just concentrate on getting a ping to work to one other machine. When that is cracked, the others will follow.

I'm struggling a bit, here, but see if any of this is in anyway helpful and report back.

Michael8
11-06-2007, 09:20 PM
My LAN seems to be working now. I am able to access files of other computers even though the ping to this computer is still not working. Why doesn't it work? I still get the same error message when I try to ping my own computer. This computer is using windows xp professional.

What I did was manually assign IP addressses, the DNS and the default gateway to each of the computers in the network. This way, they don't rely on being assigned ip addresses by the router.

Thanks for all your help!

Michael