PDA

View Full Version : Root permission



kjaada
07-06-2007, 12:05 PM
Have installed Kubuntu on a partition and was not given the oppertunity to put in a root password dureing the install.I now do not have permission to access the partition and it does not show up in "media" but boots ok from Grub
I have other OS's and can access the drive from them but would like to set up root access in ubuntu ???

Erayd
07-06-2007, 12:57 PM
To enable the root account in Kubuntu:
Open up a shell. This should be located under K>>System>>Konsole (I think - it's been a while since I last looked at Kubuntu).

Type 'sudo bash' and hit enter. You will be prompted for your password.

This will give you a 'root' level command prompt - the prompt should now end with a '#' to indicate you are root.

Now type 'passwd' and hit enter. This will prompt you for a new password. Once this is set, the root account is now enabled.

kjaada
07-06-2007, 02:06 PM
That worked but I still can not "see" my ubuntu partition.I have created a dir for the drive but can not access the fstab file cause the drive does not show.Even from one of my other OS's I can get to the fstab but can not change it

Sherman
07-06-2007, 04:12 PM
That is the one thing I hated about Kubuntu. If its not your home directory or removable storage, good luck trying to access it...

Jen
07-06-2007, 06:10 PM
Can you browse to the / directory if you put / in the address bar of Konqueror?

What happens if you open up fstab directly as sudo with a text editor?

Eg:
$ sudo kwrite /etc/fstab

kjaada
07-06-2007, 06:24 PM
I have uninstalled kubuntu in the mean time.I was not all that struck on it after PCLinuxOS but played with it after seeing ubuntu was the No1 linux OS.The fact that it did not "see" its own
partition was beyond me.I could have understood it not recognising my Xandros or PCLinux partitions,but its own disk ?????

Erayd
07-06-2007, 06:40 PM
It will have been able to see it, just not perhaps in the way you were expecting. Did you mount the disk?

kjaada
07-06-2007, 06:50 PM
Why would I have to mount the disk the OS was on.AND I did try after to mount the disk but I could not as I did not have permission.This has been a very strange exercise.

Erayd
07-06-2007, 07:32 PM
Aah... Must've misunderstood you there, the impression I got was that you were trying to access another OS's partition from within kubuntu.

What happened when you went to / in konqueror? I'd be willing to bet money you saw the contents of your kubuntu partition. Note that you need to be root if you want to write to it.

Graham L
07-06-2007, 07:44 PM
Forget about "disks" for the moment. After you have booted there is a single file system, rooted on "/". That's where your Ubuntu "partition" is. It was mounted at "/" as part of the boot process. You don't need to make a directory for it. It is already there. Only if you wish to add other partitions to the filesystem do you need to mount them onto mountpoints in the booted file system.

/etc/fstab is fstab. ;)

racepics
08-06-2007, 09:23 AM
In Kubuntu - go to "System Settings" in the main menu
In the "system administration" area click on the "Disk and Filesystems" icon
This will show you all detected drives and partitions in your system
It will also show you which ones are mounted and/or enabled
If your Ubuntu partition is not mounted/enabled hit the "administrator mode" button and typr your password,
You will see buttons along the bottom of the window
NEW | MODIFY | DELETE | ENABLE | DISABLE | DETAILS
Click on the drive or partition you want to get at and make the required changes using the options along the bottom.
If your drive is mounted and enabled but you are denied access to it, you can change access permissions in the "Modify" feature.

racepics
08-06-2007, 09:34 AM
Was it Kubuntu 7.04?
If so the "/" root partition is hidden ( for some strange reason )
You can still get to it by typing the path into the konqueror address bar but the file browser will not "show" it to you.. annoying yes.
I suppose they hide it so as to stop n00bs from damaging the system - a bad idea IMO - the whole idea of linux (for me at least ) was to learn, often by making mistakes......

kjaada
08-06-2007, 09:59 AM
Thanks for that I will give it another try now I know it was not something amiss with my setup.