PDA

View Full Version : hard drive write error



Hokonui
04-05-2007, 07:59 PM
I'm trying to restore a late model Compaq Presario (SR1925AN - Athlon64) to it's original condition for a family member. I have newly arrived Compaq recovery discs. Whenever I try to boot using these discs I'm asked if I want full system recovery (yes) and immediately get a "hard drive write error!" with reboot the only option.

Have found I can boot & install WinXP Home from my personal copy ok which suggest drive is ok but whenever I run the Compaq discs that belong with the machine I get the write error. (NB this is resulting from a failed Vista install which messed up the hard drive)

I have reformatted the drive successfully using XPHome. Am suspicious the failed Vista install has left something that is interfering with the Compaq recovery.

Any help would be appreciated

The_End_Of_Reality
04-05-2007, 08:35 PM
Run the HDD manufacturers diagnostics tool and see if that picks anything up, try setting it on different cables.

And FYI just because the HDD showed no errors on Windows setup does NOT mean it is fine... heck even the manufacturers diag tool can't definatively say!

Zero fill the HDD (if it is a Seagate (well it should work with any brand, but need confirmation) run the Seagate DiskWizard and zero fill the HDD, this will ensure there is nothing on the drive)

Hokonui
04-05-2007, 10:06 PM
Thanks End of Reality

That was all I could think of .... will open it up and check the hdd and do as you suggest.

I also tried Gparted which hung after loading.

recovery partitions, recovery discs,
and Vista install via propriety upgrade all suck as far as I can see.

pctek
05-05-2007, 06:42 AM
I have reformatted the drive successfully using XPHome. Am suspicious the failed Vista install has left something that is interfering with the Compaq recovery.

This originally had a recovery partition on it?
And someone decided to put Vista on it?
Did they mess with the partitions?

Check what partitions exist now, and what were there before, that might be why its complaining.

Hokonui
05-05-2007, 09:29 AM
Hi pctek

Vista install (via HP upgrade discs) hung at/just after unpacking files stage and wouldn't rollback, apparently taking old partitions with it. (Compaq tech thought it might be because pc has extra memory and therefore isn't stock std??)

It had a recovery partition, now gone and I've repartitioned since.

Have found some samsung disk utils and am running them at present to check hdd and will probably use them to clean erase also.

I'll try and find out what the config was originally and return to that.

pctek
05-05-2007, 12:31 PM
(Compaq tech thought it might be because pc has extra memory and therefore isn't stock std??)

It had a recovery partition, now gone and I've repartitioned since.


Did he. I doubt it.

Well you could just do it the manual way. Install Win-whatever. Install drivers. Install apps.

That way you wouldn't get infested with the HP crap.

Graham L
05-05-2007, 01:44 PM
Make sure the BIOS setup doesn't inhibit wrting to the boot sector. :D

You could try removing all partitions, leaving it as a "bare disk", for the installation to partition the way it wants it.