PDA

View Full Version : The gimp with GTK+2



gradebdan
21-04-2007, 03:29 PM
Hi
I wanted to look into "the gimp" which I d/l from pc world disc.It says I must install GTK+2 first.Whilst doing this part it says 2 files need to be changed. ie C:\WIN\SYS32\XMLPARSE.dll will need to have .off added to it and the other file:- same but XMLTOK.
Then it says changing may cause other progs to not work properly. Am I safe to carry on and have the .off added to these 2?

Renmoo
21-04-2007, 04:17 PM
This might be of interest to you, gradebdan: http://www.gimptalk.com/forum/topic.php?t=246&start=1

Seems that that person changed it and no problem was created as a result.

Cheers :)

Graham L
21-04-2007, 04:44 PM
"dll" files contain libraries of subroutines, which are shared between the OS and all applications. The Gimp people suggest renaming the current versions of libraries which they require to be different, so that if something else essential to you stops working, you can rename them back. :) That would stop Gimp working, but you could go back to your previously working system.

They probably add a few routines, or make minor changes to some of them, and they don't have the resources to check that everything in the world will work with their versions. So they warn you. It's likely that you won't get any problems, because the Gimp peple are very clever, but they can't give an absolute guarantee.

gradebdan
21-04-2007, 09:17 PM
Thank you for your input. I have opted for the file change and all seems ok . Now have to have a play with Gimp.

gradebdan
21-04-2007, 09:33 PM
Hi
Just discovered a major problem (for me).
When I open a photo in "my pictures" it opens in the Gimp screen. I want to look at photos that I do not intend to fiddle with in the Win xp or Nerovision screen. Is there a place where I can choose where my photos open?

gradebdan
21-04-2007, 10:43 PM
I've been searching around but can not find where to change what opens "my photos"

Faded_Mantis
22-04-2007, 03:00 AM
right click on the file and go "properties" where it says "open with" click "change" and sellect "windows picture and fax viewer" (if that's what you want)

I think it applies this change to all pictures of that type (e.g. all jpg images) so you will need to do this with a .jpg and a .gif etc.

If you want to open the image to edit just right click the file and go to "open with >" and then GIMP should be in the options - This is how I do it. However I didn't have to tell all my files to open in windows picture and fax, as I think GIMP had an option to select which file types to associate with it on install and you could just untick all the ones you didn't want it to open when you clicked.

gradebdan
22-04-2007, 01:33 PM
Hi Faded_Mantis
I followed your instructions and everything now fine. Thankyou.