PDA

View Full Version : Cursor hops about when typing document



argus
03-03-2007, 04:07 AM
When typing almost anything of any length - Word documents, emails, Usenet news postings - the cursor quite frequently jumps from the end of the text to a random point in the middle of what I've already typed, so the text I'm typing interposes itself there.

Sometimes it happens at less than half-minute intervals, making it infuriating to keep track of what I'm typing.

It happens whether or not I'm connected to the internet and, as far as I can tell, irrespective of what other programs I'm running.

Most annoying are the cases (thankfully few) when it executes two hops in quick succession and "selects" a bunch of text, so when I press the next character, that selected text disappears :( If I'm in Word, I can "undo" and get it back, but anything else - hard luck.

It smacks of mischievious interference, but I've scanned with Spybot Search and Destroy and I have Norton intrusion detection running all the time and do regular virus scans.

Alternatively, perhaps it's just the awkward keyboard of this laptop and I'm unintentionally myself pressing key combinations that caue the cursor to hop. Or there's dirt under the keyboard causing random connections?

Entering text into a browser window like this seems to be one of the environments in which the hopping doesn't happen. That suggests to me that it's a software rather than a hardware/dirt/FUBKAC problem.

Any ideas?

Toshiba Satellite laptop; Windows XP; Microsoft Word; Firefox browser; Eudora email; Forte Agent newsreader.

Argus

Rob99
03-03-2007, 07:24 AM
Ctrl Z will undo in most things.

Make surte you are not touching the touchpad.

johcar
03-03-2007, 07:55 AM
I also use a Toshiba and occasionally have a similar problem.

But my problem is definitely PEBKAC/FUBKAC - the mouse touchpad is pretty sensitive and just a slight brush with a thumb pops the cursor exactly where I don't want it.

To see if this is your problem also, plug in an external mouse and switch off your touchpad (Start>Control Panel>Mouse + TouchPAD On/Off + Disable. Alternatively, Fn + F9 may work on the keyboard to do the same thing).

Try out your typing skills again - I think you will find this sill be the solution. But it does mean you need to use an external mouse instead (or keyboard shortcuts) - my personal preference is the external mouse over the touchpad anyway: far less fiddly for fat fingers like mine.

mark c
03-03-2007, 08:00 AM
I have found shirt cuffs brushing over the Control Key while typing activates the control functions and can do unexpected things.

Scouse
03-03-2007, 10:00 AM
Wow - no disrespect here, but shirt-cuffs. I haven't worn or thought about shirt-cuffs for 25 years. Wow. Memories. Shirt-cuffs - well, who'd have thought.........

mark c
03-03-2007, 10:44 AM
Even worse if you wear trousers with cuffs.

Shortcircuit
03-03-2007, 10:56 AM
Even worse if you wear trousers with cuffs.

And I would be concerned it they were brushing across the touch pad.

I did have this problem with an old comp (not laptop) where mouse and something else was causing hardware conflict... would be strange to get a conflict in a laptop where everything was pre-installed though.

CYaBro
03-03-2007, 11:04 AM
You will be tapping the touch pad with your wrists which will be moving the cursor.
You should be able to turn the touch pad off or play around with the sensitivty settings. Something like Fn + F7 usually turns the touch pad on or off.

Graham L
04-03-2007, 01:30 PM
Some touchpads are very sensitive and you don't even need to touch the surface to get unwanted cursor movement.