PDA

View Full Version : USB drive not showing all files



garyasta
29-01-2007, 05:17 PM
I have been transferring files from my PC to my laptop via a USB drive and find that not all files are displaying when i open the USB drive on the laptop. There are 799mb files indicated (Right-click on the drive>Properties) but only 199mb total of files are displayed when I open the drive.

Any help?

Cheers
Gary

Speedy Gonzales
29-01-2007, 05:28 PM
They maybe system files. Is hide protected system files unticked as well??

Are these system files, or files you've installed already, or files you've downloaded (the original exe/zip file/s)?

Hopefully they're files you've downloaded but not installed yet.

Coz if you're copying files/programs from the PC to the laptop and they've already been installed on the PC, and expect them to work after they wont.

garyasta
29-01-2007, 05:40 PM
The files are a mixture of folders and .exe files that I am trying to transfer. Some files I will delete because they are already on the laptop, others contain .exe (downloaded apps.) files along with reg. numbers and relevant info. Most apps. are up and running on the PC and I now want to install them on the l/top.

The "hide protected system files" is unticked as well.

Cheers
Gary

Graham L
30-01-2007, 12:24 PM
I think you'll find that the problem is not the total size of the files "seeable" but the limit on number of entries in the top level directory of a FAT files system On floppies it's something like 130 files.

Create a subdirectory on the USB drive, and copy the files into that. The root directory has a fixed size; subdirectories are just files, and can contain any number of files.

garyasta
30-01-2007, 12:50 PM
Hi Graham

TKS!

Will try your suggestion and get back to you.

Cheers
Gary

Brandon Metcalf
31-01-2007, 04:15 AM
And what's with 'Show hidden files and folders' radio-button in Tools|Folder options dialog box? Try to check disk with some disk editors like the ones from Acronis or Paragon.

garyasta
31-01-2007, 10:44 AM
Hi Graham and Brandon

I generated a new folder and placed a number of files in it with now appearance of any of the 'hidden' files.

I then ran a file editor which only displayed the previously visible files an no others.

Cheers
Gary

Chilling_Silence
31-01-2007, 11:22 PM
Copy all the files off, format it, then copy them back

Its a problem that commonly occurs when the drive hasnt been properly "ejected" before removing it from the PC. Had the same problem on my thumbdrive a few seperate times after loaning it to other people and they didnt eject it properly. Simple enough fix, just a bit of a hassle :)

Graham L
01-02-2007, 01:39 PM
Chilling's referring to what happens when the device has been removed before the updated directory has been written to it. I don't think that's what has happened here.

Microsoft (technet2.microsoft.com/WindowsServer/en/library/50cd4ffc-1389-423d-9d02-1a898b2eb39f1033.mspx?mfr=true) say there's a maximum of 512 files allowed in the top level directory (of non-floppy drives), and this number can be reduced by the use of 'long" file names,

Just creating the new subdirectory won't make the previously written files visible. You might need to format the device, then create the subdrectory, and write your files into it.

garyasta
01-02-2007, 02:17 PM
Thanks Guys

I am going to try a new tack and re-copy any files that I need and pay a little more attrention to how much I attempt to copy.

Cheers
Gary

Graham L
01-02-2007, 02:23 PM
I think you should have got some error messages during the copy after it hit the limit... perhaps you started it copying, and walked away because it was going to take a long time. :D

It would probably be worthwhile making a subdirectory to use as the target.

garyasta
01-02-2007, 02:30 PM
Will do

TKS!