PDA

View Full Version : LINUX (very) newbie question



Tony
22-12-2006, 03:55 PM
I've installed Ubuntu Linux dual-booting with WIN XP on a spare machine. So far, so hoopy - in fact this post is coming from Firefox on Linux. The machine is networked, and I can see and access the other machines on the network fine - they are all XP beasts. My problem is access the other way round. I have the Linux machine set to the correct workgroup by editing Samba.conf, so the other PCs can see it, but if I try to access the Linux PC from another machine, I get asked for a login and password, and whatever I supply does not seem to be accepted - it just re-displays the login request.

I presume there is something else I have to configure on the Linux PC - But what, I have no idea. Any suggestions?

This is absolutely my first foray into Linux, so please make all responses in words of one syllable, and a minimum of Linux geek-speak. :) :)

winmacguy
22-12-2006, 04:04 PM
Hey Tony, unfortunately I can't help you on the Linux department but I would like to say congratulations for getting into Linux.

kjaada
22-12-2006, 04:44 PM
Not sure on an answer despite running linux but not Ubuntu.
But I have to congratulate you on your excellent post explaining the problem.

kjaada
22-12-2006, 04:47 PM
An afterthought to my previous post.It could be to do with permissions on the other boxes if you are not the user on each of them.

Jen
22-12-2006, 05:13 PM
Hmm ... I haven't used samba for a couple of years now, so not sure how much help I can be. For starters, could you please post the contents of your smb.conf.

Also, well done on getting so far with networking the machines especially considering this is your first looksie at Linux. :)

beama
22-12-2006, 05:37 PM
like jen I havent played with samba for a while but theres a nagging thought of users have to be added to password cnf file
my suggestion is to go to the experts on ubuntu http://ubuntuforums.org

SurferJoe46
22-12-2006, 06:59 PM
It was probably an accident in my case, but Samba set itself up and I can access files across both platforms on my home network. XP seems to be happy as well as Mepis doing this.

I cannot "see" the Mepis (Linux) files that are the actual OPSYS while I search in XP, but I can access the files and folders in my shared areas bi-directionally ....but don't ask me how it happened.

Maybe Mepis has something over Ubuntu....

BTW: TY pj for the Ubuntu...I am toying with it right this moment.

PedalSlammer
22-12-2006, 08:52 PM
Use Samba for transfering files but I don't really know how to help you because I'm not good in Linux at all. But it was OK for me transfering files in window.

johnd
22-12-2006, 09:17 PM
I presume there is something else I have to configure on the Linux PC - But what, I have no idea. Any suggestions?


Have you created Samba users? To access resources for a particular user on the Linux PC from a WIndows PC you have two users normally with the same name - the traditional Linux user and a Samba user (this is because of incompatibilities between the Linux and Windows login process).

You should be able to do this from your GUI somewhere - otherwise there is smbpasswd command line tool.

winmacguy
22-12-2006, 09:29 PM
Does this link help?
http://www.linuxheadquarters.com/howto/networking/samba.shtml

heni72847
22-12-2006, 10:47 PM
i've got mine setup and here's a vague vague description from my memory:

i have the same username and password on my linux and xp machines
i setup some sort of 'samba' useraccount that contained my linux machine's username

and..um.. smb.conf
here's mine if you need it


[global]
workgroup = workgroupname
server string = linuxcomputername
interfaces = lo eth0
bind interfaces only = Yes
security = user
log level = 0
log file = /var/log/samba3/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=16384 SO_SNDBUF=16384 IPTOS_LOWDELAY
read raw = yes
write raw = yes
dead time = 15

[XP Share]
path = /mnt/xp
comment = xp share
read only = no
public = yes
browseable = yes

i myself can't remember what each of these suppose to mean
..not all of them anywayz
you probably have to look up some sites if you want answers
i just end up with this config when i read through all these sites and trial and error the configurations
wrote this up when i was using gentoo
just copied it to kubuntu and it pretty much worked..so..yea

hope this helps

Myth
23-12-2006, 08:49 AM
If you don't want passworded access; make sure you have
security = share instead of
security = userin your smb.conf

Incidentally, this is my full smb.conf (including local (to linux) shared printer)

#======================= Global Settings =====================================
[global]
workgroup = workgroup-name
server string = server-name
hosts allow = ip.allowed.xxx. 127.
printcap name = cups
printing = cups
cups options = raw
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
winbind uid = 16777216-33554431
winbind gid = 16777216-33554431
guest ok = yes

[homes]
comment = Home Directories
browseable = no
read only = no

[printers]
printable = yes
printer name = stylus
use client driver = yes
path = /home/printer

[netshare]
path = /home/media-share
read only = no

[doc-share]
path = /home/docs-share/
read only = no
case sensitive = no
msdfs proxy = no
I have set permissions on the various folders locally (for example doc-share, all computers can add, delete,edit files. media-share, all computers can access, copy, but only the linux machine can edit)

Tony
25-12-2006, 11:48 AM
You had it, Johnd - once I added a samba user I got into the ubuntu box from the winxp box after entering the username and password.

So.... next question. How do I get access to the NTFS partitions on the ubuntu box from the WINXP box? From the WIN XP beast all I can see at the moment is folders for "homes" and "tony" (My username). I presume I have to set some permissions etc., but I can't see how to do that. On the ubuntu box, I can see the NTFS partitions, but can't access them there either.

Chilling_Silence
26-12-2006, 08:33 AM
You need to have ntfs support on your linux box. Im not totally familiar with ubuntu but you might need to modprobe the filesystem drivers, or you might need to do a kernel recompile?

I was under the impression that you could just mount the filesystem in Ubuntu...

Once you've done that, just add a share in your smb.conf

My setups similar to Tazz with Security = share set. See here: http://nzlinuxfaq.orcon.net.nz/

kjaada
26-12-2006, 09:01 AM
Not sure on the latest versions but I had Ubuntu 6.1 set up with a seperate fat 32 partition and kept any files I wanted to access from XP or ubuntu in there.
Also used Open office in both systems and had a macro to save any updated files to both the home folder and the common folder.

Tony
26-12-2006, 08:56 PM
You need to have ntfs support on your linux box. Im not totally familiar with ubuntu but you might need to modprobe the filesystem drivers, or you might need to do a kernel recompile?

I was under the impression that you could just mount the filesystem in Ubuntu...

Once you've done that, just add a share in your smb.confI have to do what where now? See the comment at the end of my original post.:) :confused:

Chilling_Silence
26-12-2006, 10:25 PM
run this from the command line:
cat /proc/partitions

From here, it'll tell you the linux device "references" for your HDD. All hardware has a reference in the linux filesystem in /dev such as:
/dev/hda1 = first partition on first hdd in your PC
/dev/hdb3 = third partition on 2nd hdd in your PC
/dev/dsp = your soundcard

So what the above command you're running tells you is your HDD partition references in Linux (Which you might already know / have guessed by reading this post)

From there you need to become root (Administrator) by running:
su -
*enter root password*

Dont forget that (almost) everything in linux is case-sensitive ;)

Now, if it doesnt give you a password error then you've successfully escalated your privaleges within that terminal window to that of the root (Super) user. Now you need to make a folder for you to access your HDD partition from, by typing:
mkdir /mnt/windows

Now, you need to 'mount' it to the rest of your filesystem so the contents all show up by running:
mount /dev/hda1 /mnt/windows
replace the /dev/hda1 with whatever came up when you ran 'cat /proc/partitions' (its probably hda1)

If it gives off an error or you get stuck, just post back and we'll get you sorted

Cheers


Chill.