PDA

View Full Version : How to install Win2000 on the new laptop



grantli2002
21-12-2006, 12:25 PM
I noticed something interesting. The new laptops of these days comes with WinXP. I don't like WinXP and want to install Win2000. I use Win2000 CD to boot and go to the install screen. After the initial loading of those drivers, I get to the stage of press "enter" to install the windows 2000.

Right when I click "enter", the new screen says: hard drive not found (stuffs like that).

I know the hard drive is there because if I use the winxp disk, it can find the hard drive.

So does anyone know how to install win 2000 on this crazy laptop?

digikiwi
21-12-2006, 12:29 PM
Are you doing a clean format of the hard drive first?

Nomad
21-12-2006, 12:34 PM
I think windows installers have trouble with a hard drive that is in a particular fat system .... I think try to fdisk the hdd with a bootdisk and then strip it right down ... if not work then try to set it up and then format as fat32. You can always use install or later in win2k to convert to ntfs. Go around like a donkey that's what I do and when it works you can stop holding your breath :D This thing also encountered with the PCs with RAID support even with one HDD sometimes I need to swtich RAID on ....

SolMiester
21-12-2006, 12:38 PM
If its a new laptop, it might be using SATA drive which Win2k, will not know about. XP even has fun with these drives sometimes.
So, use have to have the SATA drivers for the disk ready and press F6, just as the setup loads into RAM the files neccessary to start the install, look out for the prompt at the bottom of the screen, just after the boot to CD. 'Press F6 to load RAID drivers etc'. Once the setup finished, it will prompt you to then load the diskette with your SATA drivers so it can then recognise the drive to install on.

winmacguy
21-12-2006, 12:41 PM
Putting Win2K on a new laptop (effectively a 6 year old OS) says a lot for the stability of Windows 2000 but doesn't stand Windows XP or Vista in very high regards. :confused: Doesn't say much for an OS that is supposed to improve with each new release.:rolleyes:

CYaBro
21-12-2006, 12:42 PM
You might need to get SP4 for Win2k and make a slipstreamed CD and try again.
If it is already a SP4 CD then as solmiester said you most likely need the SATA drivers.
Problem with that is your laptop most likely doesn't have a floppy drive.

grantli2002
21-12-2006, 03:38 PM
Thanks for all of your suggestion. I tried Win2000 sp4, format the hard drive, didn't work. I think it should be the SATA driver. The problem is: I don't have a floppy drive for this laptop. Is there any solution other than purchase a floppy?

Nomad
21-12-2006, 03:55 PM
Burn a CD or DVD with bootfiles that becomes your boostdisk.

pctek
21-12-2006, 04:18 PM
Why? Theres not much difference. And then you are going to have to do all the drivers and stuff as well.
And its probably got a hidden partition with its recovery on it.

Nomad
21-12-2006, 05:17 PM
Why? Theres not much difference. And then you are going to have to do all the drivers and stuff as well.
And its probably got a hidden partition with its recovery on it.

At boot up it may say press F12 or F8 or what .. to get to something restore. That is likely to be the windows restore, likely if you were not given windows on a CD. So you can try that. If you install windows on top, it may take out that option which may be difficult in restoring that function or even backing up that hidden partition window files which you have bought (legally).

If it was me, I would restore winXP and get my CD-Key off it. And then install win2k.

Murray P
22-12-2006, 12:59 AM
Why not dual boot win2k with XP. Make Win2k the preferential OS to boot, if that is your wish.

You can slipstream the sata drivers with the win2k CD, along with any others you might need, SP4 (as mentioned) and any other updates like the Security Rollup updates (saves having to apply them individually).

jontravolt
29-12-2006, 09:45 PM
i've the same problem as u...
then i just disable the SATA omn boot setting then its ok...
go try...