PDA

View Full Version : Networking to PC's



yorkshirekid
07-11-2006, 09:48 PM
I have a laptop [XP Home] and a desktop [XP pro]. Both are linked through a router via ethernet cable. Both are in a Workgroup. Both can ping each other. Both have different names. Through Entire Network both machines can see each other. Desktop can see the shared folder on the laptop and can access a file in there ok. The laptop cannot access the desktop. I get Access is Denied message. What am I doing wrong?

developer
07-11-2006, 09:53 PM
Is file sharing for Microsoft network enabled?
Are you running a firewall?

linw
07-11-2006, 10:19 PM
An Access Denied message indicates a credentialling problem. Your desktop will not allow a guest login to access its resources.

First step, check this registry entry:-
Quote...
This problem is caused when the "RestrictAnonymous" LSA registry value in XP gets changed from its default value of "0" (disabled) to "1" (enabled). This registry value can be located by opening regedit and going to:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa]

A more user friendly way of adjusting this same setting is to go to Control Panel --> Administrative Tools --> Local Security Policy --> Local Policies --> Security Options. Make sure the following setting is set to "Disabled":
-- Network access: Do not allow anonymous enumeration of SAM accounts and shares

--
This is an excellent diagnostic site which is good to bookmark http://www.techbuilder.org/recipes/59200376

Let's know how you get on.

Speedy Gonzales
08-11-2006, 07:21 AM
The workgroup name for both should be the same not different.

And if one has been configured to obtain an ip automatically, thats another reason why its not working. Manually enter an ip in. If u use XP, dont use the Network Wizard.

yorkshirekid
09-11-2006, 10:21 PM
Thank you all - PROBLEM SOLVED.
The resolve by 'linw' was the answer. Apparantly it is a well know problem and I found a lot of material offering the same advice.

Thread Closed